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I. Glossary | Terminology

Alpha channel

An alpha channel is a part of the image data that describes each pixel’s level of
opacity or translucency. Contrast that with the other data, which describes light and
color. Many people think of an alpha channel as a transparency mask. However,
that can lead one to think of it as rather binary - opaque or transparent - whereas
most often an alpha channel has at least 256 levels.

Aspect ratio

Aspect ratio is how the width of a rectangle compares with its height. In other
words, wide or tall, and by how much? This is typically expressed as a fraction of
width over height. For example, if a rectangle is twice as wide as it is high, we can
say iti has a 2:1 aspect ratio. This can get complicated in video where pixels
themselves can have an aspect ratio that is distinct from the display aspect ratio.
For example, SD NTSC video has a resolution of 720x480 but can be either 4:3 or
16:9 display aspect ratio neither of which are square pixels! Modern video
standards such as ATSC and UHD avoid using non-square pixels such that the
common HD resolution 1920x1080 reduces mathematically to 16:9, which is also
the most common video aspect ratio in use today.

B frames

A Bi-directional predicted (B) frame is a frame of a video that uses the motion-
compensated differences between itself and both the preceding and following
frames to specify its content. By doing so they use fewer bits to store the
information than both I-frames and P-frames.

Bitrate

Bitrate refers to the quantity of data (or number of bits) per unit of time. Most digital
audio and video formats use compression to save space, and the compression
ratio will vary. For instance, a clear blue sky contains relatively little information and
will generally compress well, while a more complex scene will compress less well.
Bitrate is also affected by other factors such as the compression algorithm used
and the quality level chosen.

Clip

In video editing, a clip refers to a segment of video footage or audio that is a
distinct unit within the overall project. Clips can vary in length and content, ranging
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from just a few frames to several minutes long. They are the building blocks of a
video project and can be manipulated, arranged, and edited together to create the
final product. Clips can be sourced from various recordings, imported media files,
or generated within Shotcut itself in “Open Other...” (ex.: Color clip, Text clip,
Animation (Glaxnimate) clip, etc...). Additionally, clips may contain both video and
audio components, or they can be exclusively video or audio depending on the
nature of the project. Clips are primarily used in the Timeline for editing but can
also be utilized in the Source panel and in the Playlist for previewing and
organization.

Codec

A codec comprises two components, an encoder and a decoder, hence the name.
Examples of video codecs are H.264, H.265, VP9 etc... Codecs use various
technologies to compress data. The compression can either be lossless, in which
case decoding the data will produce exactly the same data that was encoded, or
lossy, in which case decoding the data will lose some of the data that was encoded.
The higher the compression the more data is lost. In general the use of lossless
codecs result in much larger files than lossy ones. Some codecs are more efficient
than others in the amount of data they need to produce videos of equivalent quality
e.g. H.265 produces smaller files than H.264 at equivalent quality; however, the
more complex methods needed to do this usually mean that they take longer to
encode and decode the video.

See also Prologue | Codec Wiki

Colorspace

Color space is about how color and light is represented especially numerically. In
video and computer images, the two most popular systems of organization are
RGB and YUV (or Y’CbCr). This is a complicated subject area; you can read more
on Wikipedia.

Deinterlacer

A deinterlacer is an algorithm to convert interlaced video to progressive scan. See
below for definitions on these two terms.

Field order

Interlace video consists of two fields per frame. This term describes which field
appears before the other in storage and/or display.

GOP
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A GOP, or Group Of Pictures, specifies the order in which intra-frames (I-frames)
and inter-frames (B- and P-frames) are arranged. The GOP is a collection of
successive frames within a coded video stream. Each coded video stream consists
of successive GOPs, from which the visible frames are generated. Encountering a
new GOP in a compressed video stream means that the decoder doesn’t need any
previous frames in order to decode the following ones, and allows fast seeking
through the video. The GOP structure is often referred by two numbers, for
example, M=3, N=12. The first number tells the distance between two anchor
frames (I or P). The second one tells the distance between two full images (I-
frames): it is the GOP size. For the example M=3, N=12, the GOP structure is
IBBPBBPBBPBBI.
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GUI

GUI is short for Graphical User Interface. As opposed to a Command Line Interface
(CLI), which enables users to interface with application only by typing commands, a
GUI consists of various widgets (graphical elements such as buttons, scrollbars,
color-pallettes etc.) that enable the user to control the application and receive
feedback to enable them to make decisions on how next to proceed.

| frame

An Intra-coded (I) frame, also called a keyframe (not to be confused with keyframes
used for animating filter parameters), is a frame of a video that is coded
independently of all other frames. Consequently they use the more bits than B-
frames ans P-frames to store the information. Each GOP begins (in decoding
order) with this type of frame.

Interlace

Interlace is a simple form of video compression that uses two half vertical
resolution frames to represent a full frame. Basically, you can double the refresh
rate for the same data rate. Each half vertical resolution image is called a field.
Typically the fields are interleaved in storage and then displayed one after the other
on play back by skipping every other line.

Interpolation

Interpolation is the computation of values based on neighboring values. With
respect to Settings, it easiest to think of this as the quality level when changing the
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size of an image. Interpolation is also a term used for animating parameters in
Keyframes.

Keyframe

A keyframe defines a specific value or set of values at a specific point in time. The
term is used when talking about animating parameter values in Keyframes. It is
also used in temporal video compression (so-called delta or P- or B-frames).

Metadata

Metadata is data about another data. In the context of multimedia, the media data
(audio/video) is the core data, and all other data in the file is metadata. There can
be metadata about the media attributes such as resolution or number of audio
channels. And there can be metadata about the context of the media file such as its
creator, creation data, title, etc.

MLT

MLT is another open source software project that is the engine of Shotcut. Shotcut
is primarily the user interface running on top of this engine. This engine provides
some effects of its own, but it also uses other libraries such as FFmpeg, Qt,
WebKit, freiOr, lads, etc.

P frame

A Predicted (P) frame is a frame of a video that uses the motion-compensated
differences between itself and the preceding frame to specify its content. By doing
so they use fewer bits to store the information than I-frames, but more than B-
frames.

Progressive

In video, this refers to a scan mode where (“scan” refers to old tube-based TV
technology where a cathode ray draws video by drawing lines) each frame of video
Is a whole picture from a single point in time. This is the opposite of interlace.

Resolution

Display Resolution is the actual pixel size of video and images. Example sizes:
3840x2160 (4k), 1920x1080 (HD), 1280x720 (HD), 720 x 480 (SD), 1080x1380
(Vertical)
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Ripple

Ripple means that an operation can affect the clips on the timeline that are later or
after the clip being changed. For example, a ripple delete not only removes the clip
but also the space it occupies. This requires changing the start time of all of the
following clips.

Sample rate

Sample rate refers to how many times per second a sample is taken of the audio or
video. For instance, in the real analog world, a car driving down the street moves
continuously, but a video of that consists of individual snapshots taken at regular
intervals. If you could slow down time and watch the car, the real world car would
still move smoothly; however, the video would show the car jumping from one
position to another. Common sample rates for video include 24, 25, 30, and 60
frames per second; common sample rates for audio include 44,100 and 48,000
samples per second.

Scrubbing

Scrubbing is seeking by clicking some object and dragging it. Typically this is the
play head in the player or timeline. But it can also refer to simply rewind and fast
forward playback through media.

Skimming
Skimming is seeking based on the horizontal position of the mouse over the video

image or timeline. You press and hold the shift |+ Alt keys in Shotcut to
enable skimming.

Snapping

Snapping is a setting on the timeline. Aids in sliding two clips together on the same
track with no gap in between them.
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Scan mode



Scan mode indicates whether video is progressive or interlaced - see related
definitions above.

Threads

Threads are a software programming mechanism to let multiple things occur at the
same time. Most CPUs now consist of multiple execution units typically called
“cores.” Often, these cores support a CPU-based “thread,” which you can think of
as a light core (not completely parallel). While it is important that your operating
system let multiple things run at the same time to use these CPU cores and
threads, it also important that Shotcut run things (i.e. parallel processing) at the
same time because media decompression, processing, and compression is very
computationally heavy. You can learn more about how Shotcut uses multiple cores
and threads in the FAQ.

Timecode

Timecode is a way to represent time numerically. Shotcut uses a standard called
SMPTE from the Society of Motion Picture and Television Engineers. It is a display
of the running time of video that is frame-accurate yet easier for humans to
understand than pure frame count. It shows hours, minutes, seconds, and frames
in the format HH:MM:SS:FF. On many video modes that use a non-integer frame
rate (e.g. 29.970030 or 30000/1001 fps), the semicolon ( ;) is the delimiter
between seconds and frames to indicate that it is using drop-frame timecode. Drop-
frame is a technique to make the timecode follow the real time over long durations.
For 30000/1001 fps, drop-frame subtracts two frames every minute except every
tenth minute.

Ul

Ul is short for User Interface. This is the mechanism whereby users interact with
the application (Shotcut). The goal of this interaction is to allow effective operation
and control of the application from the human end, while the application
concurrently feeds back information that aids the user’s decision-making process.

VUI

VUI is short for Visual User Interface, In the context of Shotcut this is an interface
that appears in the preview area of the screen when certain filters, like the Text:
Rich filter, or the Size, Position & Rotate filter are active. The VUI enables users to
manipulate the parameters by dragging handles and/or typing directly in the preset
window rather than changing the parameters manually in the filters panel.

XML
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XML is a text format that is designed to be both human and machine readable and
writable. It is standardize, structured, and extensible - the X in eXtensible Markup
Language. There are many dialects of XML, and when one video editor says it
reads “XML" it does not mean it can read the XML that another video editor can
export. They need to be the same kind of XML. Shotcut reads and writes MLT XML,
but at this time it can only fully understand the MLT XML that it writes.



I. Installing Shotcut

Shotcut supports Windows, macOS, and Linux. Here’s how you can install it on
each platform:

Windows

1. Go to the Shotcut download page.

2. Choose the appropriate installer for your system (e.g., Windows 10/11 on
Intel/AMD or ARM CPU)

3. Download the installer and run it.

4. Follow the on-screen instructions to complete the installation.

Alternatively, you can purchase it for a small price in the Microsoft Store. It is single
lifetime purchase, and doing so helps fund the development. In return, you get
automated updates without needing to re-download and install.

macOS

1. Go to the Shotcut download page.

2. Select the macOS version compatible with your system (e.g., macOS 12+ or
older versions).

3. Download the app bundle and open it.

4. Drag the Shotcut app to your Applications folder.

Linux

1. Go to the Shotcut download page.

2. Download the Linux portable tar or Applmage file.

3. For the portable tar, extract the archive and run the shotcut shell script.
4. For the Applmage, make it executable and run it directly.

Alternatively, you can install the Flatpak (via Flathub), the Snap, or a package from
your Linux distribution. Often, the software manager in your desktop environment
makes some of these options available to you.

Please be aware that the portable, Applmage, and Snap are all the same build
based on the glibc version in Ubuntu 20.04 and thus stuck to using an older version
of Qt. The Flatpak or distribution package works better on the Wayland graphics
subsystem. Also, the Flatpak or distribution package supports ARM processors
whereas the portable, Applmage, and Snap do not.
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I. Launching Shotcut

Windows

The installer puts the app icon in the Start menu only (not on the desktop). Use the
Start menu or search for it. When using the portable version, you must extract the
zip file. You should not open the zip file as a virtual folder in Explorer and run it from
there. In Explorer, navigate to where you extracted the Shotcut portable zip file,
locate shotcut.exe and double-click it. If you want to create a shortcut on your
desktop, right click shotcut.exe and choose Send to > Desktop from the context
menu.

macOS

It depends on where you drag the app out of the downloaded DMG file, but usually
it is Applications in Finder. If you did add it to Applications, then you can also find
it in Launchpad and search it in Spotlight. After it starts, right-click the app icon in
the Dock, and choose Keep in Dock if you want to launch it from there in the
future.

If you want to run it from the command line run open -a shotcut or manually run the
executable at /applications/Shotcut.app/Contents/Mac0S/shotcut per the app nimble
standard. To run a version not installed to Applications atthe command line, use
open /path/to/Shotcut.app . TO run another instance of Shotcut at the same time, use
open -na shotcut OF open -n /path/to/Shotcut.app.

Linux

It depends very much on which app package you used, the desktop environment
you use, and sometimes the distribution.

If you are using the portable tar version, first extract the tar file. Then, in your file
manager, double-click the icon in Shotcut. That does not always work. In some
desktop environments, it will only work on the Desktop. In others, it does not work
at all. In GNOME and extracted to the Desktop, you might need to right-click the
app icon and choose Allow Launching. If the file manager does not launch
Shotcut, open the shotcut.app folder, and try double-clicking the shotcut shell
script. Do not try to run bin/shotcut directly.

If you are using the Applmage, simply make it executable. Then, double-click the
file to run it.

If you are using the Snap, it depends on your distribution. On Ubuntu, after
installing, Shotcut will be in your menu or list of programs and in your $paTH to
simply run shotcut at the command line.
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If you are using the Flatpak, after installing, it should be in your menu or list of
programs. At the command line run flatpak run org.shotcut.Shotcut . The upper
case s is important.



I. Quick Start Guide

Quick Start Guide on how to use
Shotcut

New Project

Option Description

Projects This is where Shotcut will look for your file for editing by default, and
Folder where it will save videos when you export them.

Project  This creates a sub-folder within the named Projects folder, and creates
Name the project save file when you hit start.

Important to set this before beginning your project. Leaving this in
Automatic may not produce the results you desire. Example: If you want
to Export a HD 1080p 30 FPS video, set it here first.

Video
Mode

Project File Saves

Shortcut Shortcut

Function Description o
Win/Linux  macOS

Saves to a project MLT file. If already saved command |+
Save . , : ctrl |+ S
previously, updates opened MLT project file. S
Allows you to choose a new file name (and/or il
SNl
' ject. ctrl |+
Save As |OC?.'[IOI’I) _for your current prol_ect Open r —
project will take on the new file name and/or | shift + s <
file location.
Performs Save with the ability to make a
Backup & backup copy of nan!ed.mlt t(.) named yyyy-mm- TERINT option +
Save ddThh-mm-ss.mit While keeping named.mit +le command |+
active. Must perform function twice to get S
date/time saved file.
Editing

There are three modes of editing available within Shotcut.

Modes Description

The most popular. Has multiple Video/Audio tracks (or one). Needed for
transitions and voiceovers. No need for the Playlist.

Arrange clips in order, apply filters if needed, and then export. No need for
the Timeline.

Timeline

Playlist
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Modes Description

Source

Just a single file. Trim if needed and/or apply filters as needed, then

export. No need to use the Playlist or Timeline.

Exporting
Options Description
Presets Choose a preset that best suits your export needs. If you are a
beginner Stock — Default is your best choice.
You can export from Timeline, Playlist, Source, or Marker. If you have
From no clips in the playlist or the timeline, or no markers set, these options
will not appear.
Hardware Graphics card encoder may aid with exporting (Read FAQ). Click
Configure, then Detect to set. If nothing is detected then your graphics
Encoder . .
card is not compatible.
. Prompts you to name your video export file. Once named, click Save
Export File . . -
and export will start. Do not close Shotcut until the export finishes.
Reset Resets all options back to Default.
This is where you will find all of the advanced options such as Parallel
Processing, Codec, Rate control, CRF, Bitrate, etc. Warning: The
Advanced

Advanced moded does not prevent creating an invalid combination of
options!

If you're a beginner at video editing follow these steps:
To export with the Default settings (frame rate will match your Video Mode)

1. Click on the Export icon at the top, right.
2. | Export File

3. Name your video file.

4. Wait for Shotcut to finish exporting.

After the export is done, you can double clock on the job to play your finished video
within Shotcut.

The longer the video project, amount of filters, and computer specifications will all
be factors in how fast your video export takes to complete.

Troubleshooting

At times exporting may fail. Video filters may not perform the way you expect them
to. Or some other issue that you may not understand. Video editing is a very
complicated task for anyone and their computer. Do not be afraid to ask for help.

o First start by reading the FAQ (Frequently Answered Questions). Several issues
are addressed in there.
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« Search the forum for the issue you'’re having. If you can'’t find the answer, feel
free to make an account and post your issue. The forum is made up of many
volunteers who also use Shotcut.

¢ Look through the Tutorials section of the forum.

e Watch Tutorial Videos specifically chosen by the developers.
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I. Project Management

Introduction

Shotcut does not provide very much in the way of project management at this time.
Rather, you are required to manage many aspects of this. There are a few things
you should know:

e Shotcut saves to a project file in a text format called MLT XML. (Technical detail
on that format can be found here.)

e The project file does not contain any of your media. Rather, it only /inks to your
media files by file system path and name.

¢ There are 3 different kinds of projects:

1. Clip
If you put anything in Playlist or Timeline and you open a media file (or
generator), then you can save it as a clip-only project along with trimming
information as well as filters and their keyframes.

2. Playlist
If you add some things to the Playlist but not the Timeline, then you have
saved a playlist-only project.

3. Timeline
This is what most people use, but keep in mind it is not necessary to use the
timeline. Any of the above can be exported as a final audio/video file!

Project Folder

Shotcut supports the concept of a project folder, which is optional. A project folder
iIs when you create a file system folder for your project and you put project file in
there along with whatever companion files get created as well as media files if you

choose.

When Shotcut first starts (or after you choose File > New or File > Close), this
view appears in the area for the Source player:

New Project

Projects folder fUsers/ddennedy/Movies

Project name

Video mode HD 1080p 60 fps

Automatic means the resolution
and frame rate are based on the
first file you add to your project. If
the first file is not a video clip (for
example, image or audio), then it
will be 1920x1080p 25 fps.
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You use this to create a project folder. When you use it, Shotcut creates a folder on
the file system with the name in Project name within Projects folder. Then, it
saves an empty project with the name in Project name followed by .mit.
Thereafter, companion files that Shotcut creates are saved automatically into the
project folder instead of requiring you to name them:

o Stabilize video filter
e Text: HTML video filter
* Properties > Reverse

We encourage you to store all or most of the media files that you use in the project
in the project folder. However, Shotcut does not provide a way to copy or move the
files into there automatically at this time.

Of course, you can skip using this because it is entirely optional, and the view goes
away as soon as you open something. Also, you can create a project folder
manually by not using this, but Shotcut then does not provide the automatic naming
and placement of the companion files.

Relative vs. Absolute File Names

Shotcut saves MLT XML with file paths and names rather than embed any media.
So, it can save these paths in full (i.e. absolute) or partially (i.e. relative). On
Windows, a full path begins with a drive letter such as c: . On Linux and macOS, a
full path begins with a slash (/). Shotcut saves with a relative path if the file is in
the same folder as the .mit project file or a sub-folder of this folder. It saves with
an absolute path otherwise. This means your project file can be a mix of the two; it
is determined per file.

There are different schools of thought around which to use. If you use absolute
paths, you can keep media where you have it already organized and freely move
the project document without any impact. If you use relative paths, you can put
everything into a single folder (optionally with sub-folders), and freely move around
the project folder. Take your pick; Shotcut does not force you into either one.

Example : Relative File Structure

D:/Shotcut/ZProject (File Folder)
D:/Shotcut/ZProject/Zproject.mlt (Current project MLT file)
D:/Shotcut/ZProject/BugV.png (Source Location)
D:/Shotcut/ZProject/Square/BugS.png (Source Location)

When saved, the MLT file has the Source file locations as such:

e BugV.png
e Square/BugS.png



You can copy the file folder D:/Shotcut/Zproject which is helpful for sharing with
people or to another computer. Also useful for backing up saved projects for later
use.

Example: Absolute File Structure

o D:/Shotcut/XProject (File Folder)

¢ D:/Shotcut/XProject/Xproject.mlt (Current project MLT file)
¢ D:/Shotcut/ZProject/BugV.png (Source location)

o D:/Shotcut/ZProject/Square/BugS.png (Source location)

When saved, the MLT file has the Source file locations as such:

o D:/Shotcut/ZProject/Bug Vertical.png
¢ D:/Shotcut/ZProject/Square/Bug Square.png

The folder of D:/Shotcut would need to be copied for sharing with people or to
another computer. If you tried to share XProject.mlt along with your source files
individually to another person they would be presented with this dialog box.

Autosave

Autosave is always working and cannot be turned on or off. It does not save to your
existing project. Rather, it saves to a hidden file in your app data directory. Then, it
is checked when you reopen a project. It is only meant for crash recovery. Every 60
seconds it checks if the project is modified (the window title bar shows an asterisk
except on macOS which uses the red dot) and saves to the backup file. When you
reopen a project after a crash, if the backup is found, Shotcut prompts you to use it:

Shotcut X

91) Auto-saved files exist. Do you want to recover them now?

Once you save successfully - including save at exit when prompted, - the backup
file is removed. This also works for projects that were never saved - an Untitled
project. Except in that case, simply restarting Shotcut will attempt to locate a
backup and prompt. Otherwise, for a named project, you need to open the project
for it to check.

Missing Files

Shotcut presents a missing dialog box when you open the project if a file has been
moved or deleted or file folder has changed name. This allows you to still use your
existing project, but you must tell Shotcut where to find your source file.



Double click each item that's missing as assign the source files a new location.

There are missing files in your p

Replacement

uare\Bug Sguare.png

Search in Folder...

One files have been found, then click OK.
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Il Adding Media

There are many ways to import media files in Shotcut.

Open File

¢ From the main toolbar or from the File menu, click on Open File.
Or use the keyboard shortcut Ctrl+O (comman+0 on macOS).

Eile Edit View Player Settings Help

= & H O C

Open File  Open Other, Save  Undo

File Edit View Player Settings Help
MNew Ctrl+N

Open File... Ctrl+0

Open Other... Ctrl+5Shift+0

+ Navigate to the folder containing the media file (or files) you want to import.

o Select your file(s) and click on the Open button.

If only one file is opened, it will automatically be added to the Source panel. From
there it can be dragged to the Playlist, or to the Timeline.

If multiple files are opened, they will all be added to the Playlist. The first file in the
list will open in the Source panel.

NOTE: Open File cannot be used to import a MLT XML file as clip.

From the Playlist

The Playlist panel can be used to import files in a project, including MLT XML file
as clip.

» At the bottom of the Playlist panel, click on the Add files to playlist button.
= +=[Hv BE

Playlist  Filters Properties

+ Navigate to the folder containing the file (or files) you want to import.
¢ Select your file(s) and click on the Open button.

The file(s) will be added to the Playlist. From there, any or all of them can be
moved to the Timeline when needed.


https://forum.shotcut.org/t/source-vs-project-player/12576
https://forum.shotcut.org/t/about-the-playlist/12951
https://forum.shotcut.org/t/about-the-timeline/12952
https://forum.shotcut.org/t/open-mlt-xml-as-clip/12946
https://forum.shotcut.org/t/open-mlt-xml-as-clip/12946
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Drag from a folder

You can add files (including MLT XML file as clip) to your project by dragging them
from a folder

¢ Open the folder containing the file(s) you want to import.

e Select the file(s).

o Grab and drag the file(s) in the Playlist or in the Timeline...

¢ You can also grab and drag the file(s) in the Source panel.
If you drag multiple files at once in the Source panel, they will all be added to
the Playlist, and the first file in the list will open in the Source panel.


https://forum.shotcut.org/t/open-mlt-xml-as-clip/12946

I. Trimming Clips

In video editing, trimming is the process of adjusting the start (in-point) or end
(out-point) of a video or audio clip to shorten or lengthen its duration. This is
different from moving the clip on the timeline; it's about changing the content and
duration of the clip itself.

While some software uses a dedicated trim tool, in Shotcut you perform trimming
directly within the Timeline or Source player using controls and keyboard
shortcuts.

A good workflow involves using the Source player to prepare clips before adding
them to the timeline. This helps you select and trim the best parts of your footage
first, which saves time and makes the editing process on the timeline more efficient
and less disruptive.

Source Player

You can open a clip into the Source player a number of ways:

¢ File > Open (menu, main toolbar, shortcut)

» drag from a file manager & drop onto the player
¢ double-click in:

o Recent

o Playlist

o Files

00:00:00 |00:00:10 | T |00:00:20

M 44 » > M DO-m-H-aw)

00:00:17.917 5 / 00:00:28.500 00:00:05.417 / 00:00:17.708

Source Project

Drag [i] to change the in-point.
Drag [:l to change the out-point.
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Alternatively, play and seek within the clip to position the playhead: §d
Then, press | 1 to set the in point and/or | o | (letter o, not the number o) to set
the out point.

As you are trimming the bottom, right corner of the player shows some time
values. Remember, there are tool tips through the application. Hold the mouse a
couple of seconds over one of the time values to reveal its purpose: In Point /
Selected Duration. Note that, technically, duration is not the out point. If you
actually move the playhead to the out-point, the time field in the bottom, left corner
shows the out point. However, more often the duration of this sub-clip is more
interesting than the out point.

Sub-Clip and Playlist

A sub-clip is a new, shorter clip created from the larger, original media file. Instead
of keeping the entire clip, you create a sub-clip that contains only the specific,
trimmed segment you want to use. This is a common practice in the Source player,
where you set the in-point and out-point of a desired section and then add it to the
Playlist. Sub-clips are useful for organization, as they allow you to work with
manageable, focused pieces of a long recording without affecting the original
footage. You can have multiple sub-clips from the same source in the playlist or
timeline. You can also add Filters to the sub-clips while preparing it in the Source
player.

Timeline

Clips on the timeline also have interactive controls for trimming. Move the mouse
cursor to the left edge of a clip, and you see a green bar appear:

Drag it to trim the in point.
Move the mouse cursor to the right edge of a clip, and a red bar appears:
N

Drag it to trim the out point.
You can also use the ' 1  and o keys to on the timeline.

Regardless of the approach, in the timeline the behavior also depends on
something called Ripple, which is a fundamental concept in video editing and
especially in Shotcut. For the interactive mouse control, ripple is used when this
timeline toolbar button is active:

When the button is not active, you can hold ' shift | while trimming to do a ripple
trim.

There are ripple variants of the keyboard shortcuts:


https://forum.shotcut.org/t/glossary-terminology/12413#p-39168-ripple-21

e shift + 1 | for Ripple Trim Clip In
e shift + o  for Ripple Trim Clip Out

Another thing to note about using the timeline keyboard shortcuts is that you do not
need to first select the clip. It operates on the topmost clip under the playhead. But
an important consideration is that shortcuts on the timeline cannot increase the
duration. It can only decrease by removing more from the beginning or end.

Roll Edit

Aroll edit is a specific type of trim that adjusts the cut point between two adjacent
clips on the timeline simultaneously. The defining feature of a roll edit is that it
shortens the end of the first clip and lengthens the beginning of the second clip by
the exact same amount. This means the total duration of the two clips—and your
entire video sequence—remains unchanged.

You use a roll edit to refine the timing and rhythm of a transition without affecting
the rest of your timeline. It allows you to shift the “moment of the cut” to a more
effective point, such as aligning a visual cut with a beat in music or a specific word
in dialogue.

In Shotcut, hold | ctrt | when trimming to perform a roll edit.

Scrub While Dragging

“Scrubbing” is essentially another word for seeking, but it is a bit more about
playback than simply going to a point in time. Think of it as rapidly seeking short
distances while updating the video preview. This can be useful when trimming or
doing a roll edit. In Shotcut, this is on when the timeline toolbar button is active:

Otherwise, when it is off, you can still kind of see where you are inside the clip by
viewing the thumbnail on the timeline.



I. Three Point Editing

Three-point editing is a technique used in video editing to manipulate footage by
using three reference points: an in-point, an out-point, and a cut point. It's
particularly useful when you need to extract a segment from a source clip and
insert it in your Timeline. The segment can also be inserted into to the Playlist.

The Three Points
In Point

This is the starting time of the segment you want to insert into the Timeline. In the
Source player, you set the in-point at the specific frame where you want the clip to
begin.

r In-point

The keyboard shortcut used to set the in-pointis 1 |.

Out Point

This is the ending time of the segment you want to insert. In the Source player, you
set the out-point at the specific frame where you want the clip to end.

Out-point =l

The keyboard shortcut used to set the out-pointis ' o ' (the letter o, not the number

0).
Cut Point

This is the location in the Timeline where you want to insert or overwrite the new

clip. To set the cut point, move the playhead at the frame where you want the new
clip to be inserted. If there is more than one track in the Timeline, also make sure
to change the current track to where the segment needs to go.

Edit

The last step is to execute the edit operation: Paste (insert) or Overwrite. Drag-n-
drop is not recommended but still possible. With drag-n-drop the playhead is only a
visual cue and not as precise.
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I. Undo and Redo

The Undo and Redo functions in Shotcut are crucial for managing your editing
workflow efficiently.

¢ Undo: 'D The Undo feature allows you to revert the last action you performed.
Whether you added a clip, adjusted the filters, or made a cut, you can easily

reverse the change by clicking the Undo button (or using the keyboard shortcut
ctrl + z ). This can be repeatedly used to step back through multiple actions.

* Redo: C' The Redo function is the counterpart to Undo. If you have undone an
action and decide you want to keep it, the Redo button (or the keyboard shortcut
Ctrl+| v | on Windows or | ctrl + shift [+ z on Linux and macOS) will reapply
the most recently undone action. Like Undo, you can use it repeatedly to step
forward through your action history.

» History Panel: Shotcut also features a History Panel, which provides a visual
timeline of your editing actions. This panel allows you to see and navigate
through your actions quickly, making it easier to manage complex edits. Access
the History Panel by going to View > History.

e There is a default maximum of 50 items for the history, but it can be increased
using the configuration key undoLimit .


https://forum.shotcut.org/t/history-panel/12944
https://shotcut.org/notes/configuration/
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I. Trimming Filters

Trimming a filter means you can choose when the filter effect starts and ends
independent of the clip’s starting and ending time. Obviously, if the filter is applied
to a clip, it must still be within the clip’s time frame. If the filter is applied to a track,
however, it can be truly independent. Filter trimming takes place in the Keyframes
panel:

Wildlife.wmv

Video
¥ Brightness

100.0 %

Properties  Playlist  Filters  Export

Keyframes

r
00:00:00
T -
Brightness i - S8 e

The first row of the Keyframes panel shows the clip with its thumbnails and audio
waveform. Drag the left, green edge to change when the filter starts. Drag the right,
red edge to change when it ends. Here is how it looks when both ends of the filter
have been trimmed:

The dimmed portion of the clip reflects when the filter is inactive.

With version 19.10.20, toolbar buttons and keyboard shortcuts for filter trimming
were added.

These are the toolbar buttons:


https://forum.shotcut.org/uploads/default/original/2X/4/44d535efb80c42209cfae6f2996c8680905839f4.png
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Brightness

These are the keyboard shortcuts:
[ | to set the filter start

1 | to set the filter end

Using these buttons and keyboard shortcuts will speed up the process of precise

filter trimming considerably. Simply place the playhead at the desired point and
press the filter start or end button/keyboard shortcut.

Keyframes

||:I|:I :00:15

Q0:00:05
Brightness -
M




I. A Guide for Blind Users

The timeline is the least accessible part of the Shotcut Ul. You do not need to use
the timeline in Shotcut. It is possible to make single-clip-only and playlist-only
projects in Shotcut. | think we should start there. In a clip-only project, you can
open a single clip, trim and filter it, and then export it. For this, you only need
CtrlI+O to open a file into the Source player. Then, you can refer to all of the
keyboard shortcuts under the player section. When you use left and right arrow
keys here you should hear little audio blips as long as “Scrub Audio” is turned on in
the Settings menu. If you still do not hear the audio, then this feature is
incompatible with the format or encoding of some files. In the Properties panel
there is a way to convert a file into what | call an edit-friendly format to fix that.
Next, Press | to set the start frame, and press O to set the ending frame. Finally,
you can export the sub-clip.

Now, you can also do the above repeatedly; but, instead of export, add each sub-
clip to the playlist. When done, you can export the playlist, which will concatenate
all of the sub-clips.

Initially, the playlist panel is not open, and that is OK. With a clip opened and
trimmed, you can press shift+a to add it. That opens the playlist panel for you, but
maybe you do not need to do anything else at this time except to export it of
course. You can add more to the playlist by repeating everything you have done
thus far. You can play the entire playlist by pressing the escape key and use the
same playback shortcuts. Press escape key again to return the clip player, which
has the label “Source”. Exporting the playlist is simple. As soon as you add
something to the playlist, export automatically defaults to export from the playlist.
This can be confirmed using the drop-down control labelled “From” in the export
panel.

Let me give you a tip about the toggles for the different panels. When you use the
View menu or keyboard shortcuts, it will toggle the visibility of the panel. However,
the main toolbar buttons always make it visible - not a toggle - and raises the panel
in case it is tabbed behind another panel. | just noticed that neither of these
methods give focus to the panel. Panel focus is difficult in this Ul and for most
users. So, Shotcut demphasizes it. However, sometimes it is needed. | guess your
voiceover software lets you search the Ul and take focus. Each panel does have
like a sub-window title, and maybe you can find it that way. This panel title is also
reflected in the tab in case the panel is tabbed with another panel.
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I. How to Reduce Memory Usage

Here are ways to reduce the memory usage in general:

Save and restart Shotcut
Close other browser tabs.
Close other applications.
Reboot (does all of the above).

Here are ways to reduce the memory usage of your project:

¢ Reduce the resolution of the Video Mode.
¢ Reduce the number of tracks. The number of tracks will increase the amount of

caching to prevent files from being closed and reopened repeatedly from one
frame to the next.

Here are some ways to reduce the memory usage while editing:

+ Make sure Settings > Realtime is turned ON. When it is off, it uses more
threads, and more threads needs more memory.
¢ Use Preview Scaling and Proxy Editing.

Here are some ways to reduce the memory usage while exporting:

o See all of the things list above about reducing memory usage in general and of
the project.

e Turn OFF Export > Advanced > Video > Parallel processing. That uses more
threads, which needs more memory.

¢ Turn ON Export > Use hardware encoder (use Configure... > Detect if
needed).

¢ It can be very helpful to reboot, start Shotcut and only Shotcut after reboot, open
the project but do not play through it, and then export. You are then guaranteed
to give the most of your available physical memory to the Shotcut export
process.


https://forum.shotcut.org/t/video-mode/12790
https://forum.shotcut.org/t/preview-scaling/15650
https://forum.shotcut.org/t/proxy-editing/18517
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I. Editing HDR Source Clips

Introduction

Some users report that their clip looks “washed out” or “pale” in Shotcut compared
to media players. This is often because the clip is encoded as High Dynamic Range
(HDR). Shotcut has very limited support for editing HDR, and most users do not
want to bother with HDR output. So, HDR clips can be converted to SDR that
Shotcut can edit.

Identifying HDR Clips
To identify HDR clips in Shotcut, open the clip and view the Properties panel. In the
properties panel, look for the “Color transfer” field in the Video tab.

The following Color transfer types are HDR:

« SMPTE ST2084 (PQ)
« SMPTE ST428
« ARIB B67 (HLG)

Properties

HDR_clip.mpa

Comments:

Speed = = Apply Pitch Compensation

Duratic

Fficiency Video Coding)

Aspect ratio 16 Sl
Scan mode  Progressive =
Color range  Broadcast Limited (MPEG) ~

Rotation 0

= | Reverse... | Convert... Proxy

Transcode HDR to SDR

When opening HDR clips in Shotcut, you may be prompted to convert the file. If
you are not prompted, follow these steps:
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1. Click Convert... in the Properties panel. A dialog window opens.

2. Open the “Advanced” section of the dialog.

3. Ensure that the Convert to BT.709 colorspace checkbox is checked.
4. Click OK to start the conversion.

After the conversion is complete, the clip will be replaced with the converted clip.

Properties
HDR_clip.mpa

Comments:

Speed 00000 x = Apply Pitch Compensation
Duration

Video  Audio

Aspect ratio
Scan mode
Color range  Broadcast Limited (MPEG) ~

Rotation 0

= | | Reverse.. |Converk..

Convert to Edit-friendly...

Choose an edit-friendly format below and then click OK to
choose a file name. After choosing a file name, a job is
created. wWhen it is done, double-click the job to open it.

falelels) better best

medium large biggest
Lossy: I-frame—only H.264/AC-3 MP4
Use sub-clip
Deinterlace
Override frame rate
Frames/sec
Frame rate conversion
v Convert to BT.709 colorspace
Sample rate Same as original -

Keep Advanced open

Advanced Cancel v OK

Convert Color With a LUT


https://d2t917e3b1b2xy.cloudfront.net/original/3X/d/c/dc76330721eae5f6e656ac7b3229aaec301f855b.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/3/6/36ce56f318afb8fdc71ebede33892c5bfb33414e.png

Instead of converting a HLG HDR clip, you can use it as-is with or without a proxy
and use a LUT to convert it to SDR. Our Resources page has a LUTs section with
some freely downloadable LUTs from NBC/Universal that can convert from HLG
HDR to BT.709 SDR. “SL” in the file name means scene light, and “DL” means
display light. Use either of these with the LUT (3D) video filter.

Convert Using Another Tool

There a different ways to convert HDR to SDR since the result is only an
approximation of the source. Shotcut’'s Convert gives a result some people do not
like. A lot of people mention using the popular Free, open source, cross-platform
Handbrake video transcoder.

If you are using macOS and shooting HDR video with an iPhone you can use
QuickTime Player:

1. Choose File > Export As

2. Pick a resolution and a file dialog opens

3. At the bottom of the dialog is a drop-down where you can choose:
Greater Compatibility (H.264)

How to Edit HLG HDR Video With
Shotcut

Version 25.05 of Shotcut added limited support for editing, processing, and
exporting HDR video. This is focused on HLG HDR at this time because my
cameras are iPhone and GoPro HERO13 that both can shoot in HLG. It is also
possible to record in log color, but that is not the focus here.

Limitations

» No embedded HDR preview! You can only see the HDR video as HDR in
Shotcut when using a Blackmagic Design SDI/HDMI device with Settings >
Player > External Monitor. As an upside for this, since HLG is supposed to
provide a satisfactory experience when viewed on a SDR screen, this gives you
a way to simultaneously preview both SDR and HDR.

 If you want to do any filtering, transitions, or track blending/compositing you
must enable Settings > GPU Effects and limit yourself to video filters with the
tags #gpu Or #1epbit on 10-bit video sources. (GPU filters always support a 10-bit
workflow but not all CPU video filters.)

+ When not using GPU Effects, you can do a simple cuts-only editing (trimming
and sequencing). It is OK to include text on a solid color or still image with this,
but its color will look a little different than the preview.

e There is a bug in version 25.05 converting color range of 10-bit video between
full and limited. You should export the same range as the source. This has been


https://shotcut.org/resources/#luts

fixed for the next version.

A Simple, Inexpensive Setup for HLG HDR

This also includes how | do 5.1 surround sound.

recording with GoPro MAX and HERO13 cameras — less than $500 each,
previewing on a 42" 4K HDR (800 nits) Samsung TV | bought in 2018 for about
$650,

using a Blackmagic Design DeckLink Mini Monitor 4K that | bought this year
for $200, and

playing through a Sony AV receiver | bought in 2018 for less than $200.

Shotcut Settings

Turn on Settings > GPU Effects.

Choose Settings > Audio Channels > 6 (5.1 surround) if desired.

Create and use a custom Video Mode with Colorspace = ITU-R BT.2020.
Ignore conversion dialogs when importing video.

Add and edit media as usual. For video filters on HLG video sources, use only
#gpu and #1epit filters. You can use these tags when searching filters.

To convert first order (4 channel) Ambisonic audio to 5.1 surround, use the
Ambisonic Decoder audio filter.

It improves performance to use proxies and preview scaling, but the proxy for
HLG must have been created with version 25.05 or later.

In Export, select a preset from the “ten_bit” category. | have tested AV1, HEVC,
and ProRes.

If the Shotcut version is 25.05 and the source HLG video is primarily full color
range (for example, GoPro HERO13 is but not iPhone), set Export > Video >
Color range = Full (JPEG).

In Export > Other add the line color_trc=arib-std-b67 .


https://www.blackmagicdesign.com/products/decklink

I. Editing Variable Frame Rate Source Clips

Introduction

Sometimes users report that Shotcut is not frame accurate. For example, they split
a clip on a certain frame, but then later the split is not where they expected it. Or,
they put a keyframe on a certain frame, but later the keyframe seems to be on a
different frame. Also, sometimes people report that the audio and video out not in
sync.

Symptoms like these can be caused by Variable Frame Rate (VFR) source clips.
Some users report that VFR clips work in Shotcut if the VFR is subtle. Other clips,
however, are completely unusable in Shotcut.

Identifying VFR Clips

Some programs will skip encoding frames as a way to reduce file size. Also, some
devices will skip encoding frames if they do not have enough processing power to
perform real time encoding. Typically, these clips can be identified by looking at the
frame rate in the properties panel. If the clip frame rate does not match a standard
frame rate, then it is probably VFR. If Shotcut is able to detect a VFR clip, it will add
a “(variable)” tag after the frame rate. But Shotcut can not always detect VFR clips.

Properties
yuv]_vfr.mp4

Comments:

Speed .00 =I5 Apply Pitch Compensation

Duration ©6:00:
Video  Audic  Metadata
Track 1:3840
APEG-4 AVC [ MPEG-4 part 10
ion
Frame rate
Format

Colol }

Aspect ratio
Scanmode  Progressive =
Color range  Full (JPEG)

Rotation 0O

= Reverse...  Conwert... Proxy

Converting VFR Clips
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The best way to edit VFR clips is to convert them to a fixed frame rate. Follow
these steps:

1. Set the desired Video Mode in Shotcut (do not use Automatic). In particular,
choose a frame rate for your project that meets your needs.

2. Open the VFR clip

3. If Shotcut detects the VFR, it may prompt you to convert. If not, click the
“Convert...” button in the properties panel to open the conversion prompt.

4. Click “OK” to start the conversion

After the conversion is complete, the clip will be replaced with the converted clip.


https://forum.shotcut.org/t/video-mode/12790

I. Keyboard Shortcuts

See Keyboard Shortcuts page on the main web site.
As of version 22.09 you can edit or add your own using Help > Actions and
Shortcuts.


https://shotcut.org/howtos/keyboard-shortcuts/
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I. File > Save and Save As

These actions save your project to a file format that is specific to Shotcut so you
can resume editing at a later time. If you want to output a video (or audio only) file

that plays in any other media player or to share use Export.

Save

e Saves current project to a .mit file you name.
e Repeat using Save continues to save current project to the same specified file.

e Shortcut ctrt [+ s (macOS cmd + s )

Save As

Eile Edit View Settings Help
Ctrl+N
Ctrl+ 0O

Ctrl+Shift+ 0

Ctrl+5

Ctrl+Shift+5

Ctrl+E

e Saves current project to a .mit file you name (possibly different).

o Repeat using Save As will offer you a new file name to save as each time.

e The last Save As file you name will be the current project file open in Shotcut.
Now when using Save it only saves to this current project file name.

e Shortcut  ctrt |+ shift + s (macOS  shift + cmd + S )

Backup and Save

This is only available if you have already saved a project (“Untitled” does not
appear in the window title bar). It first gets the last date and time the project file was
modified. Then, it duplicates the current project file with a new name that ends with
the date and time of last modification. Finally, it saves the changes.

This menu item was added in version 23.09.


https://forum.shotcut.org/t/export-basics/12953
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I. File > Backup and Save

Making backup copies of a project can be very helpful in case we want to go back
to a known good state of the project.

A project backup can be created, either manually with File > Backup and Save or
automatically with Settings > Backup.

Eile Edit View Player Settings Help
Ctrl+M Settings
Op Ctrl+0
Open Other... Ctrl+Shift+0

Audio Channels
Ctrl+5

Backup Manually

Ctrl+Shift+5
Hourly
Ctrl+Alt+5

my-project.mit - Shotcut
File Edit View Player Settings Help
Ctrl+N z= ] »
: i O ¥

e Peak Meter Properties  Recent |

Ctrl+Shift+0

Ctrl+5
Ctrl+5Shift+5
Backup and Save Ctrl+Alt+5

Other Versions

Ctrl+Q
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I. File > Open MLT XML as Clip

In Shotcut, the “Open MLT XML as Clip” feature allows you to import an MLT XML
file directly into your project as a single clip. This means that instead of treating the
XML file as a project file with multiple elements like video clips, audio tracks, and
effects, Shotcut treats it as a single media item that can be placed on the timeline
like any other clip.

Using this feature can be handy if you want to incorporate a pre-edited project into
your current project without having to import each individual element separately. It
simplifies the process by treating the entire XML file as a single entity, making it
easier to manage and manipulate within your project.

Like any other type of clip, a MLT clip can be trimmed and have filters applied to it.

MLT clips work best when the profile of the clip matches the profile of the project it
Is being added to. To make this easier, the properties panel for an MLT clip will

display the profile properties and a validation if the clip matches the project profile:
Properties

colorbars.mlt

Duratio

7 Subclip profile matches project profile.

MLT clips with a profile that does not match the project profile can still be used. But
it may result in lower quality or performance.

To import a “MLT XML file as a clip you can either:

1. Use the “File” menu

Open the File menu and click on “Open MLT XML as clip...”
Untitled - Shotcut
View Player Settings Help
Ctrl+MN
Ctrl+ 0

Open Other... Ctrl+5hift+0

Open MLT XML As Clip...

¢ Navigate to the folder containing the MLT file you want to import.
e Select and open the file.

The MLT file will open in the the Source panel, and from there it can be moved
to the Playlist, or to the Timeline.

2. Use the Playlist panel

¢ Open the Plavlist panel.
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Cl-ick on the “Add files to playlist” button
= +=EHv B =

Playlist

Navigate to the folder containing the MLT file you want to import.

Select and open the file.

The MLT file will be added to the Playlist, and from there you can move it to the
Timeline.

. Drag it from a folder

On your computer, open the folder containing the MLT file you want to import.
Select the file and drag it in Shotcut, either to the Source panel, the Playlist, or
the Timeline.
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I. File > Export > Frame

Export Frame is a feature that lets you save the frame currently displayed in the
Shotcut viewer as a still image. The available formats are: PNG, BMP, JPEG, PPM,

TIFF, or WebP.
Export Frame was added in Shotcut version 16.07

After moving the playhead to the desired frame, you can export the image by
either:

e Using the ctrl + shift + E keyboard shortcut.
e Going to File > Export and choosing Frame...

In the export dialog box, Shotcut automatically generates a file name
corresponding to the position of the playhead, but you can use a custom name if
you prefer. This is also where you can choose the file format.

Export Frame

« v s ThisPC » Documents 5 My Project Search My Project

Organize = New folder
Marne Date modified

Mo items match your search.

File name: | Shotcut_00_00_08_125.png

Save as type: [PNG (*.png)

# Hide Folders

This saves the frame as it is displayed in the viewer, including any changes made
with filters or from options in the Settings menu (e.g., Proxy).

Upon saving, the new file is added to the Recent panel for easy access in Shotcut.
Recent

Shotcut_00_00_08_125.png

Shotcut_00_00_03_292.png

Shotcut_00_00_02_083.png

This feature makes it easy to achieve a freeze frame effect:
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e Move the Playhead to the desired frame on the timeline.

e Export the frame.

+ In the Recent panel, double-click on it to copy it in the Source viewer.

¢ In the Timeline toolbar, click on the Paste button to insert the still image at the
position of the Playhead.

It's also convenient for creating a custom thumbnail for your web video:

Export the frame you want to use as a thumbnail.

In the Recent panel, double-click it to open it in the Source viewer.
Apply a Text filter to add a title.

Use Export > Frame again to export the new thumbnail.



I. View > Notes

Keyboard Shortcut | ctrt |+ shift + 3 | (| shift + command + 3 | on macOS).

The Notes icon on the top toolbar will open/close the panel.
Menu: View - Notes

» Use the new Notes panel to keep notes about your project.
» This panel can moved to other panel sections.

Player Settings Help

Al (5

Open File  Open Other, Sav Undo ‘eak Meter Properties  Recent  Mote

(shift+ command+3 on mac(05).

the panel.

your p rl::_i ect.

gust and Septernber

Motes Playlist Filters Properties Export
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I. View > Filters

The Filters Panel allows you to add and manage effects and adjustments to your
video and audio clips. You can apply a variety of filters to enhance your media,
such as color correction, size and position adjustments, masks, blurs, audio
adjustments and many more. Most filters come with customizable settings.

This panel also lets you:

Manage the order of applied filters.
Disable/Enable applied filters.
Copy and Paste filters.

Create and save Filter Sets.

Display/Hide the panel
If the Filters panel is not visible in the interface, you can either:

¢ Click the Filters icon on the main toolbar Y
e Go to the top menu and select View > Filters
(can also be used to hide the panel)

If the panel is visible, but all buttons are grayed out, either:

+ Select a Clip, a Track head, or the Output track in the Timeline.

e Copy or Cut any clip from the Timeline and switch to the Source viewer.

e Double-click any item in the Playlist to copy it to the Source viewer.

e Double-click an image, video or audio file in the Recent panel to copy it to the
Source viewer.

To view a list of all available filters, see the Documentation Table of Content
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I. View > History

The History Panel in Shotcut allows you to manage and navigate through your
editing actions efficiently. Here’s how to make the most of it:

¢ Accessing the History Panel: To open the History Panel, click the History icon
"2 on the main toolbar or go to the top menu and select View > History. This

will display a list of all your recent editing actions in chronological order.

+ Using the History Panel: The History Panel lists each action you’ve taken in
your current editing session, such as adding clips, applying filters, or making
cuts. By clicking on any item in the list, you can revert to that specific point in
your editing timeline. This can be particularly useful for complex edits where you
need to quickly backtrack and make adjustments.

+ Undo and Redo Integration: The actions in the History Panel are directly tied to
Shotcut’s Undo and Redo functions. If you undo an action from the History
Panel, it will appear in the panel, allowing you to easily redo it if necessary.

+ Managing History: The panel not only helps you track changes but also allows
you to delete specific actions from the history if you wish to simplify your action
list.

By incorporating the History Panel into your workflow, you can streamline your
editing process and make adjustments with confidence and precision.
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I. View > Resources

This was added in version 23.09 to the View menu. It shows all unique and sorted
files in the Playlist and Timeline

= Dropped Files

_2117. MOV
_2413. MOV

Convert Selected

This also appears when you drag and drop multiple files to Source, Playlist, or
Timeline that might be problematic - as a way to bulk convert them.

Clicking Convert shows the same Convert to Edit-friendly dialog that you can
reach from the Properties panel.

If you see an exclamation point icon hover the mouse over the icon to see a tooltip
that explains a possible issue.
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I. View > Subtitles

The Subtitles Panel was added in Shotcut 24.08

The Subtitles Panel can be used to add subtitles to a project. Subtitles can only be
added to the Timeline. They can not be added to the playlist or clips. We
recommend to save subtitle editing until the timeline editing is complete because
moving or cutting clips on the timeline will break the subtitle synchronization.

Subtitle Tracks
To start editing subtitles, click the “add” button and give the subtitle track and name
and language.

Mew Subtitle Track

Mame Subtitle Track 1|

Language English (eng)

Cancel

After the subtitle track is created the subtitle track area will appear in the timeline
above the top video track. Multiple subtitle tracks can be added. But only the
currently selected subtitle track is shown in the Subtitle Panel and the Timeline.

Adding Subtitles
Click the “Add subtitle” button to make a new subtitle item at the cursor position.
Then type in the “Current” text area to add the text.
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cubtitles

ubtitle Track 1 (ena) . 14

Text Start End Du
This is some text 000004.967 OMOMO6. 967 00

Fileers  Playlist  Export

o=

00:00:00
[

Importing Subtitles

Subtitles can also be imported. Supported subtitle import formats include: SRT,
VTT, ASS, and SSA. Subtitles are imported at the current cursor position.So be
sure to place the cursor before importing subtitles from a file.

[ 1 <

S SN k-

Exporting Subtitles
Subtitles can be exported to a file. Subtitles are exported in SRT format.

E S -
Tracks

5 Import Subtitles From File

(3 Export Subtitles To File  [x

[Z] Create/Edit Subtitle Shift+Q

& Add Subtitle Item Shift+w
Remove Subtitle Item Shift+E
Set Subtitle Start Shift+R

[
i ] setsSubtitle End Shift+T
L e Subtitles Shift+Y

Generate Text on Timeline
Track Timeline Cursor
Show Previous/Next

Columns

Embedding Subtitles

When exporting a Shotcut project, subtitles will be embedded in the output file if the
file format supports it. Formats that commonly support subtitles include MKV, MOV
and MP4.
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I. Help > Actions and Shortcuts

This feature provides a unified action search and shortcut editor. Action search
makes it quick to find and execute a command. It also provides a keyboard shortcut
reference and lets you add or change shortcuts.

The Actions and Shortcuts Window was added in version 22.09.23.

I Actions and Shortcuts x

Shortcut 2

e The window can be accessed by going to Help > Actions and Shortcuts.

e The window can also be accessed by the default shortcut keys | » and | / .

e Searches both action name and shortcut.

e Press Return /| Enter within the search box to move focus to the list of actions.

e Press Return / Enter oOn a selected Action to trigger it and close the dialog.

e | shift ,  Ctrl |,0Or Alt +  Return /| Enter 0N a selected action to trigger it and
NOT close the dialog.

e Double-click an action to trigger it but NOT close the dialog.

e The dialog is not modal so you can leave it open and to the side while working.

e Press  Esc  when the dialog has focus to close it.

e Press r2 when an action is selected to edit its first shortcut.

» Single-click a selected shortcut to enter edit mouse using the mouse. This
means you typically need two single clicks: one to select, the second to enter
into edit mode.

e You can Tab  out of edit mode to navigate focus to the apply button and press

Space | to trigger the apply. It is intentional that you cannot assign ' Tab | as a
keyboard shortcut to an action.

e There are some keyboard buttons such as J/K/L that are reserved and cannot
be used in a shortcut. You will see an error message when you try to apply it.
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e You can define up to 2 shortcuts per action! You may want to leave the default
as well as add your preferred shortcut.



I. Settings > Video Mode

Introduction

Video Mode is the project resolution, aspect ratio, frame rate, and color space. It
is important to set this as you desire at the beginning of your project. If you try to
change it later Shotcut will try to retain the timing of edits, but some users have
reported problems, and it is risky. Also, at this time Shotcut will not automatically
adjust anything for you related to size and positioning of elements like text and
picture-in-picture when changing resolution. You can think of this like the page size
in a word processor or the canvas size in a drawing program.

Broadcast vs. Non-Broadcast

Shotcut includes a number of video modes that are compatible with broadcast
standards and thus the Blackmagic Design SDI/HDMI integration if you have that.
These are also simply the most popular choices as well:

® Automatic
HD
HD
HD
HD
HD
HD
HD
HD
HD

HD 1080p 60 fps

SD NTSC
SD PAL

How to read these:

o HD = high definition (resolution)

o SD = standard (low) definition

e UHD = ultra-high definition (UHD 2160 is the 4K variant of UHD)
e the first number is the vertical resolution (number of lines or rows)
e the second number is the number of frames-per-second (fps)

p after the first number means progressive scan
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e i after the first number means interlaced

If you go to the Non-Broadcast sub-menu, there are a number of useful
alternatives including trendy square and vertical resolutions:

640480 4:3 NTSC

Square 1
Square 1

al HD 30
Vertical HD

Custom

In the bottom Custom sub-menu, you can Add... your own:

Add Custom Video Mode

Aspect ratio

Framesfsec

Scanmode  Progressive ¥

Colorspace ITU-RBT.709 -

Cancel

If you give your mode a name, it will be saved in the Custom sub-menu.
Otherwise, you can defined something for the current project only.

The maximum resolution is 8192 x 8192. Only even numbers are accepted
because most video codecs only support even values.

Click the down arrow at the end of Frames/sec to pick from some popular frame
rates. Due to some weird legacy video stuff, most often something that is called 30
or 60 fps is actually slightly less. The exact numbers are achieved through fractions


https://forum.shotcut.org/t/glossary-terminology/12413#progressive

3000/1001 and 60000/1001. In order to express those in Shotcut, it is important to
use enough decimal digits. 29.97 or 59.94 is not considered precise enough
because there are some devices and tools that use these exact values instead of
the fraction values. Then, this imprecision affects Shotcut’'s Automatic video mode
and export. Some people do not want their source video frame rate uncontrollably
altered at export. Thus, Shotcut only really uses 30000/1001 when you use
29.970030 and 60000/1001 when you use 59.940060. These special values are
conveniently available in this drop-drown menu.

There are many colorspace standards for video, but at this time Shotcut only
supports ITU-R BT.601, which is typical for SD, and ITU-R BT.709 for just about
everywhere else except HDR.

Of course, after adding a custom video mode, you can use Settings > Video Mode
> Custom > Remove... to remove it:

Remowve Video Mode

v foo

Simply click the checkbox next to the name or double-click the row until you see
the check appear and click OK.

Automatic

Automatic means the resolution and frame rate will be based on the first file you
add to your project. If the first file is not a video clip (for example, image or audio),
then the video mode will be 1920x1080p 25 fps This is not necessarily the first clip
currently in the Playlist or Timeline. Again, it is the first file you open and then add
to the playlist or timeline. Therefore, it almost always recommended to wisely
choose a video clip first when you use Automatic. If you are making an image
slide show, you may find the default 1080p25 adequate. If not, then set your video
mode! If you are only doing audio editing, then it does not matter much except
higher frame rate gives you greater precision in edits.

Project vs. Settings

Once you start a project, the current Video Mode is adopted (not Automatic) or
determined (Automatic). Then, when you load a project, the Video Mode in the



Settings will be checked if it matches your project. Otherwise, if a match is not
found Automatic is checked. (Versions before 20.06 did NOT change its checkmark
to indicate the project’s mode.) You can also see the video attributes of a currently
opened project - assuming it is using the Timeline - click Output (this was named
“Master” in versions before 20.06) in the top left corner and view Properties.

Properties

Timeline

Resolution : 1280 x 720
Aspect ratio : 1280 : 720
Frame rate : 29.97 fps
Scan mode : Progressive

Colorspace : ITU-R BT.709

Properties Filters Playlist Export

Timeline

E el +=~Avm Neoe@® S

Master 00:00:00 |DD:DD:05

V1

You can change the project video properties by choosing a Video Mode in the
Settings menu; However, as mentioned above, be careful with this because
Shotcut will not automatically adjust anything for you related to size and positioning
of elements.



I. Settings > Audio Channels

This is a project setting that controls the number of audio channels you want to use
in your project. The default is 2 channel stereo, which suffices most people. You

can choose 6 (5.1) for surround sound, but Shotcut does not yet support a variety
of surround channel layouts.

For 6 channels, Shotcut uses the FFmpeg default channel layout for 6 channels:
Front Left, Front Right, Front Center, LFE, Surround Left, Surround Right


https://forum.shotcut.org/

I. Settings > Preview Scaling

The Preview Scaling setting may be used to reduce the resolution of video
processing when you are using a fair amount of filters, transitions, and track
blending. This may help with the performance during the editing process.

Settings Help

Video Mode
Audio Channels

v Scrub Audio

Use JACK Audio
v Realtime (frame dropping)
v Progressive

Projects folder

Preview Scaling None
Deinterlacer v 360p
Interpolation 540p

720p

Language

Theme

App Data Directory
Clear Recent on Exit

However, keep in mind that the source video or images must typically be scaled
down to the designed preview scale, and that will have a processing cost. See
Proxy Editing for the remedy to that. Proxy generates substitute clips at the same
resolution as preview scale to eliminate the overhead of this scaling.

The submenu lists only the vertical resolution. The horizontal resolution depends on
the aspect ratio of your project.

e 360p is a good choice on a 1080p screen or less

¢ 540p is good choice when working on a high density screen or screen with
resolution > 1080

e 720p is a good choice when working on a 4K screen or with 4K UHD footage
and you want to get a
little more clarity

Preview Scaling was added in version 20.02.

Export

Export > Advanced > Video has the option Use preview scaling.


https://forum.shotcut.org/t/proxy-editing/18517
https://forum.shotcut.org/

From

e encoder Configure...

Audio Other

Field order
Deinterlacer 'Y

polation

Export File

This is intended to provide a faster export for draft review. You should leave the

export resolution set to the project resolution unless your preset or video codec
dictates a resolution.

Caveats

¢ The Stabilize video filter disables preview scaling for the clip on which it is
applied because it is incompatible.

¢ Preview scaling is a step further away from WYSIWYG (what you see is what
you get) and does not provide perfect fidelity and full precision. Some

differences are unavoidable especially where blur, softness, and noise are
concerned.



I. Settings > Proxy Editing

Introduction

Proxy editing is the process of creating and using low resolution videos and images
in places of the original or optimized (Convert to Edit-friendly) files. This provides
the advantage that your computer has less work to do in realtime while editing:
decoding, scaling, and effects. This is, quite simply, because there are less pixels
to compute. Then, when you are ready to export, it will use the original (or
optimized) files for full quality.

Performance is optimal when the preview resolution matches the files it is working

with. So, this feature is designed to work in conjunction with Preview Scaling. You
can still use the proxy mode without Preview Scaling, however, in case something
Is not working absolutely correct with Preview Scaling.

Proxy editing was added in version 20.06.

The format of a proxy file can be hotly debated because they typically have a
number of goals that is difficult to achieve simultaneously: low resolution, small file
size, fast to generate, fast to seek and decode, and decent image quality to do
understand your work. Not everyone has these goals, but these are Shotcut’s
goals, and the format is not configurable. If you do not like how Shotcut generates
proxy files, you can still create them with a different process (including Shotcut) if
you understand where proxies are stored and how they are named. You are not
required to use the MP4 file format for videos, but the name must end with .mps4 for
video and .jpg for images. Shotcut can almost always handle a video file whose
name does not match the format (but almost never for an image). Fortunately, most
people will be happy with JPEG for a proxy image even if not happy with our choice
of MP4. A convenience of MP4 is that most media players can play them making it
convenient when troubleshooting proxy files.

Settings > Proxy > Use Proxy

This either turns on or off the usage of proxy files for either the current project or
the next project you open or start. When you turn this on and open a project,
Shotcut looks for proxy files that already exist on your file system and uses them
automatically and dynamically. However, it does not automatically

generate a proxy file at this point if there are any missing. Any files added to the
Playlist or Timeline will, however, generate a proxy file if one does not exist
according to the following rules:

e Itis avideo (optionally with audio) or an image file.
e Itis not an image sequence.
» It does not have an alpha channel (transparency).
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e The video is not only cover art.

¢ It does not already have a proxy.

* Proxy for this file has not been disabled in Properties.

+ Both the image width and image height are more than 1.3X the preview scaling
resolution (or 540 if preview scaling is off).

e A proxy job for this file was not yet created.

It generates a proxy by queuing a job in Jobs. You can continue working with the
original at this point. When this proxy job completes, it uses the Replace command
to asynchronously update matching clips in Source, Playlist, or Timeline. In doing
So, it tries very hard to retain all changes thus far including trimming, filters, and
transitions. The vertical resolution of the proxy will be the same as your current
Preview Scaling resolution. If Preview Scaling is set to None, then it uses 540p.
The width of the proxy will be whatever matches the display aspect ratio for

the target height.

If you turn off proxy with a project opened, Shotcut automatically reopens the
project. This causes it to no longer look for proxies during reopen, but it does take
time for the project to reload, it clears undo history, and it resets selected clips. It
does this without requiring you to save your current project,

however.

If you turn on proxy with a project opened, Shotcut also automatically reopens the
project as well while locating whatever proxies are currently available. Then, it
prompts if you want to generate proxies for files that do not currently have them
subject to the same rules above. These proxy jobs will not do a replace operation
as they complete successfully. As the Replace command is still immature, we do
not want someone to open a big old project, generate proxies for nearly everything
and have it murder your project! Rather, once all of the jobs are done, reopen the
project to pick up the proxies.

Settings > Proxy > Storage

Proxy files can be stored in one of two locations: a global folder or a project folder.
When opening a project, it looks in both places. The global folder defaults to a sub-
folder named “proxies” of your App Data Directory. The project folder is a sub-folder
named “proxies” of a project folder created with New

Project > Start on Shotcut’s startup screen.

Choose Settings > Proxy > Storage > Set to change your global project folder to
a new location.

Choose Settings > Proxy > Storage > Show to open a folder view from your
operating system’s file manager to see which folder is currently in use. This is
where newly generated proxies are saved. The result of this action depends on
whether you have a project currently opened or started and whether it has a project
folder.
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Choose Settings > Proxy > Storage > Use Project Folder to control whether you
want proxies to be generated in a project folder, if in use, or always in the global
folder.

Settings > Proxy > Hardware Encoder

You have the option to use your configured hardware encoder to generate proxies.
The lead developer of Shotcut has not found much of an advantage in using it for
these low resolution files if you have a strong CPU. Some systems with a weak
CPU and compatible GPU may benefit from using it. For most users, do not expect
it to significantly improve the speed. Since most hardware encoders tend to create
larger files for the same quality as a software encoder, it uses HEVC to keep the
file size reasonable. With that said, do not expect them to be much smaller than the
software-generated H.264. In fact, they are going to be slower to decode. Still, it is
there for your option and experimentation.

Properties

The Properties panel for video clips and images display (PROXY) next to the
resolution when it is using a proxy file. You may also notice that Properties shows
information about the proxy file instead of the original/converted except for the clip
name, duration, frame rate, aspect ratio, and color range. Properties should
continue to reflect any overrides where possible.

The Properties panel also has a Proxy menu button with the following options:

+ Make Proxy - forces a proxy to be generated without adhering to the rules
above. If you choose not to batch convert a project to proxies, use this to
selectively generate proxies. The proxy job this generates will do a replace
operation.

+ Delete Proxy - Unfortunately, this is not available on Windows due to file locking
prevents it from working (file is likely in use). Otherwise, this does what it says.

+ Disable Proxy - prevents a proxy from being generated for this file. It only
applies within the current project and not globally. Also, replaces all matching
clips in the project with the original if it using a proxy. Re-enabling does not
create or replace with proxy; you need to either reopen the project (if proxy
exists) or choose Make Proxy.

¢ Copy Hash Code - shows a dialog with a 32 character alpha-numeric code that
has also been copied to the system clipboard. This is helpful to track down
problems with proxy files or to generate proxy files externally.

Export

Normally when you export, the proxy clips are replaced with their original or
converted. However, if you go into Advanced mode and turn on Video > Use
preview scaling, not only does export use the preview scaling resolution, but also



it uses proxy clips and images to further speed up export! This is intended to more
quickly make a rough draft for review, not as a final output, of course.

Known Problems

1. A proxy can hide a problem with the actual source media, for example, frame
accurate seeking on video.

2. There is no obvious way to add a proxy to a clip-only project. It is by design not
to load or create a proxy until you add it to the playlist or timeline since the
Source player can be used to quickly preview clips to decide whether to use
one. However, it is possible. If you know the proxy already exists, you can save
the project and reopen it to pick it up. Otherwise, choose Properties > Proxy >
Make Proxy.

3. File > Export Frame... exports using the proxy up-scaled to project resolution it
since uses the current image from the player.

4. It does not work with File > Open MLT XML As Clip. It does not replace the
clips in the sub-project with proxies.



I. Settings > Player > Scrub Audio

Scrub Audio was added in version 15.09
In Shotcut, the audio is muted by default when you:

o Drag (scrub) the Playhead in the Timeline

* Move the Playhead forward or backward frame by frame (with the left/ right
arrow keys, or the mouse wheel on the Timecode)

¢ Increase the playback speed (forward or backward)

The Scrub Audio feature allows you to hear the audio while navigating through your
timeline. This can be useful for precise audio editing and synchronization.

To enable/disable Scrub Audio:

+ Go to Settings > Player.
¢ Check/uncheck the Scrub Audio option.
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I. Settings > Player > Realtime (frame dropping)

This option affects playback and controls two things:

1. when ON: drop some video frames to try to keep the audio continuous and keep

the video running near real-time

This can make the video to appear choppy or slower frame rate than expected
when it is on. Even when this is on it is possible that video processing is so
intense that audio becomes choppy as well because Shotcut will not drop video
frames indefinitely. In fact, currently it will only drop 5 consecutively (subject to
change). Turn this off if you want to see every video frame regardless of how
slow it goes or choppy the audio becomes.

. when OFF: use multiple threads for image processing (filters, transitions, and

track blending/compositing). Turn this setting off if you want to see if multiple
threads can reduce some choppy playback or lag.

Additional Notes

When this is option is off it turns on the same thing as Export > Advanced >
Video > Parallel processing.

Shotcut will use up to 4 background threads to render 4 video frames at the
same time.

Sometimes, this is the cause of a malformed image, which should be reported
so it can be debugged.

This is in addition to image slice-threaded processing used in many effects. The
number of these threads is typically the same as the number of CPU threads.
These threads do not consume nearly as much memory.

The rule for the number of frame threads:

# CPU threads # Shotcut threads

R N W sV

4

P RPN WA


https://forum.shotcut.org/

I. Settings > Player > Interpolation

Interpolation is the computation of values based on neighboring values. It easiest to
think of this as the quality level of scaling - or changing the size of an image - but it
also affects things like positioning and rotation. It is also called sub-pixel rendering
because it gives the impression of positioning between actual pixels.

This settings appears in the Player category of Settings because this only affects
preview. There is a separate interpolation option in Export > Advanced > Video.

Mearest Neighbor (fast)

# Bilinear (good)

Bicubic (better)

These names are based on algorithms. You can search for them on Wikipedia to
get started on learning more about theme. Shotcut provides hints about the quality
and speed trade-offs. Nearest Neighbor actually means no interpolation, no sub-
pixel rendering.

This setting does not affect text or SVG anti-aliasing. It also does not apply to
HTML.
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I. Settings > Timeline > Rectangle Selection

The Rectangle Selection tool, introduced in version 23.11.29, allows you to use
your mouse to select a single clip or a group of clips in the Timeline.

The tool is enabled by default.
To disable or enable it, go to Settings > Timeline

Settings
Project
GPU Effects (unstable)

. ﬂ Snap

¥ &b Scrub While Dragging
) ()] Ripple
Player @ Ripple All Tracks

Playlist * @ Ripple Markers
Timeline Toggle Ripple And All Tracks
Language Toggle Ripple, All Tracks, And Markers
Theme ' Rectangle Selection
Job Priority L4 A ati Add Tracks
App Data Directory
Use Higher Performance Wavefarms
ecent on Exit / Show Video Thumbnails

Screlling

There are a few supported actions for multiple selection:

o Copy

o Cut

o Lift

e Move to another place in the Timeline
e Ripple Delete

e Split (version 24.01 and up)

e Apply Copied Filters

Shortcuts

e When the tool is disabled, hold shift | to enable it temporarily
e When the tool is enabled, hold | shift  to disable it temporarily


https://shotcut.org/blog/new-release-231129/
https://shotcut.org/blog/new-release-240128/
https://d2t917e3b1b2xy.cloudfront.net/original/3X/6/0/605c582088ff9abf2820ee77bbf9b85167429752.jpeg
https://forum.shotcut.org/

I. Settings > Timeline > Automatically Add Tracks

This timeline option was added in version 23.11 and is off by default. This option
tries to automatically add an empty audio or video track to have ready so you do
not need need to add them manually. An empty track also helps to provide some
space in order to select by dragging a box or rectangle.

It only adds tracks when you add something to the timeline or move a clip between

tracks. Also, it does not automatically add a track when you open a project with no
empty tracks.
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I. Settings > Timeline > Scrolling

This is a sub-menu in Settings > Timeline that was added in version 23.09 with
the following options:

+ Center the Playhead - you can still move the playhead before the center point.
But during playback, when the playhead reaches the center, it stops moving and
the timeline starts scrolling in a smooth fashion.

* No - no automatically scrolling

+ Page - when the playhead reaches the end of the timeline panel, the timeline
suddenly scrolls by nearly the width of the timeline panel and stops scrolling until
the playhead reaches the end again. This seems to be the most common among
video editing tools - except perhaps by the page size.

e Smooth - the traditional behavior of Shotcut: when the playhead reaches the
end of the timeline panel, it remains there and the timeline starts scrolling
smoothly.

Scroll to Playhead on Zoom is a checkbox separate from the above options. This
controls whether Shotcut scrolls the timeline to keep the playhead within view after
changing the timeline level of zoom.
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I. Settings > Display Method

This setting is only available on Linux.

Shotcut uses OpenGL technology to draw its user interface and display video.
OpenGL is typically implemented in the GPU of your computer and its driver in the
operating system. These two pieces (Shotcut and the Ul library it uses) and the
OpenGL implementation need to communicate using a complex protocol.
Sometimes, they do not communicate well and have compatibility or interoperability
problems. Thus, there are some workarounds:

o use only software using a library called Mesa 3D. While this is known to be very
compatible, it is much slower since it is not hardware-accelerated.

¢ on Windows, convert the OpenGL protocol to DirectX (Direct3D) using a library
called ANGLE. While this is typically hardware-accelerated, Microsoft provides
an automatic software fallback of its own called WARP.

If you choose Automatic, Shotcut’s Ul library chooses one of the options based on
the model of your GPU, and usually that is OpenGL. You can see what Shotcut is
using by looking in View > Application Log... from the main menu. Then, after
about 100 lines, look for the lines start with

[Info ] MIt::GLWidget::initializeGL
If you see the following, then it is using DirectX:

[Info ] MIt::GLWidget::initializeGL OpenGL vendor “Google Inc.”
[Info ] Mit::GLWidget::initializeGL OpenGL renderer "ANGLE...

If you see the following, then it is using Software:

[Info ] Mit::GLWidget::initializeGL OpenGL vendor “VMware, Inc.”
[Info ] MIt::GLWidget::initializeGL OpenGL renderer “Gallium 0.4 on llvmpipe
(LLVM 3.4, 256 bits)”

This setting corresponds to the key opengtl in the configuration file or registry.

See also
https:/lwiki.qt.io/lQt_5_on_Windows_ANGLE_and_OpenGL#ANGLE_Project


https://chromium.googlesource.com/angle/angle/+/master/README.md
https://shotcut.org/notes/configuration/
https://wiki.qt.io/Qt_5_on_Windows_ANGLE_and_OpenGL#ANGLE_Project
https://forum.shotcut.org/

I. Settings > App Data Directory

The App Data Directory is where Shotcut stores:

o automatically saved project files in the auvtosave Sub-folder

 builtin and saved generator, filter, and export presets in the presets sub-folder

¢ custom video modes in the profites sub-folder

¢ thumbnails and waveforms in the thumbnails Ssub-folder

e non-project-specific proxy videos and images in the proxies sub-folder

« favorited transition wipes in the transitions Sub-folder

e db.sqlite3 is a database where thumbnails and audio levels for waveforms are
saved. (This database provides a more cross-platform way to order things by
access/read time than a file system.)

e shotcut-log.txt Which is a log file of messages from the Shotcut programming
code, also viewable within the application through View > Application Log...
This is overwritten on every run of Shotcut. Thus, if Shotcut is failing to start,
there might be a clue in this file.

o optionally shotcut.ini if you used Settings > App Data Directory > Set... or
command line option --appdata to store Shotcut’s various settings or
configuration. The idea here is that the app data directory can be placed in a
portable location such as USB stick or network file share. Also, some people find
it easier to locate and edit than the registry on Windows, plist on macQOS, or
~/.config/Meltytech/Shotcut.conf file on Linux.

Use Set... ( Settings > App Data Directory > Set... ) to change the location of the
app data directory to make the Shotcut configuration and helper files portable (USB
stick) or usable from multiple systems (network file share).

Use Show... ( Settings > App Data Directory > Show... ) to open the folder in your
OS file manager (Explorer on Windows, Finder on macQOS).


https://shotcut.org/notes/command-line-options/
https://shotcut.org/notes/configuration/
https://forum.shotcut.org/

I. Settings > Job Priority Setting

Settings > Job Priority
Low: Default (Recommended)

Normal: Option to improve performance on Intel 12th generation CPUs with E-
cores.

Job Priority Fo® Low k
App Data Directory MNormal

Introduced in version 22.01.30.


https://shotcut.org/blog/new-release-220130/
https://forum.shotcut.org/

I. Settings > Clear Recent on EXxit

This option removes all the entries in the Recents panel every time you cleanly exit
Shotcut (not if it crashes). This prevents other users on the computer from seeing
what you were working on.

There is also a command line option --ctear-recent that triggers this.
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Il Avout the Playlist

If you don’t see the Playlist panel in your interface, to open it you can either

e Usethe ctrt + 6 keyboard shortcut (| command + 6 | on MacOS)
 Click on the Playlist icon on the top toolbar.
e Open the View menu and click on the Playlist option.

The Playlist is a panel in the Shotcut interface where you can create a list of media
files (such as video or audio clips) to be used in your project. This playlist panel
allows you to easily organize and manage the media assets you plan to use in your
editing timeline. You can add media files to the playlist, reorder them, and preview
them before adding them to your project timeline for editing. This feature provides a
convenient way to manage your media assets and streamline your editing workflow
in Shotcut.

In Shotcut, the playlist feature can also be utilized independently of the timeline.
This means you can use the playlist to organize and manage media files for
projects that don’t necessarily require a timeline-based editing approach (see
Editing and Exporting in the Quick Start Guide). This flexibility allows users to
leverage the playlist functionality for various editing needs beyond traditional
timeline-based editing.


https://forum.shotcut.org/t/quick-start-guide/12977#editing-4
https://forum.shotcut.org/t/quick-start-guide/12977#exporting-5
https://d2t917e3b1b2xy.cloudfront.net/original/3X/3/2/32c0a6ba5da8f13dc5dadc4c5d30bc3844e237ff.png
https://forum.shotcut.org/

I. Playlist > Slideshow Generator

Slideshow Generator makes it easy to add more than one image or clip to the
timeline and automatically:

o fill the frame,
* make a smooth zoom animation for still images, and
¢ add a transition between each item.

Steps to Follow

1. Open the Playlist panel
2. Add your selected images
3. Drag within Playlist (or use sort in its menu) to the desired order

4. Select the images or videos to add to the slideshow: hold ' shift ' to select a
range or | Control | (| Command | ON MacOS) to select individually

5. Click the menu button at the bottom of the Playlist panel H

6. Choose Add selected to Slideshow

7. The Slideshow Generator dialog opens

Slideshow Geansrator - T Clips ? *

8. Adjust the settings and click OK


https://forum.shotcut.org/

9. Your images are added to the current track on the Timeline (a video track is
added automatically if it was empty)

Some Use Cases and Suggestions

* Make a video loop for an information screen.

« Show off holiday or travel photos.

¢ You can now use the usual timeline editing methods to adjust the images and
durations as required.

 If trying to fit a number of slides to an existing audio track:
Estimate the slide duration (Length of track / number of slides) and use this in
the add dialog. If its too short or long, undo and repeat with a modified timing.
Adjust the duration of the first or last clips for small adjustments.

* Set Zoom effect to O to turn it off. This is advised if most of the clips are videos
or music.

¢ Use music files and set Clip duration very high to make a music bed track that
cross-fades between each song. The resulting clip duration is automatically
limited to the clip duration and Clip duration acts as the maximum duration.



I. Source vs. Project Player

When we write about the “player” in Shotcut, we are taking about the part that looks
like below.

000600
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Source Project

When you open a media file (or generator or device in Open Other), it opens in the
Source player. It is called “Source” because it can be the source of edit operations
in the Playlist or Timeline. The Project player is the preview and playback
controls for the Timeline (or Playlist if you are not using the timeline or for
advanced users).

While all other parts of the Ul are panels that can be moved or made to float in a
separate window, the player cannot currently. Also, currently, the two players are
only available as tabs and not side-by-side like some other video editors. You can
adjust the size, however, by adjusting the surrounding panels and the size of the
main Shotcut window.


https://forum.shotcut.org/uploads/default/original/2X/b/bc26bef4acf891392e12eec8f69704caa7deb23c.jpeg
https://forum.shotcut.org/

I. Player > Loop

The Loop feature was introduced in Shotcut version 24.01.28

Introduction

The Shotcut preview player has a loop feature that allows the player to loop around
a region when it reaches the end.

Enabling Looping

The loop mode can be accessed from the Player menu

Player Settings Help
» Play/Pause Space by = =

[ D Loop tes  Playlist  Timeline  Fili

Set Loop Range
P Fast Forward

Alt+Right

Click the loop button again to disable looping

When player looping is enabled, a highlight region appears in the player timeline to
show the looping area

|

2, | : |
M « »>» » M D-u-

i - )

If the looped region is in the timeline, then the highlight will also appear in the
timeline ruler


https://github.com/mltframework/shotcut/releases/tag/v24.01.28
https://d2t917e3b1b2xy.cloudfront.net/original/3X/e/a/ea0fdf83f5c76c786231202899ff0fb26a0e169e.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/5/f/5fb7975e14666442255a099ebe660d7e6452f6e8.png
https://forum.shotcut.org/

Loop Ranges

Shotcut provides the following options to select the region to be looped:

o Loop All - loop the entire clip or timeline (depending on what is selected)

* Loop Marker - loop around the area specified by a range marker that is currently
under the cursor. If the cursor is not under a range marker in the timeline, this
option will not work.

e Loop Selection - loop around the selected clips in the timeline. If no clips are
selected in the timeline, this option will not work

e Loop Around Cursor - set a loop that starts one second before the current cursor
position and ends one second after the current cursor position


https://d2t917e3b1b2xy.cloudfront.net/original/3X/b/1/b162eadbb6d3b6c883bb67b3f44efba669dde68d.png

I. Timeline > Output

Output appears above the track headers in the Timeline:
Timeline

=

Output

V1

g v e
(In versions before 20.06, this was named “Master.”)

Output refers the sum total output of the timeline - all tracks mixed (audio) and
blended or composited (video). If your clips are the inputs to the timeline, this
represents the output. It is very similar to the master output on audio mixing
consoles. You can click this to select it and then see Properties of the timeline
(the attributes of your project’s Video Mode) or Filters that affect the entire timeline.
When you have added a filter to Output, a funnel icon (same as the main toolbar
icon that opens the Filters panel appears in its block:

Output

Often when people report all their video is black or shifted or all their audio is silent
or too loud, they have added a filter on this accidentally and forgot about it.


https://en.wikipedia.org/wiki/Mixing_console#Master_output_controls
https://forum.shotcut.org/

I. Timeline > Ripple All Tracks

Ripple All Tracks has the icon E in the Timeline toolbar and menu. Here is
how it works:

e Only applies when ripple mode (Ripple trim and drop) is also on:

Or when using an edit operation that ripples: Cut or Remove (Ripple Delete).
¢ Only affects the clips after the moved clip on the same track.

o Affects footage after the original start position of the moved clip on other tracks
(I use the term “footage” when | mean there is a time range and not strictly
whole clips, and that often includes a split.)

e When moving a clip right-to-left it simply pushes including a split on another
track per the moved clip’s original start position.

¢ Moving left-to-right is more complicated and usually has 2 actions:

1. Remove the footage from the moved clip’s original start-to-end positions
including other tracks.

2. Insert the moved clip to the new position, which shifts the clips on the same
track to the right but also shifts footage on other tracks the same duration equal
to the moved clip’s duration.

The keyboard shortcut is ' ctrt |+ Alt + R (| option +| command + R  on macQOS).


https://forum.shotcut.org/t/glossary-terminology/12413#p-39168-ripple-21
https://forum.shotcut.org/

I. Timeline > Nudge

Description

The Nudge tool lets you make precise adjustments to the position of a clip in the
Timeline without having to rely solely on dragging with the mouse, which can
sometimes be challenging. Each nudge moves the selected clip one frame to the
left or to the right.

Introduced in Shotcut version 24.01.28.

How to use

There are three ways to access the Nudge tool:
TIMELINE MENU

¢ Select a clip in the Timeline
¢ Go to: Timeline menu > Edit
¢ Click on Nudge Forward or Nudge Backward

RIGHT-CLICK

» Right-click on a clip in the Timeline
¢ Click on Nudge Forward or Nudge Backward

KEYBOARD SHORTCUTS
This is the most efficient way to use the Nudge tool.

¢ Select a clip in the Timeline
e Pressthe , (coma) keyboard key to nudge the clip to the LEFT
e Pressthe . (dot) keyboard key to nudge the clip to the RIGHT

(Animated GIF - Click on the image to begin playback)

Examples

The Nudge tool is especially useful when precise alignment between a clip and a
specific moment on an audio waveform is needed.


https://shotcut.org/blog/new-release-240128/
https://forum.shotcut.org/

(Animated GIF - Click on the image to begin playback)

It is also very handy when you need to move a clip in a cluttered timeline.
Lorard
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(Animated GIF - Click on the image to begin playback)

Limitations

¢ The Nudge tool will not work when multiple clips are selected.

¢ You cannot nudge a clip located at position 00:00:00:00 on the timeline.
o It will not work on a Group of clips.

¢ You cannot use the Nudge tool to create a transition.

Nudging multiple clips

While you can’t use the Nudge tool when multiple clips are selected, if you enable
Ripple or Ripple + Ripple All Tracks you will be able to nudge multiple clips.

* When only Ripple is enabled: The selected clip and ALL subsequent clips on the

same track will nudge.

+ When Ripple and Ripple All Tracks are enabled: The selected clip and ALL
subsequent clips in the Timeline will nudge. Be cautious, however. Depending
on the position of the selected clip, with Ripple All Tracks enabled, you run the

risk of splitting the clips on the tracks above and/or below.



‘ 00:00:04

(Animated GIF - Click on the image to begin playback)



I. Timeline > Markers

Markers are like time-based bookmarks for your project to help you remember and
quickly go to sections.

Timeline Markers were added in version 21.10.31.

> & [l -

Output
Vi & 1 O

e Press m or click toolbar button the first time to add a marker at the playhead
(current position) with no dialog.

v < 2>

e Markers appear in the time ruler/track/row at the top of the Timeline.

e Drag a marker to move it.

e There are several ways to seek to a marker: Click directly on a marker, press
< | or | > |, or click the seeking buttons on the timeline toolbar.

v < >

« If snapping is turned on then dragging clips or their edges snaps to markers and
dragging markers snaps to clip edges or the playhead.

e Press Alt + R ( option + R on macOS) or click on the Ripple timeline
markers with edits button on the Timeline toolbar to have the timeline markers
shift according to the direction that the clips are dragged to in the timeline. Also
works in conjunction with either or both of the other two ripple functions (Ripple
trim and drop and Ripple edits across all tracks). Press | Att + shift + R | (

option + shift + R | on macOS) to turn on and off all three ripple icons at the
same time.

Ne®®

 Click toolbar button or press | M | when the playhead is on the exact start time of

a marker to open the Edit dialog where you can change the name, color, start,
and end times.
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Marker 1

Start ©9:00:11;21 -

End ©0:00:11;21 <
Duration: 00:00:00;01

Cancel

e A color change is remembered for all new markers until a new color is chosen.

¢ Right-click a marker to open its context menu to Edit, Delete, Choose Color...,
or Choose Recent Color.

e Press ctri |+ shift + M | when the playhead is on the exact start time of a
marker to Delete it.

e | ctrl +drag (| command | on macOS) a marker to changes its duration (a marker
with a duration longer than 1 frame is also called a “range”).

e When the mouse cursor is over a marker then a tool tip appears with the name
and time. If the marker is longer than 1 frame (range) then the tool tip will also
show its end time and duration.

Marker 1

D0:D0:13:11 - 00:00:15:10
00:00:02:00

e View > Markers or press | ctrl + shift + 6 (| shift + command + 6 ON
macOS) to open the Markers panel where all markers are listed and can be
categorized by several columns (Color, Marker, Start, End, and Duration).
Clicking on a marker in the list will seek to that marker in the timeline. Click on a
column header to change a column’s sorting to be either ascending or
descending. Under the markers list there are buttons to Add a marker, Remove
the selected marker and Deselect the marker. Click on the hamburger menu
to Remove All Markers and to remove or add any of the columns. A search bar
is also available to filter the list by name. The rest of the panel offers the same
options as the Edit dialog for markers in the timeline where the name, color,
start, and end times can be changed.



Markers

Color ~ Marker Start
Intro 00:00:
#008000 Marker 2 00:02:07;55

#fce94f Outro 00:04:13;09

X = a

Marker 2
Color... #008000
start 00:02:07;55 +
End 00:02:07;55 =
Duration: 00:00:00;01

Remove All Markers

Colurnins

v Duration

o Export > From lists all range markers (duration longer than 1 frame). Selecting
a marker here allows the exporting of just that section of the timeline.

From Timeline
Source
Marker 1

Marker 2

o File > Export > Markers as Chapters... outputs a .txt file in the format used to
make chapters for YouTube. Only timeline markers with a duration of 1 frame
(default) are exported as chapters.

Ctrl+MN
Ctrl+Q

Ctrl+Shift+0

Ctrl+5
Ctrl+Shift+5
Frame... Ctrl+Shift+E

Ctrl+W Video... Ctrl+E

Ctrl+ Markers as Chapters...

EDL...

o Markers are saved to the project file in a XML tag named <properties
name="shotcut:markers"> .

o Marker operations support Undo and Redo.



I. Timeline > Record Audio / Voice-over

1. Setting your microphone: (This only needs to be done once for Shotcut on
Windows or macOS)
Open Other - Audio/Video Device

Audio/Video Device

35 Virtual Camera i

eo Microphone] =

Cancel

Click on Open
2. Click on the Timeline

3. Click on the Microphone symbol on the Timeline

i

Record Audic

4. Name the Voice Over audio file.
Once you click “Save” for the file name, it starts recording immediately.

voiceover.opus]

Opus (*.opus)

5. When done, click the same Microphone symbol. This stops recording and saves
to the file name you specified.
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I. Timeline > Align To Reference Track

The Align To Reference Track tool allows multiple clips to be aligned to the audio in
a reference track. This can be useful to align clips that were recorded at the same
time from multiple camera angles.

Align To Reference Track was added in version 22.06.23.

Align To Reference Track X

Reference audio track Al ~

Speed adjustment range  Mone (0%G) =

Speed

4

Process + Apply Process

Limitations

e This tool can only be used to align clips with audio that is similar to the audio in
clips on another track. Both the clip to align and the reference track must have
audio that is similar so that the algorithm can detect the alignment.

e The tool does not use timecodes for alignment

Usage

Place clips with similar audio on separate tracks. For example, put all the clips from
each camera source on its own track.

Choose one track to be the “Reference Track”. Typically, this will be the audio from
the best audio source. For example, use the camera that had the microphone
closest to the presenter.

Select the clips to be aligned (do not select any clips on the reference track)
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P:Deliuhn FRoss & lan Ross - Caning {i:nr.e (M) wav e

Right-click on the selected clips and choose from the menu: More->Align To
Reference Track

Align To Reference Track
Update Thumbnails

buil

Align To Reference Track d

Reference audio track Al =

Speed adjustment range Mone (0

Camina Fuente Cam 4.mp<

s + Apply

If the results look good, click “Apply”.


https://forum.shotcut.org/uploads/default/original/3X/7/3/7314410f00dcce77e9183a9178dd8cc6a4c37d17.png
https://forum.shotcut.org/uploads/default/original/3X/3/b/3baa7043cf59d17edf89a3e3edb6573eaf217746.jpeg

Align To Reference Track X

[:|ir;|
¥ Camino Fuent m 1.mpd
¥ Camino Fuent m 2. mpd
¥ Camino Fuent m 3.mpd
P Camino Fuente Cam 4.mp4

+ Apply z Cancel Apply

Alternatively, both “Process” and “Apply” can be run as one action by clicking
“Process + Apply”.

Align To Reference Track d

[:|ir;|
¥ Camino Fuente Cam 1.mp4
¥ Camino Fuent m 2.mpd
¥ Camino Fuente Cam 3.mp4
¥ Camino Fuente Cam 4.mp4

|00:00:20

B8 Camino Fuente Cam 2.mp

£-88 Camino Fuente Cam 1.mp<)

Al o' Pater John Ross & kan Ross - Caming Fuente (Mix).wav
b

Speed drift adjustment
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Align To Reference Track X

Reference audio track Al ~

Speed adjustment range. Mone [0%)

Process + Apply Process

If the selected clips can not be aligned, or if the alignment drifts over time, re-run
the tool and select “Speed adjustment range” and click “Process”. With this option
enabled, the alignment algorithm will try to detect alignment by speeding or slowing
the clips. The clip speed difference can be detected by up to +/-0.5%.

If the tool is able to detect alignment with the “Speed adjustment range” option,

after clicking “Apply”, the clips will be moved and their speed will be changed to
make the alignment.



I. Timeline > Apply Copied Filters

The Apply Copied Filters option was added in the 24.04 release.

“Apply Copied Filters” is an option in the Timeline context menu which allows a filter
to be applied to many timeline clips at the same time. It can also be used to update
existing filters with the same value.

Applying filters for the first time

This video shows how to create a filter and then apply it to multiple timeline clips

Updating previously applied filters

This video shows how to easily modify the filter on multiple clips. First the filter is
modified on one clip. Then, the filter is copied and applied to the other clips. Note: if
the filter already exists, Apply Copied Filters will replace the filter with the new filter.
It will not add the filter multiple times.
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I. Timeline > Adjust Clip Gain/Volume

There is a black or gray line that appears across timeline clips that have audio if
Settings > Timeline > Show Audio Waveforms is on.

Adjust the volume of a clip by dragging this line up or down. Doing so adds a
Gain/Volume audio filter to the clip’s Filters. Double-click it to reset it back to O for
no change (or you can remove the added filter).

Use Settings > Timeline > Adjust Clip Gain/Volume to turn this feature off.

When the line has not been moved, it represents -1 dBFS. With it you can visualize
when the audio level is dangerously close to clipping. However, keep in mind that
there can be audio clipping that occurs due to other Gain/Volume filters or mixing
with clips on other tracks.

This feature was added in version 25.07.

See also Gain | Volume Audio Filter


https://forum.shotcut.org/t/gain-volume-audio-filter/12906
https://forum.shotcut.org/

I. Timeline > Selection and Groups

Many actions for clips in the timeline require that you select one or more of them.
There are also some actions that only work when a single clip is selected. Click the
menu button in the top left of the Timeline: there is a Selection menu.

Selected clips on the timeline have a red outline unless it is part of a group. When a
Group is selected, the clips have a white outline.

Select Single Clip

Usually, you simply click a clip with the left mouse button to select it. However, you
can also select the clip under the playhead/cursor using the keyboard combination

ctrl |+ Space (| command + space on macOS). If there is more than one clip under
the playhead, it selects the top clip.

You can select the neighbor of a selected clip (move the selection) by holding
ctrt (| command | on macOS) with left, right, up, or down arrow keys.

Multiple Selection

Here are some of the actions you can perform with multiple clips selected:

e Copy

o Cut

o Lift

¢ Ripple Delete

¢ Move

e Split

e Apply Copied Filters

e Align To Reference Track

To select a range (multiple consecutive clips) click the first (or last) clip, press and
hold | shift and click the last (or first) clip.

To select or deselect multiple clips individually hold | ctrt | (| command | on macOS)
while clicking the clips.

Rectangle Selection

You can also use the mouse to drag out a rectangle to select multiple clips. If
Settings > Timeline > Rectangle Selection is on simply click an empty area of the
timeline near a corner where you want to start. Then, holding the left mouse button
down drag to select. Release the left mouse button when you are done.

If that setting is turned off, hold | shift | to draw the rectangle (without Shift clicking
seeks).
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To facilitate this feature, it is helpful to have empty space above or below the clips.
You can start the rectangle by clicking below the existing tracks. To have an empty
track at the top turn on Settings > Timeline > Automatically Add Tracks.

Group/Ungroup

A group is a multi-selection that is saved with the project. To make one, select
multiple clips, right-click any member, and choose Group/Ungroup from the
context menu. Alternatively, use keyboard shortcut ' ctrt |+ G | (| command |+ G  ON
macOS). Now, whenever you click a member of a group, it selects all of the
members and show a white outline instead of red. You can have multiple groups
but not overlapping groups.

Frequently you need to work with only one member of a group. You could ungroup
and re-group later, which is tedious, or:

« If the group is already selected ' ctrl -click the one to use.
 If the group is not selected Alt -click to select a single member of a group.

Select Track

Did you know that you can not only select clips but also a track? With a selected
track, you can add Filters to it that affect all clips on that track! There is a special
track at the top of the track headers labeled Output, and by selecting that you can
add a filter to everything in the project. However, it is better to think about that as
putting an effect between the timeline and the output—preview or the export.

However, there is also a current track. It has the gold color background. Selecting a
track or clip also makes it current, but it also possible to use the keyboard to
change the current track: | ctrl |+ Alt |+ up Or | Down (| option + command | ON

macQOS).

Some actions depend on the current track. See the Track Operations in the
timeline’s menu button:

e Insert Track

e Remove Track

e Move Track Up

e Move Track Down
e Show/Hide

e Lock/Unlock

e Mute/Unmute



I. Subtitles > Speech To Text

The Speech To Text tool can analyze the audio for a project and generate text in
the View > Subtitles

Speech To Text was added in version 24.10.29.
Using The Tool

1. Place your video in the Timeline.

2. In the Subtitle panel, click on the Detect speech... button

3. Wait for the 2 jobs to complete (the Speech to Text job might take a while to
complete depending on the length of your video).

About Speech To Text

Shotcut’s Speech To Text feature uses Al based on OpenAl’s Whisper, courtesy of
the whisper.cpp project.

Our builds include a basic model that has decent speed and accuracy but not a big
size. (You can think of the model as the brain.) You can download a bigger and
better better brain (model) in ggnt format and configure it in the Speech to Text
dialog, but it will be slower.


https://forum.shotcut.org/t/subtitles-panel/45312
https://openai.com/index/whisper/
https://github.com/ggerganov/whisper.cpp
https://huggingface.co/ggerganov/whisper.cpp/tree/main
https://forum.shotcut.org/

Speech to Text

Name Subtitle Track 1
Language English
Translate to English
Maximum line length 42 characters -

Include non-spoken sounds

v V2
. VARA
Tracks with speech

Configuration

The dialog creates two jobs that appear in the Jobs panel: one to export audio and
another to convert to text. The results are added to the Subtitles panel as a new
top-level Subtitle Track.

Currently, the only GPU our build supports is Apple Silicon. Otherwise, it is heavily
multi-threaded on the CPU.

Known Quirks:

o Subtitle items sometimes start earlier than expected. Timing is provided by the
model and tool, and we lack the skills and resources to improve this.

o Expect there to be occasional errors. Like humans and non-ideal conditions, it is
not perfect. We will not take action on bug reports about some piece of audio not
converting to the expected text.

OpenAl has made some warnings about the usage of their Whisper models:

In particular, we caution against using Whisper models to transcribe recordings
of individuals taken without their consent... We recommend against use in high-
risk domains like decision-making contexts, where flaws in accuracy can lead to
pronounced flaws in outcomes.


https://huggingface.co/openai/whisper-large#evaluated-use

I. Export Basics

The Export panel (also File > Export Video...) is used to create a new video or
audio file from your project because File > Save saves a project file. Think of this
like a photo editor that saves its own format (e.g. .psd or .xcf) versus saving a
JPEG or a word processor that saves to its own format (e.g. .doc Or .odt) versus a
PDF.

Presets Export Help

The defaults create a H.264/AAC MP4 file,
which is suitable for most users and purposes.
Choose a Preset at the left before deciding to
use the Advanced mode. The Advanced mode
does not prevent creating an invalid
combination of options!

Custom
= Stock
AV1 WebM
Default
GIF Animation
H.264 Baseline Profile
H.264 High Profile From Timeline hd
H.264 Main Profile =
Aain Profile Use hardware encoder Configure...

WebM
WebM VP9
YouTube

= - Export File Reset Advanced

The most important thing to know is to click Export File to export your project as a
new video file. It opens the standard save file dialog for your operating system
where you must choose a folder and give it a name.

Here are the other things to know about the Export panel in its basic mode:

¢ Click Advanced to show many more controls and options. However, by clicking
Advanced you should understand that Shotcut expects you to be advanced and
know what you are doing. There are simply too many combinations of settings
and options that Shotcut’'s advanced export mode lets you create invalid
combinations and does not protect you from yourself.

* The Reset button is used in advanced mode to reset all the options and settings
to their default values.

e The list of many things on the side are Presets. There are many presets
provided by Shotcut in the Stock category, and you can add your own that will
be shown under the Custom category. The ' + | and | - | buttons at the bottom of
the list are used to add and delete custom presets.

NOTE: It is not necessary to choose a preset! Shotcut comes with default values
that creates a high quality H.264 MP4 file at a reasonable size and speed that
automatically adapts to the resolution, frame rate, and visual complexity of your
project. Clicking Reset or the preset named Default restores the panel to its
default values.


https://forum.shotcut.org/t/advanced-export/12956
https://forum.shotcut.org/

¢ The From field lets you choose what to export. You can export more than just
the timeline. In fact, you do not even need to use the Timeline in Shotcut! You
can export a single clip that has been trimmed and filtered in the Source player.
You can also add that clip to the Playlist, add more clips, and export the playlist
as a single, sequential file or a separate file for each item.

+ Use hardware encoder is option to use the hardware-accelerated encoder in
your NVIDIA or AMD GPU or CPU (Intel Quick Sync on most processors since
2012, but it may depend on your motherboard as well). You will need to tell
Shotcut which you have, but if it has not been configured Shotcut tries to
automatically detect it when you click the checkbox to turn it on. Pay attention to
the status message area just below the player controls for several seconds after
clicking the checkbox to see what it reports. This feature currently only supports
the H.264 (aka AVC) and HEVC (aka H.265) codecs.

+ Configure... opens a dialog for the configuration of the hardware encoder. This
is useful in case there was a problem with automatic detection, you want to see
what automatic detection found, or you want to change it if you have more than
one available on your system.

Next, you might need to understand some basic, fundamental concepts of video
and audio compression to understand why it takes long or why the file size is not
what you expected. Please see this article

How to compress a video | Reduce video file
size on iPhone, Mac, and more |...

Learn how to compress video on iPhone, Android, Mac, and
with popular video compressors online. Reduce file size and keep your video
high-quality.

Est. reading time: 9 minutes


https://vimeo.com/blog/post/video-compression-basics/

I. Advanced Export

Shotcut’s export panel has an advanced mode that you can access by clicking the
Advanced button at the bottom of the panel. By default the next time you restart
Shotcut, the advanced mode is turned off again. However, you can pin it to the on
or enabled state by clicking the checkbox next to Advanced.

Export

Presets .
N tiom Use hardware encoder Configure...
* Stock -
Format | mp4 o
Default P

Video Codec Audio  Other

in Profile
Main Profile Aspect ratio 16

Resolution 1920 = x 1080 =
=

2 9
Frames/sec 2
Scan mode Progressive ~
WMV ; Field order
WebM e ([ = = =
WebM VP9 Deinterlacer 'YADIF - temporal + spatial (be ~
YouTube Interpolation Bilinear (good) e
- alpha o ;
Quicktime Animation Use preview scaling
- . Parallel processin
W VP8 with alpha cha... etetprocessng
WebM VP9 with alpha cha...

Export File Reset Advanced

Video
Codec
Audio
Other

See MLT’s documentation for information about the syntax and parameters. MLT’s
consumer properties also apply here. Most essential parameters are written by
the presets and various form fields of Export > Advanced but you can override
them here (must use the correct name, of course). Some parameters are appended
to the generated ones. For example, you can supply a x265-params , and the Codec
tab will prepend values needed for rate control. Prepending lets you specify
overrides. You might also find FFmpeg’s codecs and formats documentation
more useful here as it is more organized. Please keep in mind that Shotcut is not a
ffmpeg command line front end except in the rare cases of Properties > Convert
and Reverse and proxy media generation. Thus, there are many things you cannot


https://mltframework.org/plugins/ConsumerAvformat/#plugin-information
https://www.mltframework.org/doxygen/properties.html
http://ffmpeg.org/documentation.html
https://forum.shotcut.org/uploads/default/original/3X/6/5/65bb1b5b85adfac70079c86a72e353633009d528.png
https://forum.shotcut.org/

copy from ffmpeg examples are possible here. Only options from FFmpeg that
affect the encoder or muxer.

Custom Export Presets

You can save your own custom preset by clicking the n button at the bottom of
the Export panel.

To add a new Custom Export Preset:

o Set your preferred parameters in the Video, Codec, Audio and Other tabs.
« Click the [ button.
e Give a name to your preset and click OK

Presets

Use hardwai

Format mp4

Interpolation  Bili

h alpha channel
h alpha channel

rt File 2ege Advanced

Flaylist Filters Properties Markers Jobs

© Add Export Preset

Name My preset

-

Make fina q E including remaving item do not want to
indude, or the dipboard.

Cancel



https://forum.shotcut.org/uploads/default/original/3X/5/2/5238441ed3b4d635f3f828b10440573c8092a419.png

Presets

Custom

To delete a Custom Export Preset:

¢ Select the custom preset you want to delete
« Click the [l button at the bottom of the Export panel
¢ Click OK to confirm

o Delete Preset

?




I. Export > Resample

Resample is a button in Export > Advanced > Video that enables the
Resolution, Aspect ratio, and Frames/sec fields.

This was added in version 24.09, but the concept of resample in export always
existed in Shotcut. It is named “Resample” because it usually occurs after each
frame of the Timeline or Playlist is rendered. Export = render + encode
(uncompressed is formatting and writing).

Some sample uses for this feature:

» Video Mode resolution = source (can make editing interaction faster), AND you
want to down-sample to make a smaller file.

e You composed this project at resolution X but | need Y, AND you have some
stuff sensitive to size and position, AND you do not want to take the time to
adjust these by changing Video Mode. Best quality is not a concern.

e You made this project at aspect ratio X but you want Y, AND you really do want
black bars.

e You made this project at frame rate X but you want Y, AND Y < X.

 All your sources are <= Video Mode resolution, AND you are not using text or
vector graphics, AND you want to upscale export in order to game YouTube’s
encoding (or avoid some other upscaler such as in my TV).

In version 23.09 clicking this shows a dialog:

o Resample Export

Reframe is for experts and may not do what you expect.
Do you want to change Video Mode in the Settings menu?

Yes o

(“Reframe” in that dialog was a typo and should have been “Resample.”)

Click No to acknowledge that you really do not want to change the Video Mode at
this time and resample the export.

In the next version 24.10 this button and dialog are removed and instead an inline
warning message may appear that does not block anything:


https://forum.shotcut.org/

Video Codec Audio Other

Reframe
Resolution 1920 < x 1080 < =

i .

Aspectratio 17 = =

) Aspect ratio does not match project Video
Mode, which causes black bars.

Framesfsec 29.970030 < ~




I. Embedding metadata into Exports

Certain formats such as MP4 and MP3 (and many others but not all) support
embedded metadata attributes such as Artist and Title. See the MultimediaWiki

FFmpeg Metadata page for more information about which formats supports which
attributes.

In Shotcut, you can embed these attributes into your exports by using the Other
tab in the Advanced mode of the Export panel. You can add one of more of the
following lines with the value you want on the right side of the = sign:

e meta.attr.artist. markup=

¢ meta.attr.comment.markup=
e meta.attr.copyright. markup=
e meta.attr.date.markup=

¢ meta.attr.description.markup=
¢ meta.attr.genre.markup=

¢ meta.attr.title.markup=

For audio language, you can set alang to an ISO 639 language code. For example:

alang=eng


https://wiki.multimedia.cx/index.php/FFmpeg_Metadata
https://forum.shotcut.org/

I. Export at the Command Line

Introduction

It is fairly easy to run an export on the command line because Shotcut essentially
does the same thing. For example, do an export in the Ul and then View >
Application > Log... and scroll to the end. You will see the command line printed;
however, the file name is fully encoded to workaround potential character set
problems.

Quick Start

The general basic form is:
LC_ALL=C melt project.mlt -consumer avformat:export.mp4

Of course, you substitute your own file names possibly with a path prefix for
project.mlt and export.mlt. LC_ALL=C Sets that environment variable to mitigate
problems with numeric strings in some locales. That command line generates a
H.264/AAC MP4 using software encoder x264 with melt & FFmpeg’s default
encoding options.

Encoding Options
You can add some encoding options at the end of the command line like

LC_ALL=C melt project.mlt -consumer avformat:export.mp4 movflags=+faststart vcodec=

Notice that each option is not preceded by one or two dashes. Rather, the -
consumer Specifies a consumer “object”, and the options that follow until the next
dash add properties to that object. There are an extreme number of avformat
(named after FFmpeg’'s libavformat library) options and values! Moreover, they
depend on operating system and which hardware encoders are available. There is
a rough reference of them on the MLT web site. If you know or find some ffmpeg
command line examples, you can adapt some of its options but not in the same
order or syntax! Melt only accepts the encoder and muxer options here, but only
some of ffmpeg’s options are for the encoder and muxer. Moreover, ffmpeg
command lines do not usually clearly organize the options. So, you need to be a
fairly advanced user. See also Advanced Export.

You can use Shotcut’s Ul to prepare these option=value pairs. Basically, setup and
export, and click the ' + | button at the bottom of the Export > Presets list. That

opens a dialog with all of the option=value pairs in a text box. You can copy and
paste these, but you need to convert the new lines into spaces.

Project vs. Export Job XML


https://mltframework.org/plugins/ConsumerAvformat/
https://forum.shotcut.org/t/advanced-export/12956
https://forum.shotcut.org/

The above command line uses a -consumer option, but if you looked at Shotcut’s
log you see it does not. The difference is that Shotcut adds the consumer and its
options into the MLT XML. That is the main difference between them (except for a
clip-only project). Basically, Shotcut adds a fourth line to the project XML.:

<consumer mlt_service="avformat" movflags="+faststart".. />
So, an easier way to do all of the above is:

. Open a project in Shotcut

. Click Export

. choose export preset or configure export options
. Click Export > File

. Right-click the new job in Jobs and choose Stop
. Right-click the job and choose View XML

. In the dialog that opens, choose Save

. Choose a location and filename, and click Save

. At the command line run Lc_ALL=C melt job.xml

© 00 ~NO UL WDN P

Platform Notes

e With Linux Flatpak, run melt using
LC_ALL=C flatpak run --command=melt org.shotcut.Shotcut

e With Linux Snap, run melt using
LC_ALL=C shotcut.melt

¢ With Linux Applmage, | think the only way is to mount the image and then use
the reported /tmp directory followed by /usr/bin/melt, fOor example
LC_ALL=C /tmp/.mount_shotcuD5hIPg/usr/bin/melt

o With Linux portable, run melt using
LC_ALL=C path/to/Shotcut.app/melt

¢ With macOS, simply run
LC_ALL=C /Applications/Shotcut.app/Contents/Mac0S/melt

e On Windows (outside of a package system like msys2), cd to the directory
where Shotcut is installed and run mett in cMp.EXE Or ./melt in a shell.
Alternatively, provide the full path to the mett.exe:
LC_ALL=C 'C:\Program Files\Shotcut\melt.exe'

Pro Tip: Shotcut includes a few other executables you can run in the same
manner:

ffmpeg
ffplay
ffprobe
glaxnimate


https://docs.appimage.org/user-guide/run-appimages.html#mount-an-appimage

I. Filter Sets

Filter sets first appeared in version 23.05.14.

A Filter Set is a collection of filters. A few examples are included:

Glow Intensity

Obscure With Blur

Obscure With Mosaic

Text Simple with Gradient Back

You can create your own from all enabled (checked) filters by clicking the Save a
filter set button in the Filters panel.

This opens a window to let you give it a name. If you do not give it a name, the
filters are copied to the clipboard.

Cancel

To use a filter set, after clicking  + to add a filter you can either search or click the
Sets category to browse them.

¥ Favorite | [ Video © Audio @ Time £ Sets

To remove a filter set that you created (stock ones cannot be removed), go the
Sets list and right-click the custom filter set you want to remove.

How to install a Filter Set

In the Forum Resource section, you will find many Filter Sets created and shared
by members of the forum.

They are usually contained in a ZIP file and, once unzipped, they need to be moved
to a specific folder on your computer.

Steps

¢ Download the ZIP file containing the filter set and un-zip it.


https://forum.shotcut.org/c/resources/14
https://d2t917e3b1b2xy.cloudfront.net/original/3X/f/b/fb57b39a4f7113c4566cc16a9214b06116fce23a.jpeg
https://d2t917e3b1b2xy.cloudfront.net/original/3X/3/c/3c7c30960eaf9f201f356d5b2918540bfe3fbe77.png
https://forum.shotcut.org/

¢ In Shotcut, go to Settings > App Data Directory > Show to open the filter-set

directory.
« In that directory you should see a filter-sets folder. If it is not there, you will have

to create one (use that exact name: filter-sets).

¢ Open the filter-sets folder.
* Move the unzipped Filter Set file in that folder.
¢ Close and re-launch Shotcut.

To find your new filter set in Shotcut, go to Filters panel > Sets

Transition

search

¥* Favorite ] Video © Audio




I. Audiol/Video Properties

When an Audio/Video clip is selected, the Properties Panel shows the audio and
video properties.

Properties
Elephants_Dream_{2006).webm

Comments:

Speed Apply Pitch Compensation
Duration 00:1

Video Audio Metadata

Track 1: 192

Resolution

Frame rate

Color transfer

Aspect ratio

Scan mode  Progressive ~

Colorrange  Broadcast Limited (MPEG) =

Rotation 0 - =

The Speed setting allows the playback speed of the clip to be increased or
decreased.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/4/8/4875771f8b3b013c8a00af8fe0aed021f1d4e11e.png
https://forum.shotcut.org/

I. Properties > Extract Sub-clip

Shotcut can not “pass through” or copy codecs without re-encoding. The closest
thing available to that is Properties > menu > Extract sub-clip, which uses the in
and out points of a trimmed clip.

Extract sub-clip will find the key frame closest to the in/out points and copy the
codecs into a new container without re-encoding. Any filters applied to the clip will
not be applied to the sub-clip because that would require re-encoding.

This feature has some limitations and may not always provide the expected result:

¢ The extraction will round to the nearest codec keyframe - which could be more
than a second a way from the selected in/out points

¢ The extraction tries to pack the media into the same container format as the
original. But it may not always be able to get the packing or timing to match the
original


https://forum.shotcut.org/uploads/default/original/3X/3/9/39ce92431b3d65647089e8dd1d727b768300d8f3.jpeg
https://forum.shotcut.org/

I. Color Generator

The Color can be used to create a color clip. After choosing the menu option, the
dialog will appear.

Preset Save Delete

Colar... FFFO00000

Open Cancel Add To Timeline

Click on the “Color...” button to choose a color. After the color is chosen, you can
click “Open” to open the color clip in the source player. Or, you can click “Add To
Timeline” to add the color clip directly to the timeline.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/3/5/35e11b4690a9092f2e60946735551b324c00c0ea.png
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I. Lissajous Generator

The Lissajous generator creates a Lissajous clip.

A Lissajous curve is a pattern made by combining two wave motions: one side to
side, and one up and down.

After selecting, this dialog box will appear.

Lissajous

Preset > Save

X Ratio Y Ratio

Add To Timeline Cancel

You can adjust the dials to set the curve’s properties (values range from 0.00 to
1.00):

o “X Ratio” controls the horizontal wave frequency.
¢ “Y Ratio” controls the vertical wave frequency.

After setting your desired curve, you can either click:

* “Open” to open the lissajous clip in the source player. Where you can adjust and
preview the curve before adding to timeline.

e “Add To Timeline” to add lissajous clip directly to the timeline.

e “Save” to “Preset”.

If you selected “Open”, drag from project player to add clip to timeline.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/9/9/99e709696bef1a04d49b43c84bbd16b8ce46348d.png
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You can continue adjusting the curve after adding it to the timeline by selecting the
clip — this will reopen the dialog box in Properties.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/4/0/40e390d92cf25d0d52e5eb04303e127ea00cfc85.jpeg

I. About Keyframes

In Shotcut, as well as in video compositing software, a keyframe is a frame used
to indicate the beginning or end of a change made to a parameter. For example, a

keyframe could be set to indicate the point at which audio will have faded up or
down to a certain level.

Images-clés

Miveaux

Input Black
H +

Input White
M -

Timeline  Images-clés

Or, Keyframing is the simplest form of animating a change to a parameter.

Keyframing in a compositing software:-



https://en.wikipedia.org/wiki/Compositing
https://i.imgur.com/stu5FBk.gif
https://forum.shotcut.org/

Example of Result of keyframing in shotcut:-
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Image source from Zoom Image and then Pan - #2 by samth


https://forum.shotcut.org/t/zoom-image-and-then-pan/13981/2

I. Simple Keyframes

Simple keyframes are a quick way to animate a filter over the course of a clip.
Simple keyframes only support two keyframes:

o The “start” keyframe is relative to the beginning of the clip and defines how the
filter animates in.

e The “end” keyframe is relative to the end of the clip and defines how the filter
animates out
The space between the start and the end keyframes is not animated

Simple keyframes are activated by dragging the circles in the upper left and right of
the keyframes panel

¢ To set the starting values for the filter, move the cursor to the left side and then
set the filter parameters in the filter panel.

¢ To set the middle values for the filter, move the cursor between the start and end
keyframes and set the filter parameters in the filter panel.

¢ To set the ending values for the filter, move the cursors to the right side and then
set the filter parameters in the filter panel.

Here is a demonstration that sets the brightness filter to animate in brightness, hold
the brightness, and then animate out the brightness.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/5/9/5905645e0d6da76592a5659ee8ec918b372a830f.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/1/4/149ee36a571206f1f84f2d3d2ea3d727a07ecaad.png
https://forum.shotcut.org/




I. Audio Loudness Scope

The Audio Loudness scope provides a real-time calculation of the program
loudness for the preview player.

The meter displays 6 metrics as defined in EBU-R128.
These metrics include:

e Momentary loudness
e Short term loudness

e Integrated loudness

e Loudness range

o Peak

e True peak

Audio Loudness
M S I 1 P
99 -120 -175 99 2.2
LUFS LUFS LUFS LU dBFS
0 0 0 30 3

-50 -50 -50 0 -50 -50
= Reset 00:00:21:23

The display can be customized by clicking on the hamburger menu to disable the
display of specific meters.

Reset 00:00:2
fomentary Loudn
v Short Term Loudn
Integrated Loudness

Loudness Range
Peak
True Peak



https://en.wikipedia.org/wiki/EBU_R_128
https://d2t917e3b1b2xy.cloudfront.net/original/3X/9/9/99d6abf5fa2d57d5f71f95d0ac7423f8055f09ff.png
https://forum.shotcut.org/

The meter readings could become inaccurate if the user seeks around the timeline.
To get accurate readings for a segment of a clip or timeline, follow these steps:

. Seek to the position that you want to begin measurement

. Click the “Reset” button in the Audio Loudness scope

. Click “Play” in the player.

. Observe the Momentary, Short Term, Peak and True Peak values while the
player plays (these are dynamic metrics that change over time)

. When the player reaches the position where you want to stop, click pause

6. Observe the Integrated loudness and Loudness range. These values apply for

the duration of the segment that was played.
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I. Audio Peak Meter Scope

The Audio Peak Meter Scope provides an illustration of the instantaneous peak
audio value for each channel.

In this screenshot, the Audio Channels setting is set to 6 channels.

Audio Peak Meter

L R CLFLsRs

The scope also shows a “recent peak” indicator as a small line above the level bar.


https://forum.shotcut.org/t/audio-channels/12791
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I. Audio Spectrum Scope

The Audio Spectrum Scope provides an illustration of the instantaneous audio level
for the range of frequencies of the audio.

The left axis represents the level of the frequency in dBFS. The bottom axis
represents the frequency for each bar.

Audio Spectrum

The scope also shows a “recent peak” indicator as a small line above each level
bar.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/6/5/65ad14211c9d90267eb408dc3dad23543f48a5a6.png
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I. Audio Surround Scope

The Audio Surround Scope was added in the 24.04 release.

The Audio Surround Scope provides a visualization of the multichannel sound.

In this figure, the Audio Surround Scope is shown with the Audio Peak Meter

Scope.
Audio Peak Meter @ Audio Surround
0 L

L R CLFLsRs
The center of the display represents the position of the listener.

The blue lines extending from the center of the display visualize the signal strength
for each channel. In the illustration above, you can see the relationship between
the level for each channel in the Audio Peak Meter and the Audio Surround Scope.

The purple lines connecting the blue lines help to illustrate the width of the sound in
the room.

The green concentric circles illustrate the “focal point” of the sound. In the display
above, the focal point is in front of the listener and slightly to the right.

The display adjusts to the number of channels in the Audio Channels setting. In
this screenshot, the setting is set to Stereo (2 channel). So the C, LS and RS


https://forum.shotcut.org/t/audio-peak-meter-scope/12918
https://forum.shotcut.org/t/audio-channels/12791
https://forum.shotcut.org/

channels are grayed out.
Audio Surround
L




I. Audio Vector Scope

The Audio Vector Scope was added in the 24.04 release.

The Audio Vector Scope provides an illustration of the phase relationship between

two channels. A typical display for two stereo channels is shown below:

Audio Vector
L -

To show the phase relationship between different channels, choose the channels

from the drop down boxes:
Audio Vector



https://forum.shotcut.org/

If the vector scope shows a vertical line without any horizontal separation between
the points, that means the two channels are perfectly in phase. Typically caused by

a mono signal that is split to left and right:
Audio Vector
L -

If the vector scope shows a horizontal line without any vertical separation between
the points, that means the two channels are perfectly out of phase. This means one
channel is an inverted version of the other channel. This can be caused by
microphones that are wired incorrectly. The problem with such an audio signal is
that if they are summed together (such as converting stereo to mono), the channels
will cancel out and the result will be silence. The following figure shows the vector
display for two channels that are inverted. It also shows the waveform display
where you can see that the waveforms are the exact opposite.



Audio Waveform

Audio
L -



https://d2t917e3b1b2xy.cloudfront.net/original/3X/5/d/5d18ce30228b93242af8d4de381b9f109fd650aa.png

I. Audio Waveform Scope

The Audio Waveform Scope provides an illustration of the waveform of each audio
channel.

Passing the mouse over the display will show a bubble that indicates that value for
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I. Video Scopes

Shotcut contains various video scopes to help with color adjustment and picture
validation.

i i @ = R = T

» Mleter Properties Recent Playlist Fles  Timeline  Filter

The video scopes represent the picture from the preview player. The preview player
always displays as YUV 4:2:0. As a result, the representation in the scope does not
necessarily represent the original source material. Nor does it necessarily
represent what will be in the final export file.

Format Conversions

Shotcut manipulates images by applying various services (filters, transitions,
playlist, timeline). Different services operate on different image formats. Shotcut will
automatically convert the image format as needed as the image passes through the
processing pipeline from one service to the next. Depending on the services that
user has applied an image may go through multiple conversions before it reaches
the preview player.

Internally, Shotcut supports two image formats:

e Limited range YUV as defined by BT.709 and BT.601
e Full range sRGB as defined by IEC 61966-2-1

Note that a full range YUV image will be converted to limited range upon decoding.
If a limited range source image has values that are outside of the limited range,
those out-of-bounds values will be passed to the preview window (and therefore
the scopes) unless they go through a conversion. In order to satisfy the needs of


https://www.itu.int/dms_pubrec/itu-r/rec/bt/R-REC-BT.709-6-201506-I!!PDF-E.pdf
https://www.itu.int/dms_pubrec/itu-r/rec/bt/R-REC-BT.601-7-201103-I!!PDF-E.pdf
https://webstore.iec.ch/publication/6169
https://d2t917e3b1b2xy.cloudfront.net/original/3X/e/6/e6870983194e314d62baa12b332926cc7fd181e4.jpeg
https://forum.shotcut.org/

various services (transition, filter, etc.) an image may be automatically converted
between YUV and RGB. These automatic internal conversions will result in out-of-
bounds values being rounded down to be within the limited range.



I. Video Histogram Scope

View > Scopes > Video Histogram opens a panel to display a histogram of the
image luma and the reg, green and blue color channels. The histogram updates
with every image in the preview player.

Video Histogram

Luma Min: 19 Ma
P
all J—.r“ -

Green
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I. Video RGB Parade Scope

The Video RGB Parade Scope shows a waveform for each of the R, G & B
channels in a row.

Video RGB Parade



https://d2t917e3b1b2xy.cloudfront.net/original/3X/9/6/96bde9c1ec6098ade70562b3ccb831c394375e43.png
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I. Video RGB Waveform Scope

The Video RGB Waveform Scope shows the waveforms for each of the R, G & B
channels displayed on top of each other.



https://d2t917e3b1b2xy.cloudfront.net/original/3X/b/e/befaf54f1c4c320627e730fd8ad7618562479239.png
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I. Video Vector Scope

The Video Vector Scope provides a vectorscope display. This scope can be used to
to evaluate the hue and saturation in the image. The presence of colors are
mapped as a circle containing Red, Magenta, Blue, Cyan, Green and Yellow
demarcations. The more samples that exist for a given value, the brighter the
sample will appear in the display.

Video Vector

When the mouse is passed over the scope, a bubble appears to display the U & V
values for the sample under the mouse.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/2/f/2f2dd74b9b97e123606e03e2429ca22da2617fe9.png
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Video Vector

The scope also includes a skin tone line, located at about the 11 o’clock point

between the red and yellow demarcation points. It is common for colorists to center
the skin tones around this line.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/0/d/0d7e5a8ad4a9d41c977124458c739b07d05f5dcf.png

I. Video Waveform Scope

Shotcut provides a video waveform scope to aid in setting video levels.

Video Waveform

See Video Scopes for general information about video scopes.

The waveform scope displays graticules for 100 and O IRE. These graticules are
hard fixed to a Y value of 16 = 0 IRE and a Y value of 235 = 100 IRE. These
assignments are not user configurable.

While IRE is technically an analog video construct, it is included in this scope as a
familiar and useful indicator for video levels.


https://forum.shotcut.org/t/video-scopes/19996
https://forum.shotcut.org/

I. Video Zoom Scope

Shotcut provides a video zoom scope to aid in inspecting images.

See Video Scopes for general information about video scopes.

The video zoom scope receives YUV 4:2:0 images from the preview player and
converts the image to a zoomed in window as RGB. The mouse cursor allows the
user to select individual pixels and shows the x,y position, YUV values, and
converted RGB values.

NOTE: For RGB sources, some chroma bleeding occurs due to the conversion
from 4:2:0 to RGB. This can be demonstrated by opening File->Open Other->Color
Bars. The source color bar image is generated with no chroma bleeding. But the
images is converted to YUV 4:2:0 for the preview display which results in vertical
chroma bleeding as shown below:

This chroma bleeding may or may not appear in the exported file depending on the
image format requested by the export parameters.


https://forum.shotcut.org/t/video-scopes/19996
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I. 360: Equirectangular Mask Video Filter

Adds a black matte to the frame. Use this if you filmed using a 360 camera but only

want to use part of the 360 image - for example if you and the film crew occupy the
90 degrees behind the camera.

Parameters

Horizontal

o Start: the width of the field-of-view in degrees of the un-matted area.
» End: the width of the field-of-view in degrees where the matte is at 100%.

Vertical

o Start: half the height of the field-of-view in degrees of the un-matted area.
+ End: half the height of the field-of-view in degrees where the matte is at 100%.


https://forum.shotcut.org/

I. 360: Equirectangular to Rectilinear Video Filter

Converts an equirectangular frame (panoramic) to a rectilinear frame (what you're
used to seeing). Can be used to preview what will be shown in a 360 video viewer.

Parameters

* Interpolation: Nearest-neighbor or bilinear. Determines the sampling method.
See also “Interpolation” in the Glossary | Terminology

e Yaw, Pitch and Roll: The direction of the image center in the panorama.

¢ FOV: Tthe horizontal field of view, in degrees, of the resulting frame. Any value
over 179 results in a fisheye projection.

+ Fisheye: The amount of fisheye to mix in. 100 means that you get a 100%
fisheye lens.

VUI

When this filter is active you can click and hold in the video area to drag the video
around to adjust it:

o left-right for Yaw
¢ up-down for Pitch
e | ctrl  up-down for “Roll”

This does prevent being able to drag from the Source player. Either use a toolbar

icon or keyboard shortcut to perform the intended operation, or select a different
filter to turn off the VUIL.


https://forum.shotcut.org/t/glossary-terminology/12413#interpolation
https://forum.shotcut.org/

I. 360: Hemispherical to Equirectangular Video Filter

Converts a video frame with two hemispherical images to a single equirectangular
frame. The plugin assumes that both hemispheres are in the frame. If you have a
camera like the Garmin Virb360 that produces two videos, one from each camera,
you should start by converting them to a single movie by placing them side by side
using, for example, ffmpeg (you can also add parameters to produce lossless,
intra-only output here for easier editing):

ffmpeg \
-i left.mp4a \
-i right.mp4 \
-filter_complex hstack \
output.mp4

Parameters

« Interpolation: Nearest-neighbor or bilinear. Determines the sampling
method.See also “Interpolation” in the Glossary | Terminology

¢ Yaw, Pitch and Roll: The two fisheye cameras of a 360 camera are rarely
perfectly 180 degrees apart. These parameters adds a rotation to both lenses to
correct for this.

* Projection: The fisheye projection type. Currently only equidistant fisheyes, like
the Ricoh Theta and Garmin Virb360 are supported.

+ FOV and Radius: The field of view of a single hemisphere in degrees, and the
radius of the image circle, expressed as a fraction of the frame width.

e X, Y and Up: The image center and image orientation for the front- and back-
facing camera. The X parameter is a fraction of the image width, and the Y
parameter a fraction of the image height. Up is the “up” direction in the image, in
degrees clockwise from a direction towards the frame top edge.

+ Nadir Radius and Nadir Start: 360 cameras like the Theta have a problem with
the nadir direction where, no matter what, you will have a little of the camera in
the image. This parameter “stretches” the image near nadir to cover up the
missing parts.


https://www.ffmpeg.org/
https://forum.shotcut.org/t/glossary-terminology/12413#interpolation
https://forum.shotcut.org/

I. 360: Rectlinear to Equirectangular Video Filter

Converts a rectilinear (a normal-looking) image to an equirectangular image. Use
this together with 360: Transform to place “normal” footage in a 360 video.

Parameters

* Interpolation: Nearest-neighbor or bilinear. Determines the sampling method.
See also “Interpolation” in the Glossary | Terminology

+ Horizontal: The field of view’'s width in degrees of the rectilinear image.

¢ Vertical: The field of view’s height in degrees of the rectilinear image.


https://forum.shotcut.org/t/glossary-terminology/12413#interpolation
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I. 360: Stabilize Video Filter

Stabilizes 360 footage. The plugin works in two phases - analysis and stabilization.
When analyzing footage, it detects frame-to-frame rotation, and when stabilizing it
tries to correct high-frequency motion (shake).

How to Stabilize Video

1.

w

0 N O 0o b~

10.
11.

Disable Realtime (frame dropping) in the Settings menu. It is important that
the filter sees all frames.

. Add the 360 footage
. Apply a Hemispherical to Equirectangular filter to it so it is in equirectangular

format.

. Apply a Transform 360 filter

. Apply the Stabilize 360 filter.

. Select a file to store stabilization data in.

. Enable Analyze mode.

. Use the Transform 360 filter to rotate the footage so that the point straight

ahead is over the center cluster of track points.

. Play the footage from start to finish. The FUD (Filter-Up Display) should show an

increasing frame count.
When the footage has completed playing, switch off the Analyze mode.
You should now have stable 360 video.

The FUD (Filter-Up Display)

When you switch to analysis mode, the filter will overlay information on the video.

In the top left is information about the file you use for storage and how many
frames it has data for.

The squares are the areas used for motion detection.

Red outline are the areas that were sampled.

Yellow outline is the search radius

Blue squares are fixed.

Green squares are where the sampled areas were found.

When analyzing, the red, yellow and green squares are drawn first. Then the
frame is transformed in such a way as to cancel the rotation from the previous
frame, and the blue squares are drawn. If the detection and detected rotation are
flawless, the blue and green squares should overlap completely and form cyan
squares. Note: “Analysis: Apply Transform” must be enabled.

The waveform drawn in the lower middle shows the detected motion. Red is
yaw, green is pitch and blue is roll.
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Parameters
e Mode: Toggle this checkbox to go from stabilization mode to analysis mode.
» File: Path to file that will be used to store the analysis data.

o Start Offset: The offset into the stabilization file that corresponds to the start of
this clip. Press the Undo button to set it from Shotcut timeline. For example, if
you have a 30 second clip, analyze it all, and then split it into three clips of 10
seconds each, then the start offsets should be Os, 10s, and 20s.

Added in Shotcut 20.11

 Interpolation: Output quality.
Analysis

* Apply Transform: When checked, the filter will apply the frame-to-frame
transform in order to show the quality of the analysis (see the above section
about the FUD). When you are satisfied with the analysis quality you can turn
this off, as it adds approximately 50% to the analysis time.

Added in Shotcut 20.11

+ Sample Radius: The radius of the square that the stabilizer will sample.
e Search Radius: The maximum amount of motion the stabilizer will detect.
o Offset: The distance between the track points.

» Use backwards-facing track points: If set, six backwards-facing track points
will also be used to detect pitch and yaw motion. Disable if, for example, you
show up holding the camera there.

Yaw, Pitch & Roll

e Amount: The amount of stabilization to apply. 100% means that the stabilizer
will make the camera as steady as it can. Smaller values reduce the amount of
stabilization.

+ Smoothing: The number of frames to use to smooth out the shakes. The higher
the value, the slower the camera will follow any intended motion.

e Time Bias: Shift the frames used to smooth out the shakes relative to the
stabilized frame. A value less than zero will give more weight to past frames, and
the camera will seem to lag behind intended movement. A value greater than
zero will give more weight to future frames, and the camera will appear to move
ahead of the intended camera movement. A value of zero should make the
camera follow the intended path.



I. 360: Transform Video Filter

Rotates a panoramic image.

Parameters

¢ Interpolation: Nearest-neighbor or bilinear. Determines the sampling method.
See also “Interpolation” in the Glossary | Terminology
¢ Yaw, Pitch and Roll: The amount to rotate the image.

VUI

When this filter is active you can click and hold in the video area to drag the video
around to adjust it:

o left-right for Yaw
¢ up-down for Pitch
e ctrl up-down for “Roll”

This does prevent being able to drag from the Source player. Either use a toolbar

icon or keyboard shortcut to perform the intended operation, or select a different
filter to turn off the VUIL.
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I. Alpha Channel: Adjust Video Filter

Mode No Change

Amount

This filter adjusts the alpha channel in a number of ways.
Mode works in conjunction with Amount.

The modes primarily affect the edges of the alpha channel, which is very helpful for
chroma keying. It is cascadable, so for example one can do a soft shrink first and
then threshold, which gives a slightly different result than a hard shrink.

+ No Change
* Shave tries to remove the “hairy” stuff, and also shrinks the selection
a bit.
o Shrink Hard
The “hard” operations introduce no new values to the alpha channel,
so if you have a “hard” key (only 0 and 255) it will stay that way.
¢ Shrink Soft
The “soft” operations will introduce interpolated values, making
the edge softer.
e Grow Hard
e Grow Soft
e Threshold
¢ Blur simply blurs the alpha channel with a quasi Gaussian blur.
* Reset (added in version 23.09) changes the alpha channel to all zero for
transparent. Combine this with */nvert to make the alpha channel entirely
opaque.

Amount controls how much the selected mode applies.

Invert means transparent becomes opaque, and opaque becomes transparent.
However, these are just the terms for 0 or 100%. If the alpha level of a pixel is 50%,
then invert does nothing. Or, 25% inverts to become 75%, for example.

See also

freiOr/srclfilter/alphaOps at master - dynel/freiOr

A large collection of free and portable video plugins - dyne/freiOr


https://forum.shotcut.org/t/glossary-terminology/12413#alpha-channel
https://github.com/dyne/frei0r/tree/master/src/filter/alpha0ps
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I. Alpha Channel: View Video Filter

The Alpha Channel: View filter is intended for temporary use to assist in
visualizing the alpha (transparency) channel of your video. It's particularly useful for
fine-tuning transparency effects, chroma keying, and masking operations.

It displays the transparency information of your clip, making it easier to see which
areas are transparent and which are opaque.

See the Glossary/Terminology page to learn more about Alpha Channels.
The Alpha Channel: View filter was added in Shotcut version 16.01

Filters

Video
v Alpha Channel: View

Display Gray Alpha

How to Use the Alpha Channel: View Filter

1. Add the Filter: In the Filters panel, search for the “Alpha Channel: View” filter
and add it to your video clip.

2. Choose a Display option: The filter will display the alpha channel of your clip
differently depending on the Display option you choose.

To show the difference between the Display options, we will use this sample
project: A fully opaque image on track V1 and a clip with transparencies on track
V2.


https://forum.shotcut.org/t/glossary-terminology/12413#alpha-channel-1
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Display options
Gray Alpha
Shows the alpha channel as a grayscale image, where white areas are fully

opaque, black areas are fully transparent, and shades of gray represent varying
levels of transparency.

Red & Gray Alpha

Shows the fully transparent pixels in gray and overlays a red-pink color over the
other pixels in the image. The intensity of the red-pink color varies according to the
level of transparency.

Checkered Background

Shows a checkered background under the transparent and translucent areas.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/6/8/689d3629355e2cb4e9b009f1a29d282c9259d2b6.jpeg
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https://d2t917e3b1b2xy.cloudfront.net/original/3X/7/3/73122210c56f0bd725108d1e53b75d95be2fea06.png

Black, Gray or White Background

Shows a black, gray or white background under the transparent and translucent
areas.
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I. Audio Dance Visualization

The Audio Dance Visualization filter is a creative tool that allows to animate your
video based on the audio waveform of a video or audio track. This filter is perfect
for adding dynamic, eye-catching effects to your projects.

This filter was added in Shotcut version 19.04.30

IMPORTANT: The clip or track that the filter is applied to must have audio. The
filter will not respond to the audio from a different track or clip.

If your music is in an AUDIO track and want the visualization to appear on
the video from video tracks, you should add the filter to the “Output” track
in the top, left corner of the Timeline.

Timeline

=S xm [ +

Output 00:00:00

Vi o
A" )

Settings

« Initial Zoom: The amount of zoom to apply to the image before any motion
occurs.

¢ Oscillation: Oscillation can be useful to make the image move back and forth
during long period of sound.

e Zoom: The amount that the audio affects the zoom of the image.

e Up, Down, Left, Right: The amount that the audio affects the vertical and/or
horizontal offset of the image.

¢ Clockwise, Counterclockwise: The amount that the audio affects the rotation
of the image.

e Low Frequency: The low end of the frequency range to be used to influence the
image motion.

» High Frequency: The high end of the frequency range to be used to influence
the image motion.

¢ Threshold: The minimum amplitude of sound that must occur within the
frequency range to cause the image to move.
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I. Audio Waveform Visualization

The Audio Waveform Visualization filter allows the user to display a waveform of
the audio on top of the video.

The clip or track that the filter is applied to must have audio. The filter can not show
the audio from a different track or clip. If you have music in an audio track and want
the visualization to appear on the video from video tracks you should add the filter
to the Output track in the top, left corner of Timeline.
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I. Blend Mode Video Filter

The Blend Mode filter lets you override the way a clip blends with the the bottom
video track. The default blending mode follows the video track’s blending mode,
which is set in Properties with a default of Over (simple alpha compositing).

Track: V2

Blend mode | Ower

Most of the options are the standard Porter/Duff blend modes. Full technical
details about the different blend modes are defined in the Cairo graphics library.


http://ssp.impulsetrain.com/porterduff.html
https://www.cairographics.org/operators/
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I. Choppy Video Filter

A “choppy video filter” refers to an effect that intentionally makes a video appear
uneven or stuttery, like it's skipping frames. This look mimics a low frame rate or
gives the impression of stop-motion animation. It's often used creatively to add a
sense of retro, glitchy, or dramatic style to videos.

You can see the difference between the original video and the same clip with the
filter, but the frame rate reduced by half.
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I. Chroma Key: Advanced Video Filter

Introduced in version 16.01

This filter makes certain colors of your video transparent. Thus, you need to have
something under the video to see its effect. You can also use it after a Mask filter
and before Mask: Apply if you want to make other filters affect only certain colors,
for example for secondary color correction.

Preset
Key color Ve
Color space Red-Green-Blue Hue-Chroma-Intensity
Hue delta
Chroma delta
Intensity delta
Shape Ellipsoid
Edge Slope
Slope

Operation Overwrite

2
2
o] D
o] D
o] D
=)
2
o| |
=)
=)

Invert

Key color

This is the color to select. This is the center point of the selected color subspace.
You can use the dropper to pick a color from the screen. When using the dropper,
drag a small rectangle to average the color values within the rectangle.

Color space

This specifies in which of the two color spaces (RGB, HCI) the delta controls will
work. HCI is separated luma/chroma (a cylindrical “Hue Chromacity Intensity”)
space. It suffers from chroma subsampling, and will give less sharp results than
RGB.

NOTE: Chroma subsampling is not a fault of this plugin. FreiOr plugins work in RGB
4:4:4. If you supply it with a truly 4:4:4 video, it will produce perfectly sharp alpha
from both color spaces.

NOTE: HCI is slow, because it has to calculate the arctangent and hypotenuse for
each pixel.

Red/Green/Blue delta
Hue/Chromalintensity delta

These three parameters determine the size of the color subspace along each axis.
Bigger value means bigger tolerance on that axis. For example, setting a high
intensity delta (in HCI), will allow the selection of a specific color in both light and


https://github.com/mltframework/shotcut/releases/tag/v16.01
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shadows, but will also discard most of the high-bandwidth luma signal, making the
selection less spatially accurate.

Shape

This determines the shape of the color subspace. Options are: Box, Ellipsoid or
Diamond. Box is the biggest of them (by volume) and diamond the smallest.
Imagine an octahedron inscribed inside an ellipsoid, which is in turn inscribed in a
box. The tips of the diamond touch the ellipsoid, and the box, at the center of the
sides of the box.

Edge

This has five options: Hard, Fat, Normal, Thin and Slope. Hard means the alpha
channel will be thresholded to two values only, fully opaque and fully transparent.
This is mainly useful for keying. The Slope mode is also intended for keying. It is
particularly useful when keying partly transparent or fuzzy (like hair) objects. The
remaining options (Fat, Normal and Thin) create a gradual transition between
transparent and opaque. Alpha will be a function of the difference of color from the
selected color, with cutoff at the delta points.The fatter the choice, the more the
selected areas are filled towards the rim. This is useful with alpha controlled color
adjustment tools.

Slope

When edge mode is set to Slope, this parameter controls a gradual transition
between opaque and transparent. 0% gives a hard-edged key, increasing the value
of this parameter increases the range of colors around the selected color, that will
be rendered partially transparent.

Operation

This determines the way in which the alpha channel will be written. These options
combine the current selection with the pre-existing alpha of the source material.
This way complex selections can be built. The Minimum, Maximum, Add and
Subtract options allow cascading of other Alpha Channel or Mask filters;
Overwrite does not.

Invert

When ON, the selected color will be transparent, as normally used with keying.
When OFF (default) the selected color will be opaque, for example for alpha
controlled adjustment of that color only.



I. Chroma Key: Simple Video Filter

Introduced in version 16.01
Location: Filters > Video > Chroma Key: Simple

If you have an item in your playlist or timeline that has a uniform background, you
can use the “Chroma Key: Simple” filter to remove it. This is commonly used to
remove a green screen to superimpose a picture or video onto a background that
was captured or acquired separately. That means the asset has to be placed on
any track but V1, and a background has to be placed on a lower track. So for
example some green screen footage is placed on V2, and a background is placed
on V1.

=S ¥ F =
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There are two options:
The Key colour sets the background colour. The eye dropper icon can be used to
activate the colour picker. By clicking now on the background, the colour will be
selected as the key colour.
The Distance adjusts which shades or colours are treated like the key colour. This
is especially important for similar colours that are present in the background as well
as in the foreground. If the colours are very similar, only few percentages decide
whether both are keyed out or not. This is also useful for retaining fine details like
hairs, which might be keyed out as well.
Preset is for saving a set of key colour and distance.

Preset

&

Key colour

Distance

In this example the colour of the text is very similar to the background. With a small
percentage the background is keyed out, but the text remains. Increasing the value
gradually reduces the opacity of the text.
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00:00:01:03

In this example one strand of hair is partially removed beyond a certain percentage.

In this example the lighting is subpar, and the background consists of various
shades of green. With finding a key colour in the middle of these shades and
adjusting the distance, the background can be removed to large parts. The lighting
is partly responsible for the green screen remains behind the hair. Using only this
filter will not remove it completely without affecting other parts.
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If “Chroma Key: Simple” does not lead to satisfying results, “Chroma Key:
Advanced” and/or the key spill filters (“Key Spill: Simple” and “Key Spill:
Advanced”) might help.


https://forum.shotcut.org/t/chroma-key-advanced/12834
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I. Corner Pin Video Filter

This filter lets you transform (change the size, position, and shape) to fit inside a
shape defined by four points. This is not limited to a 4-sided polynomial
(quadrilateral) because the corners can be moved beyond the lines between other
points to create weird effects. A common use case for this is to fit one video to a
rectangular area within another video. For example, replacing a sign or window, or
placing something on a wall.

This screenshot is a super simple example, but typically you will use this on a
timeline with more than one video track where the video with this filter is on a video
track above another video below to composite them. (One could also use this in
conjunction with Mask: Simple Shape and Mask: Apply video filters to composite
the distorted video on top of itself with additional filters applied only to the corner
pinned video by stacking them before Mask: Apply.)

This filter also features a video user interface (VUI) meaning the corners are shown
with circles on the video preview area, and you can drag these circles to
interactively define the four Corner X Y parameters. These corner controls will
snap to the player grid if that feature is turned on.

Stretch X 'Y parameters will do a non-linear scaling horizontally (X) or vertically (Y)
to help create perspective when the plane onto which you are projecting is not
facing parallel with the camera.

Interpolator is the algorithm used to define how to do sub-pixel rendering and
affects the quality and speed. Nearest Neighbor is fastest but the worst quality.
Lanczos is probably the best quality but also slowest. The default Bicubic Smooth
represents a good combination of medium quality and speed.

Alpha Operation controls how the alpha channel created by this filter combines
with the alpha channel that is already in the video. When not set to Opaque, this
filter’'s alpha channel makes everything outside of the lines connecting the corners
transparent while the rest is opaque.

Feathering controls the softness of the edge between opaque and transparent.

For Simple Keyframes, this filter uses only the following parameters:


https://forum.shotcut.org/t/glossary-terminology/12413#alpha-channel
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e Corner1l
e Corner 2
e Corner3
e Corner4
e Stretch

+ Feathering

Note: added in version 20.04.12



I. Crop: Rectangle Video Filter

Crop: Rectangle is a filter used to crop a specified region of a video clip or image
file to the current Video Mode. Keyframes are available with this filter.

Filter can be applied to Source, selected clip, Video Track or Output.

Parameters

* Preset: Save current settings for later use. To use later, just click the drop-down
menu for selection.

o Position & Size: Values can either be input by keyboard or adjusted by the
adjustable border corners and center.

o Corner radius: Apply a corner radius to the cropped selection. Can be adjusted
by the slider bar, entering a value, or just click & scroll on the percent value.

o Padding color: Default is set to Black with no opacity (Alpha channel = 255). Any
padding color can be selected and alteration of the Alpha channel can all be
adjusted. You can also pick a color using the eye dropper tool.

Tip: To adjust opacity, lower Alpha channel from 255 to O.

Example #1.:
Video Mode 1920x1080, Image 1920x1080, Padding Alpha channel set to 255.

Krug 1920%1080.5ng

Example #2:
Video Mode 1920x1080, Image 1080x1350, Padding Alpha channel set to O.

Krug 1080x1350.png
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Apply to Source

Filters

Video
v Crop: Rectangle

Preset
Position
Size
Apply to Source
Corner radius |

o

Padding color ‘7 & Transparent

Load Keyframes from Motion Tracker

The Apply to Source button in the Crop: Rectangle filter is the primary way to
simply "crop a video".

Exporting without using Apply to Source

Cropped area Exported file

& 0

The clip is exported at its original size, with black bars around the cropped area.
Exporting using Apply to Source

Cropped area Exported file

| ';a. | "'ﬁ'

Only the cropped area of the clip is exported. The clip will have the same
dimensions as the ones set in the Crop filter.

Notes

e The Apply to Source button was added in Shotcut version 23.11.29.

+ The Apply to Source button is only enabled when the aspect ratio of the source
media matches your project’s Video Mode because it is impossible to include the
black padding that Shotcut adds to a source. To make sure the project and the
media dimensions are the same, set the Video Mode to Automatic before
importing your media file.

¢ Since this feature is intended to crop a single clip, you do not need to use the
timeline.

How To Export a Cropped Area


https://d2t917e3b1b2xy.cloudfront.net/original/3X/a/e/aead712bba9ee3122102b1564ff55c01ff5f3b13.jpeg
https://d2t917e3b1b2xy.cloudfront.net/original/3X/b/b/bb1752f8da4af052085d8d17c7232348456d37d4.jpeg

1. On a new Shotcut project, go to Settings > Video Mode and choose
Automatic.

. Go to File > Open File... and import your media file.

. Add the Crop: Rectangle video filter.

. Adjust the size of the cropped area.

. Click the Apply to Source button in the Filters panel.

. Choose Yes in the dialog asking to change the Video Mode.
At this point, your clip will be cropped, and the Crop: Rectangle filter will be
replaced by the Crop: Source filter.
Also, the Export settings will automatically be adjusted to match the new
dimensions of the project.

7. Export

o 01 WDN

Residual Black Bars

It happens sometimes that the cropping is not perfect and leaves small black bars

on one or two sides of the clip.
. |
L1
\\

"y
s ‘ ®

If that happens, edit the parameters of the Crop: Source filter to remove those

bars.
Depending on which side(s) the bar(s) are located, adding 1 or 2 pixels to one or
more of the parameters highlighted below should be enough to remove them.

Filters
Video

¥ Crop: Source

Center

center bias [

Top




I. Crop: Source Video Filter

Crop: Source removes rows or columns of pixels from the edges of the source
video or image before the image is scaled and padded to match the current Video
Mode. When cropping, selection is centered to the Video Mode because padding is
used to maintain the aspect ratio and prevent the image from appearing stretched
or squished. Keyframes are not available with this filter.

This filter can only be applied to Source or a selected clip; it cannot be applied to a
track or Output because these are not sources.

Preset

Save the current parameter values for later use. To use later, just click the drop-
down menu for selection. Preset folder: crop

Parameters

+ Center automatically computes the crop values to remove artificial black bars
that have been added to the source to make it match your Video Mode. For
example, if you put an image with a 3:2 aspect ratio into a 16:9 project, it will be
padded with black on the left and right so the whole image is displayed without
the distortion of stretching. Turning on Center removes the black bars by
removing some of the image from the top and bottom.

» Center bias only works when Center is checked. Instead of removing the same
number of pixels from opposite edges, this is a convenient way to adjust the
center or balance of the cropping to give control over the framing or region of
interest/focus.

« Top removes rows of pixels from the top edge.

e Bottom removes rows of pixels from the bottom edge.

¢ Left removed columns of pixels from the left edge.

¢ Right removes columns of pixels from the right edge.

Notes

The values are in pixel units in terms of the current Video Mode, not the source
resolution that may change depending upon whether a proxy is being used.
Therefore, to convert the values from source to video resolution use the equations:


https://forum.shotcut.org/t/video-mode/12790
https://forum.shotcut.org/

e [OpP/BbOtioMm = source-top / source-neignt * mode-neignt
o Left/Right = source-left / source-width * mode-width

Now, since these values must be rounded to enter them without a decimal, you
may need to add 1 to one or more edges to get rid of black edges. You may find the

Video Zoom helpful to look for black edges.



I. Fisheye Video Filter

Overview

Convert fisheye video to rectilinear, and vice versa. It is based on the angular
mapping functions actually used in fisheye lens design, to get the best possible
results. It can also be used to correct the slight distortion of some wide-angle
converters, or to bend the image beyond recognition for special effects and light
shows.

Presets

Camera Resolution Type

4K CLONE1080p Wide (Action)
4K CLONE1080p Wide (Focus)
4K CLONE1080p Wide (Linear)

4K CLONE720p Medium (Focus)
4K CLONE720p Medium (Linear)
HERO3 1080 Wide (Focus)
HERO4 1080 Medium (Action)
HERO4 1080 Medium (Focus)
HERO4 1080 Medium (Linear)
HERO4 1080 SuperView (Action)
HERO4 1080 SuperView (Focus)
HERO4 1080 SuperView (Linear)
HERO4 1080 Wide (Action)
HERO4 1080 Wide (Focus)
HERO4 1080 Wide (Linear)

HERO4 1440 4:3  Wide (Action)
HERO4 1440 4:3  Wide (Focus)
HERO4 1440 4:3  Wide (Linear)

HERO4 1440 Wide (Action)
HERO4 1440 Wide (Focus)
HERO4 1440 Wide (Linear)
HERO5 1080 SuperView (Linear)
HERO5 1080 Wide (Linear)

+ Save current settings as a preset
- Delete selected preset

Stored presets location: ~shocut\presets\freidr.defish@r
Settings - App Data Directory — Show

Fisheye


https://en.wikipedia.org/wiki/Fisheye_lens#Mapping_function
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Selection: Add or remove fisheye effect.

Focal ratio

The amount of lens distortion
Default setting is o.500
Range: 0.000 - 1.000

Quality (Resample)

Option

Nearest neighbor
Bilinear

Bicubic smooth
Bicubic sharp
Spline 4x4
Spline 6x6
Lanczos 16x16

Lens

Select a lens distortion that best matches your camera.

Option Fisheye mapping function

Equidistant  Linear-scaled
Ortographic  Orthogonal
Equiarea Equal-area
StereogrphaicPanoramic

e Non-Linear Scale: The image will be stretched/squished to fix camera scaling
between 4:3 and 16:9. Like used in GoPro’s superview.

o Use negative values for up-scaled videos

o Use positive values for down-scaled videos

Scale

Preset Scale methods.
Lock pixels at specific locations.

Presets:

e Scale to Fill

+ Keep Center Scale
e Scale to Fit

e Manual Scale



Y - Separate Y Scale -0.49 to 05.0
Crop - Remove distorted edges

Aspect
Pixel aspect ratio
Presets:

¢ Square Pixel (Default)
e PALDV 1.067

e NTSC DV 0.8889

e HDV 1.333

¢ Manual Aspect

Tips

« this filter is very CPU intensive on high resolution videos so using Preview

Scaling will have a massive impact allowing realtime playback even for 4K
sources.

¢ See also Lens Correction which supports keyframes unlike this filter.


https://forum.shotcut.org/t/preview-scaling/15650
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I. GPS Text Video Filter

Introduction

The GPS Text filter allows you to add useful GPS related data (such as speed,
altitude or distance) on top of and in sync with your video. It is available since
version 21.08.

29.3 kn
1084 kim (@

Note: you need to record your GPS track with a device (phone, smartwatch, bike
computer or dedicated GPS tracker) AND export your track to a .gpx or .tcx file. If
you record using an action camera that has GPS (like GoPro), you need to extract
the data to a separate file (there are online and offline tools for this.

Update: Shotcut 22.09 now supports .gpx extraction itself:

Properties panel —» (hamburger menu) - Export GPX.

Tip: hover your mouse over filter elements for some extra explanations

Usage
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1. Add the GPS Text filter on a clip in the timeline.

2. Click the Open file button in the filter panel to load the .gpx or .tcx file.

Open file

3. Use the GPS offset row to sync the GPS track time to the video time (check out
some hints below; if you're extremely lucky they are already in sync and you can
skip this step).

GPS offset > days: O h: 3 m: 3 s 14

4. Edit the filter text panel with any keywords from the available list. You can also
format the text to your liking just like Text: Simple filter.
Tip: hover your mouse over the list for extra keyword arguments.

Text Sp i'h

6. If needed, change the more advanced options in the filter panel. There is also
basic keyframing support for in/out and text position/size.

7. Export

Syncing workflow details and tips

TLDR: watch out for timezones; buttons have tooltips; remember to film a clock
from time to time for easy sync later (but do remember its timezone);
Also: scrollwheel to add/substract a few seconds for quick corrections.

At the very bottom of the filter panel (you'll probably need to scroll to see it) there
are 2 important date-time notes: the Video’s and the GPS'’s start times (Note: they
will be first updated after you load a GPS file). The GPS time is always in the UTC
timezone, but the Video start time is read from the file’s Creation Time metadata
field, which is currently very not-standardized across devices, and so, it might be in
your local timezone or not, it might be set to the start or end of the video or it might
just be a very random time if your device loses power and doesn’t sync it at startup.
The important thing to remember here is that no matter when you shot your video,
this is what Shotcut sees as your file’s start time (converted to UTC, so the same
as GPS time) therefore this is what will be used for offseting the GPS track. You
can use the #file_datetime_now# keyword to see it live in the output.


https://forum.shotcut.org/uploads/default/original/3X/f/2/f2501df1529661b3f9491af4ddfa00d02d099d1d.png

Sync buttons

Syncing the GPS track to the video file will be the most annoying part of using this
filter. To the right of the sync text areas there are a number of 4 buttons that will
probably cover 95% of all use cases thus avoiding any need for doing time math.
This will be frustrating at first but you will notice that there is a pattern to follow and
it will be the same everytime for each device.

Note: if your device doesn’t support auto time sync over the internet you will most
likely still need to match a few seconds (maybe even minutes) to the real time in
addition to one of the helper buttons. | recommend you take a photo of a (digital)
clock and check the photo’s properties for the time.

I'll go over the buttons from left to right, first being the clock one, and last the
“Pause” one.

GPS offset = ™| days:

Sync button 1: Timezone removal (GoPros)

Probably the most used button as | expect most shots that would work with a GPS
overlay would come from an action camera and GoPro is doing this as well.
Why? If you can’t set the timezone in the camera clock settings, it will probably be
wrongly set to UTC (well it's wrong unless you live in UTC area) so the file will
match the GPS track a few hours ahead or behind.

Devices? GoPros, some DSLRs/Mirrorless, most non professional grade video
cameras will have this issue. This is an easy one to find as it will remain constant
for all files.

Sync button 2: Video duration removal (Android)

Why? Some devices (cough android phones cough) decided it's a good idea to set
the video’s creation time after you finish recording. So if you record a 15 minute
video starting at 12:00, it will store the time as 12:15.

Devices? Android smartphones are the only ones that do this as far as | know.

It's a big pain as you can’t copy paste the filter to multiple clips, each clip has to be
individually updated as it will most likely have a different duration.

Sync button 3: Sync beginings (tests & dashcam)

If you just want to see the filter work just press this button and it will immediately
sync the 2 times no matter how far apart they are.

When? This is good for testing random files or if you don’t want to bother with
times and just remember to start recording video and GPS at the same time.
Devices? My dashcam resets the time every time it loses power for more than a



few hours. | gave up trying to set it correctly so | just start the GPS track and
immediately hit start record.

Sync button 4: Sync to now

When? If you want a very precise sync that doesn’t need time keeping at all, this is
the way: just start filming before the GPS device and make sure to record the
moment the GPS device gets the first fix and starts recording. Move the playhead
to that exact moment in the video, press the button and you're done.

You can also make a sign or cover your camera with your palm as a mark point.

If you clap to sync audio to video this workflow will be very familiar.

Sync extra: record a precise clock

Your phone automatically syncs pretty precisely all the time. You can just record it's
clock (make sure you can see the seconds) at any moment and manually match
the #gps_datetime_now# time to what you see in the video. This is my preferred
method as It's simply the easiest and you don’t need to preserve file metadata
(don’t forget about your clock’s timezone though).

GXD11765 - tima symcMP4

fpead: 46.9km/h
Distance: 115353m
Qltitude: 596me

GPS time; 0:18 (UTC)
Video time: 18:52:33 (GMT +3)

More info

Here you can read the entire list of arguments and extra keywords. Most numeric
fields accept obvious arguments (for example the speed or distance can be

converted to imperial by typing “mi”, “mile”, “mi/h” between the # ... # (example:
#gps_speed mi# ), time accepts standard %H:%M, temperature “F” and “K”, etc).
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I. Gradient Map Video Filter

The Gradient Map Video Filter was added in Shotcut 25.01.03

The Gradient Map Video Filter maps the colors of an image to a gradient according
to their intensity. The controls for the filter include a configuration for the gradient.
The colors on the left of the gradient are applied to dark colors. The colors on the
right of the gradient are applied to bright colors.

The filter includes presets for Thermal and Sepia gradients.
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I. HSL Primaries Video Filter

The HSL Primaries Video Filter was added in Shotcut 25.01.03

The HSL Primaries Video Filter operates in the HSL color model. It can adjust the
Hue, Saturation or Lightness of the 6 primary colors in the image. The hue can be
shifted +/- 180 degrees. The saturation and lightness can be scaled by a
configurable factor.

The Overlap parameter controls how much an adjustment can fade into the
adjacent color channels. This can be helpful to avoid banding when the image has
a gradient that fades from one color to another.

This example shows an image with a blue car and no adjustments to the filter:

If, instead, the lightness is scaled down, the car appears a darker blue:
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See also:
HuelLightness/Saturation Video Filter
HSL Range Video Filter
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I. HSL Range Video Filter

The HSL Range Video Filter was added in Shotcut 25.01.03

The HSL Primaries Video Filter operates in the HSL color model. It can adjust the
Hue, Saturation and Lightness of the colors in a specified color range. The hue can
be shifted +/- 180 degrees. The saturation and lightness can be scaled by a
configurable factor.

The blend parameter controls how much an adjustment can fade into the adjacent
color colors outside the range. This can be helpful to avoid banding when the
image has a gradient that fades from one color to another.

This example shows an image with a blue car and no adjustments to the filter:

In this example, the color range was configured to include all the blue/cyan colors
that make up the car. Then, the hue was shifted and the saturation increased to
make the car appear bright red:

In the image above, you can see a color bar the displays the colors that are
included in the range to be adjusted:

In this example, the color range was set to everything except blue and the
saturation was scaled to 0% to make the background black and white:
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See also:

Huel/Lightness/Saturation Video Filter
HSL Primaries Video Filter
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Il Lut 30) video Filter

Adjust the intensity of the LUT (3D)
filter

You can reduce the intensity of a LUT (or any other filter) using filters in this order

1. Mask: Simple Shape with Width and Height = 100%

2. Opacity (here is where you adjust intensity, including with keyframes)
3. LUT (3D) (or other filters)

4. Mask: Apply



https://forum.shotcut.org/
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I. Mask: Chroma Key Video Filter

The video filters beginning with “Mask:” let you select a portion of the image or
video in which to apply other video filters. There are a few different ones, and this
one lets you choose the portion of the image by a color and a distance from the
chosen color.

lip: Mask other video filters by adding filters after this one followed by
Mask: Apply

See the “Tip” above. To really make this work you add additional video filters that
affect the selected color range followed by the Mask: Apply video filter, which
combines every thing in between. So, the order of the filters is very important. For
example, for secondary color correction, you might put a Color Grading, Levels,
or HuelLightness/Saturation video filter in between them:

lor Grading

Mask: Apply

+ Key color lets you choose the color to be affected. Click the dropper icon next
to the color box to pick a color from the video. The dropper also lets you drag
select a small rectangle of the image as well to get an average color for the
rectangle to avoid picking a single stray pixel.

+ Distance helps you choose the range near Key color like a threshold.

See also Mask: Apply


https://forum.shotcut.org/t/mask-apply/12859
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I. Mirror Video Filter

A Mirror Video Filter, is a digital effect that flips a video horizontally.
If you've ever wondered why the letters on your t-shirt appear backwards in a

selfie, this is why. Some phones let you choose whether to keep the mirrored
image or correct it in the camera settings.

daniam1123__2025-04-20T181613.000Z.mpH

.mirror|

) Misror
N
- [JReflect
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I. Motion Tracker Video Filter

Playlist  Filters  Properties

This filter is required to use motion tracking in other filters. It only does the preview
and analysis and is not intended to include effects but rather drive other video
filters...

See the Load Keyframes from Motion Tracker button in the following video
filters:

e Corner Pin

¢ Crop: Rectangle

¢ GPS Text

¢ Mask: Simple Shape

e Size, Position & Rotate
* Size & Position (GPU)
¢ Spot Remover

¢ Text: Rich

¢ Text: Simple

e Timer

Notes

o This filter first appeared in version 23.05.14.

* The Motion Tracker can be on a different clip than the clip with the above filters.

¢ The dialog only shows Motion Trackers that have successfully completed
analysis.

¢ Click Reset in the dialog to remove the keyframes added by motion tracker and
restore the state of these parameters to before motion tracking.

¢ Clicking Apply in the dialog more than once automatically resets the affected
parameters before adding new keyframes; so, you do not need to reset manually
between changes.
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e You can edit the added keyframes, but if you reapply the motion tracker your
changes are discarded.

¢ To change the initial position of something after applying tracking you should
Reset, make changes, and then Apply again.

+ Disable the Motion Tracker when your changes and its analysis are done (or
turn off its preview). | do not recommend removing this filter when you are done
loading keyframes because if you need to make an adjustment, this filter must
still be available to list it in the dialog and get its tracking data.



I. Reduce Noise: Wavelet Video Filter

This filter is available since version 20.06.
About wavelet denoising

Wavelet denoisers are excellent when decent-bitrate footage comes from a decent-
guality camera, and the only real problem with the footage is high ISO noise or high
thermal noise or photon shot noise. Wavelets are great at targeting inconsistency at
the pixel level, as opposed to algorithms that average patches or regions, and end
up smearing pixels in the process. A nice side effect of this precision is that
gradients (especially skin tones and out-of-focus areas) are rendered extremely
smoothly, which is a benefit that cannot be overstated. My primary use for this filter
is to clean up low-light video. It usually increases the level of realism in the
process.

That said, wavelets are not the best tool for making VHS tapes or 19th-generation
MPEG-2 videos look great. Wavelets will usually perceive blocky borders as
intentional detail and preserve them rather than eliminate them, hence the need for
a decent-quality start point. Use NLMeans or HQDN3D for restoration purposes.

Demonstration using the attached images

Below are attached two high-1SO images to give everyone a common reference
point. Film.jpg was shot at ISO 8000, and Dashboard.jpg is a frame grab from an
ISO 6400 video, both from Micro Four Thirds cameras.

Using a 2160p UHD video mode, add the following filters to Film.jpg and compare
them one at a time to the original:

¢ “Reduce Noise: Wavelet” at Heavy preset
¢ “Reduce Noise: HQDN3D” at 70% spatial
¢ “Reduce Noise: Smart Blur” ... any

Then using the same UHD video mode, compare Dashboard.jpg with these filters:

e “Reduce Noise: Wavelet” at Medium preset
¢ “Reduce Noise: HQDN3D” at 25% spatial
¢ “Reduce Noise: Smart Blur” ... any

Naturally, this is best observed with a full-screen external monitor.
Observations to help choose between HQDN3D and Wavelet

e On the Film image, Wavelet converted the noisy background into liquid gold.
Very smooth gradients at the left and right edges. When HQDN3D tried the
same thing at 70% strength, it got very close, but there were still some banding
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and macroblocking artefacts inside the gradients. This becomes more evident
during video playback when the bands wiggle like worms.

On the Dashboard image, HQDN3D had to be dialed back to 25% because
more strength would cause the skin tones to look like a plastic doll. Being scaled
back this far (compared to 70% in the Film image) left many more bands,
macroblocks, and color patches on the dashboard compared to Wavelet. Skin
tones frequently prevent HQDN3D from being used at a higher strength.

On both images, HQDN3D shifts the image down and right by a noticeable
amount (several pixels) compared to the original, which makes me very uneasy.
When applied to video, the shift is not constant either, so the video shakes. |
don’t know if this is the usual temporal ghosting issue or if this is an
implementation issue. Maybe @Paul B Mahol has some ideas. It also happens
with command-line FFmpeg. Meanwhile, Wavelet “just works” every single time.

The main downside of Wavelet is that it takes 2.75 times longer to process than
HQDNS3D (on my hardware at least). For longer clips, | sometimes process them
separately, then bring them back into the main Shotcut project as DNxHR
intermediates.

I could not find any combination of settings that made Smart Blur even remotely
match the quality of HQDN3D and Wavelet. Smart Blur produced blocky
gradients and blurry edges by comparison. As for export speed, it was only 30%
faster than HQDN3D on a 16-core server, and identical in speed on a 4-core
laptop. | struggle to find a use case for Smart Blur when much higher-quality
options are available.

Why bother with another denoiser filter when Shotcut already has two:

HQDNS3D and Wavelet use different techniques to serve different needs for different

audiences. For video with significant motion, I've found that HQDN3D and Wavelet
produce results that are visually similar. My eye can’t track the finer details during
motion, so I'll sometimes take the speed benefits of HQDN3D. But for a slow
dramatic shot of a fancy restaurant interior in low light where the audience wants to
see every detail of fine gold without artefacts... Wavelet scores a clear win. So this
duo of filters satisfies the “Fast” crowd (HQDN3D) and the “Quality” crowd
(Wavelet). Since my audience wants “Quality” 95% of the time, | made this
interface to get it. Whether it’s the right choice for you depends on your use case.

Happy low-light filming!


https://forum.shotcut.org/u/paul_b_mahol
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I. Reframe Output Video Filter

Reframe or reframing is a way to crop a video or editing project in order to export it
to a different aspect ratio. For example, you made a video project in 16:9 aspect
ratio landscape/horizontal orientation but now want to make a 9:16 portrait/vertical
orientation video for social media. Other forms of cropping are used primarily within
a composition to remove bad edges (Crop: Source), zoom in to fill the frame (Size,
Position & Rotate), add colored borders (Crop: Rectangle), or clip an overlay (Crop:
Rectangle).

Reframe was added in version 24.09, but it is not available if GPU Effects is turned
on.

One can only add the Reframe video filter to Timeline > Output. However, for
convenience there is also a Reframe button in Export > Video

Export

Presets . .
From Timeline -

Custom Use hardware encoder Configu
10bit prores
test abr aac

test vbr aac Video = Codec Audio = Other

Format mp4 -

Stock
AV1 WebM
Default Reframe
GIF Animation
H.264 Baseline Profile
H.264 High Profile Aspect ratio
H.264 Main Profile
HEVC Main Profile Frames/sec

-

Resolution X

-
-,
-

(Resample is typically used to change the resolution without changing aspect ratio.
But one can use it and change aspect ratio in order to intentionally add black bars.
For example, you compose a very wide film aspect ratio of 2.4:1 but want to deliver
it as 16:9—letterboxing.)

Clicking Reframe adds the filter to Output or switches the user interface to it:

You can drag this rectangle control around and resize it to even dimensions only
(for codec and pixel format compatibility), but you cannot push any part of the
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rectangle outside of the frame.

It supports keyframes and motion tracking. However, if you change the size, only
the size at the beginning is used. Here, | tracked the white horse in the first clip
only and then re-centered it.

There are presets for 9:16 (defaults), 16:9, 4:3, and Square.

You can save the Reframe filter on your project and simply disable it when you
want to export without it. You can have multiple Reframe filters and the first enabled
one is used on export.
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I. Sharpen Video Filter

Preset

Amount

Size

The freiOr plugin description says, “Unsharp masking (port from Mplayer).”

The mplayer man page says it does gaussian blur or a sharpen using an unsharp
mask routine.

The underlying plugin code range is [-1.5, 3.5] where 0 is the switching point
between blur and sharpen. Thus, 50% in Shotcut converts to 1.0 in the plugin code,
and the switch point where there is no change is 30% in Shotcut.

See also https:/len.wikipedia.org/wiki/Unsharp_masking

The Size parameter controls the amount of blur just like nearly all blur filters have
as a parameter. Sharpening still creates a blur, but it uses this as a mask to sort of
subtract from the original. This also explains why it can also be used to blur and
why many tools call this function “unsharp” or “unsharp mask.” However, | do not
like to call it that in Shotcut because it is confusing and deceptive for non-advanced
users who are generally looking to increase sharpness (while also not limiting it to
that).


https://www.mltframework.org/plugins/FilterFrei0r-sharpness/
https://linux.die.net/man/1/mplayer
https://github.com/dyne/frei0r/blob/master/src/filter/sharpness/sharpness.c
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https://forum.shotcut.org/

I. Sketch Video Filter

A sketch effect is a digital transformation that makes a image look like a hand
drawing. It can mimic different artistic styles, such as pencil, ink, charcoal, or

crayon.
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I. Size, Position & Rotate Video Filter

Location: Filters > Video > Size, Position & Rotate

=~ L - : H C
=] A H OC :
OpenFile  Open Other, Save Undo = ‘roperties  Recent  Playlist  Timeline Keyframes History

Filters :
Default Shotcut Installation: This filter will be located in the Favorite tab.
This Favorte can be removed/added by clicking on the * symbol.

This filter is used to manipulate the size and placement of a video/image in your
video. This filter can also use Keyframes.

Size Modes:

o Fit - Will not enlarge image/video in the Rectangle Control, yet allows image to
be scaled down.

« Fill - Fits any imagel/video vertically to the Video Mode. Constrains the rectangle
control to the aspect ratio of the original source

 Distort - Allows resizing to the Rectangle Control, overriding Aspect Ratio of
original source

Horizontal fit:

e Left - Aligns to the left side of Rectangle Control
o Center - Aligns to the center of Rectangle Control
e Right - Aligns to the right of Rectangle Control

Vertical fit:

¢ Top - Aligns to the top of Rectangle Control
« Middle - Aligns to the middle of Rectangle Control
e Bottom - Aligns to the bottom of Rectangle Control

The Rectangle Control is the box that surrounds the image/video allowing
placement and size manipulation. In this rectangle you'll see the Position Handle
(white/gray dot) that you can move the image/video to a desired location.

The filter can be deselected by unchecking the box, yet all of the changes remain
there.

To remove the filter use the - sign.
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shotcut-logo-640x640.png

Shotcut

Position Handles
The position handles in the corners allow the rectangle to be scaled proportionally.

If the Size mode is “Fit” or “Distort”, additional position handles are displayed on the
top, bottom, left, and right. Those position handles can be used to change the
shape of the rectangle. The top, bottom, left, and right handles are not available
when the Size mode is “Fill” because the aspect ratio of the rectangle is enforced.

_1080p_60fps_nermalmpd

Snapping
When rotating, the rotation will snap to 0, 90, 180, and 270 degrees. Additionally, if
a grid is enabled on the preview window, the position handles will snap to the grid.

To disable snapping, hold the Alt key while rotating or moving the position handles.
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I. Stabilize

Stabilization reduces or eliminates unwanted camera shake, creating a smoother
and more professional-looking video. This is particularly important for footage shot
handheld, in motion, or in windy conditions. Without stabilization, shaky videos can
be distracting, disorienting, and even cause dizziness for viewers.

The Shotcut filter uses the open source library GitHub - georgmartius/vid.stab:
Video stabilization library

Here is how its Ul looks initially

Analyze Options
Shakiness

Accuracy

Analyze  Click Analyze to use this Filter.

Filter Options
Zoom

Smoothing

Stabilization File: —

You must first analyze before the filter affects the video. Clicking Analyze creates
an analysis job in Jobs. You will be prompted to save a .stab file, which stores the
analysis data. You are not prompted to save a file when you have made a project
folder because it automatically generates the file in the project folder. When the job
completes successfully it looks something like this:

Analyze Options

Shakiness
Accuracy
Analyze  Analysis complete.

Filter Options

Zoom

Smoothing

Stabilization File: 15.stab

Notice it says “Analysis complete” next to the button and reports the file name.

Parameters

@jupiter wrote in Stabilization Settings, Descriptions, and Tendencies
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After rendering a video project countless times with low & high settings of each
scale, then closely studying the results, this is what | believe each setting does. The
higher the setting, the more it does what is described.

+ Shakiness seems to average out the frame movements instead of each frame
migrating too much compared to the previous/next frame. Max recommended.

e Accuracy seems to prefer keeping the main point-of-reference figure stabilized
instead of the moving background (this was for my case of a moving selfie
camera; not sure what happens with a stationary camera and moving objects; in
a video of walking around filming a city, this setting didn’t make any difference). |
found Accuracy to be more effective at stabilizing the video than Shakiness, tho
there seemed no downside to maximizing both.

e Zoom is the relative size of the output frame compared to the input frame.
If the whole input frame matters, | wouldn'’t set it above 0%. And if you do want
to zoom in, I'd rather do it with Smoothing.

» Smoothing is how much the frames are allowed to move around from
center to stabilize the image (this can be seen when Zoom is negative). It also
zooms in, which I guess is to hide the shifting frame borders. Without allowing
some Smoothing, Stabilize isn’'t able to do its job. | suggest between 10 to 30,
depending how tolerant you are if the moving original border becomes visible in
your output. If you prefer to not see any corrections along the edge and want to
keep almost the entire outer frame, then set Zoom=0 and Smoothing to less
than 5, but don’t expect much stabilization.

By setting the Zoom out the maximum of -50% and the smoothness around 30, |
was able to get a good perspective of how hard its working and what it's doing. |
suggest max shakiness, max accuracy, zoom around 0%, and adjust your
smoothness for how much you want the video to be stabilized.

To compare the scale of Shakiness vs Accuracy, | rendered the same video 4 times
with low and high settings for each (low-low, high-low, low-high, high-high) then
made a single video with each version in its own video track and displaying them in
the 4 corners using the Size and Position filter (like 4 Picture-in-Pictures). Then
Render/Export the whole project to have them play smoothly side-by-side and
analyze the movements frame-by-frame. | also took the same approach with Zoom
and Smoothing to determine their effects and preferred settings.

In my very dynamic sports video with a GoPro on a selfie stick, the Stabilize feature
helped tremendously, tho the algorithm still needs improvement. Big stabilization
movements seem to correct in sets of 2 frames instead of every frame (or the
average of many frames) across the sample, resulting in jitteriness. Lossy vs
Lossless didn’t seem to correct this, nor did any combination of Stabilization
settings.

Stabilize/Analyzing filter tendencies:

e When exporting the video, the stabilization filter won’t apply to the output if the
frame rate or video size is changed.



When Stabilizing (or any other filter) make sure you've properly selected what
you want it applied to. Videos in the Player, Playlist, and Timeline are 3 different
instances, and are not connected. To apply to the other instances, you must
update or add the video to them. When Exporting, you also select From which
source at the top of the tile.

Player and Playlist videos only analyze the portion selected. If its in-point/out-
points are ever expanded (in the Player or Timeline), the new sections won’d be
stabilized.

Timeline clips analyze the entire source video, not just the portion that's
selected. If you only need a small clip of a long source video, it's much quicker
to analyze a portion in the Player/Playlist, then add it and further trim it down in
the Timeline.

The Stabilization filter can only be applied to individual clips, not the entire track
or project. To affect more than just a single clip, either apply stabilization before
you chop a source video into many pieces, or render your tracks or final project
into an output file with minimum compression, then start a new project with that
output file as your source and apply your stabilization and other global
processing as needed.

If after stabilizing, you see little artifacts along the edges, this is a byproduct of it
being stabilized. If you set your Zoom to a negative value with a little bit of
Smoothing, you can see what's happening. Read about Zooming and Smoothing
above for a solution.



I. Subtitle Burn-In Video Filter

The Subtitles Burn-In Filter was added in Shotcut 24.08

The Subtitle Burn-In Filter can overlay subtitles that have been authored in the
Subtitles Panel. The filter can only be added to the Timeline Output.

After you add the Subtitle Burn-In Filter to the Timeline Output, select the subitle
track name from the Subtitle Panel that you want to overlay.

The subtitle overlay text can be configured similar to the Simple:Text filter -
including the preview window controls for size and position.
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Text: Rich Video Filter

Introduction

The Rich Text filter lets you format text (more flexible than Text: Simple) and
automatically wraps lines within the rectangle (unlike Text: Simple). To get started
after adding the filter simply enter the text in the rectangle that appears on top of
the video preview area. The text and rectangle are only editable when the play
head is over the selected clip when using the Timeline. Then, format the text using
the floating toolbar along the top of the rectangle. First, you must select some text
as shown in the screenshot above.

Toolbar

Each icon on the toolbar has a tool tip when you hover your mouse over it for one
second:

Opens a menu with less commonly used functions explained below.

'| Text size

Text color
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Decrease Indent

Insert Indent

> a4

So, you can collapse it:

3

Expand Toolbar

You can right-click the selected text to open a menu of things to do with editing the
text:

Koal=

Undo
Redo

Sometimes, you want to get the toolbar out of the way of your work.

And click again to restore it.

Cut

Copy

Paste

Paste Text Only
Delete

Clear

Select All

These are explained below.

Toolbar Menu

File Open...
Edit Save As...

Select All

Insert Table

¢ Use File > Open... to open a file you created with Save As.... The text you
enter is saved inside of the project automatically, but maybe you want to save it
to use in another clip or project.

o Use File > Save As... to save it as rich text in a subset of the older HTML 4
and CSS standards or as plain text in a .txt file. Most people should not


https://doc.qt.io/qt-5/richtext-html-subset.html
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attempt to write the HTML to be included by this filter. This is not a full browser
engine.

o Edit

o Undo

o Redo

o Cut - Copy the selected text to the system clipboard and remove it.

o Copy - Copy the selected text to the clipboard.

o Paste - Paste text (with formatting if available) from the clipboard.

o Paste Text Only is a special version of paste that does not include formatting
information. If you have copied text from a word processor or web page,
sometimes the formatting does not paste nicely into Shotcut, or you simply do
not care about the original formatting.

o Select All

+ Insert Table You can even insert a table with or without lines. This can be useful
for making columns of text, but the formatting of the table such as line style,
padding, and cell background color is not available.

Rows

Columns

Barder

Cancel

Parameters

¢ Preset contains a number of size and animation presents. You can also save

your own as well as remove one you saved.
Lower Third

Scroll Completely Up

Scroll Down

Scroll Left

Scroll Right

Scroll Up

Slide In From Bottom

Slide In From Left

Slide In From Right

Slide In From Top

Slide Out Bottom

Slide Out Left

Slide Out Right

Slide Out Top

Slow Move Right

Slow Move Up
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Position

Background Size - You can change the size of the text rectangle and move it
using either these numeric fields or by dragging the handles of the rectangle on
the video preview.

Text size is not editable. These are handy for your reference, and you can
select the values to copy them to the clipboard.

Background color - You can change the background color of the rectangle as
well as make it translucent (change Alpha or Opacity inside the color dialog).
Overflow controls what happens when there is more text than fits into the
rectangle.

Automatic

Visible - The text continues on below the rectangle.

Hidden - The text outside of the rectangle is clipped.

Load Keyframes from Motion Tracker applies the motion tracking data to the
rectangle position and optionally size as well.



I. Text: Simple Video Filter

Introduction

The Text: Simple filter in Shotcut lets you overlay dynamic text onto your video.
This text can be customized using keywords that are replaced with specific
information about the clip or system.

Keywords

+ Keywords are enclosed in hash symbols (#). For example, #timecode#
represents the frame’s timecode.

e Supported keywords:

o #timecode# Or #smpte_df# . SMPTE drop-frame timecode of the frame.

o #smpte_ndf# : SMPTE non-drop-frame timecode of the frame.

o #frame# . Frame number of the frame.

o #filedate#: Modification date of the file (GMT).

o #localfiledate# : Modification date of the file (adjusted for local time zone).

o #localtime# : Current system date and time.

o #resource# . Full file name with path of the source file.

o #filename# : File name without the path.

o #basename# : File name without the extension.

o #createdate# : Creation date of the source file. Set in the playlist clip, otherwise
defaults to file modification date.

o #meta.<field>#: Accesses metadata properties for file based clips.

Formatting Time-based Keywords

Tinwe-basecikeyvvords (#createdate#, #filedate# , #localfiledate#, and
#localtime# ) can be formatted using the strftime function.

Add the desired strftime format string after the keyword, separated by a non- #
delimiter.

#localtime %I:%M:%S %p# displays the time in 12-hour format with AM/PM.

Refer to the documentation for format specifiers.

o

(o]

Using Metadata Properties

o Use #neta.<field># to include properties from the “Properties > Metadata”
section.

o Example

O #meta.media.0.codec.frame_rate# fps

o displays the frame rate followed by “fps”


https://man7.org/linux/man-pages/man3/strftime.3.html
https://forum.shotcut.org/

The best way to see what metadata properties are available for a clip is to open the
project file (.mlt) in a text editor and look for the section that applies to that clip.
Here is an example section:

<chain id="chain0" out="00:10:34.520">

<property name="1length">00:10:34.560</property>

<property name="eof">pause</property>

<property name="resource">bbb_sunflower_1080p_60fps_normal.mp4</property>
<property name="mlt_service">avformat-novalidate</property>

<property name="meta.media.nb_streams">3</property>

<property name="meta.media.0.stream.type">video</property>

<property name="meta.media.0.stream.frame_rate">60</property>

<property name="meta.media.0.stream.sample_aspect_ratio">0</property>

<property name="meta.media.0.codec.width">1920</property>

<property name="meta.media.0.codec.height">1080</property>

<property name="meta.media.0.codec.rotate">0</property>

<property name="meta.media.0.codec.pix_fmt">yuv420p</property>

<property name="meta.media.0.codec.sample_aspect_ratio">1</property>

<property name="meta.media.0.codec.colorspace">709</property>

<property name="meta.media.0.codec.name">h264</property>

<property name="meta.media.0.codec.long_name">H.264 / AVC / MPEG-4 AVC / MPEG-4
<property name="meta.media.0.codec.bit_rate">4001453</property>

<property name="meta.attr.0.stream.creation_time.markup">2013-12-16T17:59:32.00
<property name="meta.attr.0.stream.handler_name.markup">GPAC IS0 Video Handler<
<property name="meta.attr.0.stream.vendor_id.markup">[0]1[0][0][0]</property>
<property name="meta.media.l.stream.type">audio</property>

<property name="meta.media.l.codec.sample_fmt">fltp</property>

<property name="meta.media.l.codec.sample_rate">48000</property>

<property name="meta.media.l.codec.channels">2</property>

<property name="meta.media.l.codec.name">mp3float</property>

<property name="meta.media.l.codec.long_name">MP3 (MPEG audio layer 3)</propert
<property name="meta.media.l.codec.bit_rate">160000</property>

This clip has a property called “meta.attr.composer.markup”. So, if we put
“#meta.attr.composer.markup#” in the text filter, it displays “Sacha Goedegebure”.

Additional Notes

Escape a literal # character with \#.



I. White Balance Video Filter

The White Balance filter works well by following these steps:
Restore “Neutral color” and “Color temperature” to their defaults (6500 degrees).

Click on the eyedropper and position the crosshairs over an object which is
supposed to be white, e.g. a white card, white shirt, etc. and click.


https://forum.shotcut.org/

I. Downmix Audio Filter

The Downmix audio filter converts multichannel source audio to mono audio. This
filter is simple in its operation. It adds all input channels together and sends the
same signal out to all output channels. It is not aware of center, surround sound, lor
frequency channels. The most common use case is to mix stereo sources to mono
to create two channel mono audio.


https://forum.shotcut.org/

I. Fade In Audio Filter

The Fade In Audio Filter has two parameters: duration and type.

The type parameter was added in Shotcut 25.01.03

Audio Tone
Audio

¥ Fade In Audio

Type Natural

The following waveform images illustrate each fade of a sine wave over 1 second.

Natural: A log based curve (linear in dB). This type is considered the most natural
in audio mixing and is sometimes called “Logarithmic”.

R Ea oM

S-curve: Slow at the start, fast in the middle, slow at the end

—n A

Fast-Slow: Fast at the start, then ends slow

Slow-Fast: Slow at the start, then ends fast

~

For more complex fade types, consider using the Gain / Volume Audio Filter with
custom Keyframe Types and Easing.


https://forum.shotcut.org/t/gain-volume-audio-filter/12906
https://forum.shotcut.org/t/keyframe-types-and-easing/42271
https://d2t917e3b1b2xy.cloudfront.net/original/3X/1/6/16cd38ed4d89c3a7f6dd243fea4afe5c6c2d8192.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/c/b/cbc3de625ab90e895b053d65228e54f401890c25.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/0/5/05179d1f7a36d61ae0a7bc4391c84eb7b6b39e4f.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/8/6/86b9a926212420cc412c06ba638b89043f959705.png
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I. Fade Out Audio Filter

The Fade Out Audio Filter has two parameters: duration and type.

The type parameter was added in Shotcut 25.01.03

Audio Tone

Audio
¥ Fade Out Audio

+-

Duration

Type |MNatural

The following waveform images illustrate each fade of a sine wave over 1 second.

Natural: A log based curve (linear in dB). This type is considered the most natural
in audio mixing and is sometimes called “Logarithmic”.

W

S-curve: Slow at the start, fast in the middle, slow at the end

Ao

Fast-Slow: Fast at the start, then ends slow

o

Slow-Fast: Slow at the start, then ends fast

For more complex fade types, consider using the Gain / Volume Audio Filter with
custom Keyframe Types and Easing.
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I. Noise Gate Audio Filter

This filter uses the Steve Harris LADSPA Gate plugin, whose parameters are
based on the Drawmer DS201.

This filter is used to reduce some noise like a hum or echo or to reduce cross-talk
between microphones that were targeting different sources.

Output key only

Threshold

@

@

Attack 250 ms

@

Hold 1501 ms

@

Decay 2001 ms

@

Range -80.0 dB

=

Key Filter: Low Frequency

Controls the cutoff of the low frequency filter (highpass).
Key Filter: High Frequency

Controls the cutoff of the high frequency filter (lowpass).
Output Key Only

Controls output monitor. When checked, it is the output of the key filters (so you
can check what is being gated on). Otherwise, it is the normal, gated output.
Disable the filter in Shotcut’s list of filters to achieve bypass (or trim the filter to
bound it by a time range).

Threshold

Controls the level at which the gate will open.

Attack

Controls the time the gate will take to open fully.

Hold

Controls the minimum time the gate will stay open for.
Decay

Controls the time the gate will take to close fully.

Range


http://plugin.org.uk/ladspa-swh/docs/ladspa-swh.html#tth_sEc2.45
https://www.drawmer.com/products/pro-series/ds201.php
https://forum.shotcut.org/t/trimming-filters/13212
https://forum.shotcut.org/

Controls the difference between the gate’s open and closed state.



I. Pitch Audio Filter

The Pitch filter lets you change how high or low the sound is with respect to
frequency (not loudness).

Preset v -

Octave Shift 0.000000 D@

Speed Compensation 1.000000 x

One may use this effect to disguise a voice or create a silly sounding voice. It is
very useful to use in conjunction with the Speed option in Properties, which
inherently changes the pitch. Thus, this filter can be used to correct the pitch. You
can simply copy the speed value from Properties to the Speed Compensation
parameter in the Pitch filter!

The Octave Shift parameter is a different way to represent the change in musical
form. There are 6 whole steps in music between each octave. Thus, each whole
step corresponds to increments or decrements of 0.1666. For example, to change
the pitch from A to B, set the Octave shift to 0.166666. There are twelve half-steps
(semitones) in an octave. For example, to change the pitch from A to Bb, set the
Octave Shift to 0.083333 (1/12).


https://forum.shotcut.org/

I. Stereo Enhancer Audio Filter

This filter is used to make an interesting stereo sound from a mono source - more
interesting than simply duplicating the channel, which is the default when not using
this filter. Duplicating a mono channel to stereo still sounds like mono.

Stereo Enhancer was added in version 22.03.30.

Audio
Stereo Enhancer

Preset
Source

Left Delay

Left Delay Gain
Right Delay

Right Delay Gain
Qutput Gain

The Stereo Enhancer filter is based on the FFmpeg haas filter.
The Source parameter has four choices.

» Left: The source only has mono sound coming from the left channel.

e Right: The source only has mono sound coming from the right channel.

e Middle (L+R): The source already has some stereo effects that you wish to
enhance or you do not know if the mono sound is on the left or the right channel.

¢ Side (L-R): The source has a split audio track where separate sets of sounds are
limited to each of the two channels. For example, the left audio channel has
vocals only and the right audio channel has music and sound effects only.


https://ffmpeg.org/ffmpeg-filters.html#haas
https://forum.shotcut.org/

I. Track Auto Fade Audio Filter

This filter address a problem where clicks and pops may be heard in export when
switching between clips due to discontinuities in the audio stream. A recommended
technique was to add 2-frame Fade Audio Out and Fade Audio In filters on clips.
Track Auto Fade automates that. This filter can only be placed on a track by
clicking the track header (in the left column of the Timeline) to select it.

This filter first appeared in version 23.07.29.


https://forum.shotcut.org/

I. Track Seam Audio Filter

This filter address a problem where clicks and pops may be heard in export when
switching between clips due to discontinuities in the audio stream. A recommended
technique was to add 2-frame Fade Audio Out and Fade Audio In filters on clips.
Track Seam works on a similar level but rather attempts to do a smoothing
between outgoing and incoming samples around edit points. This filter can only be
placed on a track by clicking the track header (in the left column of the Timeline) to
select it.

This filter first appeared in version 23.07.29.


https://forum.shotcut.org/

I. Declick Audio Filter

For technical reasons this appears in the Time category of the Filters chooser, but
it is an audio filter.

This first appeared in version 23.09 with the name Declick and the name in version
24.01 was changed to Declick Audio to make it more obvious.

This filter is intended to remove click, crackle, and pop artifacts in the source audio
- not from splitting clips or switching between clips on the timeline. For those
situations, see the Track Auto Fade Audio and Track Seam (recommended)
audio filters.

Here are the parameters:

Preset

Window

Threshold

Burst Fusion

e Window sets the amount of audio (number of samples in milliseconds) that will
be processed at-a-time.

o Threshold is the strength in % of impulse noise to be removed. The lower value,
the more samples will be detected as impulsive noise.

» Burst fusion is a percentage of the window - if any two samples detected as
noise are spaced less than this value, any sample between those two samples
will be also detected as noise.


https://d2t917e3b1b2xy.cloudfront.net/original/3X/7/a/7ad587144e76ba96dd35e4661c634ed62c95e782.png
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I. Speed: Forward & Reverse Time Filter

This filter is similar to Time Remap but can be easier to use.

This filter first appeared in version 23.05.14.


https://forum.shotcut.org/uploads/default/original/3X/9/b/9bcb50b00345fce27227b65deffcb531e7f18c39.jpeg
https://forum.shotcut.org/

I. Speed: Forward Only Time Filter

This filter is similar to Time Remap but can be easier to use. It does not usually

require converting the clip first unlike Time Remap and Speed: Forward &
Reverse.

iior=kE

wildlife.avi

This filter first appeared in version 23.05.14.


https://forum.shotcut.org/uploads/default/original/3X/9/b/9bcb50b00345fce27227b65deffcb531e7f18c39.jpeg
https://forum.shotcut.org/

I. Time Remayp Filter

The Time Remap filter is the first filter that allows altering the timing of the
underlying source clip. It maps clip time to output time.

Filters

TouchdownPass_8bit.avi

* Favorite| | §J Video || @ Audio @ Time x

% (@ Time Remap

See also

Speed: Forward Only Time Filter

This filter is similar to Time Remap but can be easier to use. It does not usually
require converting the clip first unlike Time Remap and Speed: Forward &
Reverse. [Screenshot Speed: Forward Only filter] This filter first appeared in
version 23.05.14.

Speed: Forward & Reverse Time Filter

This filter is similar to Time Remap but can be easier to use. [Screenshot
Speed: Forward Only filter] This filter first appeared in version 23.05.14.

Limitations

« It can only be added onto clips with NO B-frames. If you try to add it to such a
clip, it shows the Convert to Edit-friendly dialog.

¢ Aproxy clip can mask the above check for B-frames and then export may be
very slow or give bad results. However, it may also be a very convenient
workaround for the check and dialog mentioned above if you are patient and
confident to troubleshoot and fix problem areas upon export.

¢ This filter cannot be disabled.

¢ This filter does not support simple keyframes or filter trimming.

« This filter can not be applied to tracks or the timeline output.

¢ The audio waveform does not reflect any of the changes.

Usage
TL;DR


https://forum.shotcut.org/t/speed-forward-only-time-filter/40785
https://forum.shotcut.org/uploads/default/original/3X/9/b/9bcb50b00345fce27227b65deffcb531e7f18c39.jpeg
https://forum.shotcut.org/t/speed-forward-reverse-time-filter/40786
https://forum.shotcut.org/uploads/default/original/3X/9/b/9bcb50b00345fce27227b65deffcb531e7f18c39.jpeg
https://forum.shotcut.org/

Filters > Time > Time Remap > Keyframes

Hold | ctrl | to drag a keyframe vertical only or | Alt | to drag horizontal only except
on macOS these are | #  to drag vertical only or | x | to drag horizontal only.

More detail

The default setting for the Time Remap filter sets the output time equal to the clip
time which results in no change to the clip.

TouchdownPass_gbit.avi

The user can interact with the keyframes to change the time mapping. When the
slope of the line is up, time is moving forward. When the line is flat, time is frozen
(freeze frame). When the slope of the line is down, time is moving backwards
(reverse). A steeper slope moves time faster.

TouchdewnPass_Bbitavi

When the speed is faster than 1.0, multiple clip frames can map to the same output
time.

What the keyframes mean

When a video clip is added to the timeline, there is always a mapping between the
clip frames and the timeline frames. Under normal circumstances, this mapping is
created internally by Shotcut, it is invisible, and it is outside of the user’s control.


https://forum.shotcut.org/uploads/default/original/3X/8/d/8d025f180d5a1e5976fb7b097996dbdc69b1fd55.jpeg
https://forum.shotcut.org/uploads/default/original/3X/e/5/e57d11e7cc8c41afcd5487279cfba4d08531acb4.jpeg

This is how Shotcut is able to add video clips with many different frame rates to the
timeline without having to preprocess all clips to a standardized rate.

Consider what happens when 48fps GoPro footage is added to a 30fps timeline:

Source clip
from 48 Ips GoPro

Internal
frame
map

Timeline
1or 30 fps output

The gray area in the above image represents the frame mapping that Shotcut
automatically applies so that “one second” of GoPro time equates to “one second”
of 30fps timeline time. In this example, it means skipping over approximately every
third frame of the GoPro footage.

The key takeaway is that a process always exists to connect input frames to output
frames. The Time Remap filter allows the user to take manual control of that
process and override the frame mapping.

To visualize how this works, imagine that the source clip is now on the vertical axis
rather than being horizontal on the timeline. Here is an example, where the gray
area represents the keyframes in the Time Remap filter:

=3

o
8;3
L-E'
3%
o

Timeline
lor 30 fips. calpul

For each keyframe, imagine that you're standing on top of that dot looking towards
the source clip wall. Whatever source frame is directly in front of you is what you
will see at that point in time on the timeline. In essence, the keyframes create a


https://d2t917e3b1b2xy.cloudfront.net/original/3X/0/0/002b289c478c3b1b8cd13456e68e3d33938f810a.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/3/3/33cbca53fd487347cd7456983c826c93c91eb196.png

“lookup table” that allows any source frame to be referenced from any timeline
frame, enabling time effects such as slow motion, freeze frame, and even reverse.

Since the source clip is on the “vertical axis”, the length of the source clip on the
timeline is now arbitrary. The clip’s length does nothing but allocate time for the
Time Remap filter to do its work. If a video is being slowed down, then the clip will
probably need to have its Duration extended so that it's long enough to
accommodate the slower video. Similarly, if all that's needed is a quick freeze
frame, then the clip can be trimmed short.

To visualize how reverse works, consider the red arrows in the image. When
exporting Frame 6, the export engine will look at the keyframes to determine which
source frame should be selected. In this example, Frame 3 of the source is
selected. Comparing timeline Frames 5-7, we get:

Timeline 5 -> Source 4
Timeline 6 -> Source 3
Timeline 7 -> Source 4

From the viewer’s point of view, the source clip went backwards from Frames 5 to 6
because the selected source frames went from 4 to 3. But when playing Frames 6
to 7, time will appear to move forward again because the selected source frames
went from 3 to 4. And yes, creating a steep line (up or down) that skips over source
frames will look as though the source clip is sped up.

Following this logic, we also see that source frame 4 is selected for timeline frames
3, 4, and 5. When the same source frame is selected for multiple timeline frames in
a row like this, the visual effect is a freeze frame.

The | Att  and  ctrl | modifiers when dragging keyframes are extremely useful for
scrubbing to find a specific source frame without modifying the keyframe’s
placement on the timeline, or for preserving a specific source frame while changing
its placement on the timeline.

Parameters
Time
This is the output time of the current frame.

and ' + decrement or increment by one frame at a time. You can click and
hold these to repeat.

< | Sets the speed between the previous keyframe and the current frame by
adding a keyframe at the current time position if needed.

> Sets the speed between the the current frame and the next keyframe by
adding a keyframe at the current time position if needed.



Enable pitch compensation

Enable this if you want the audio pitch to remain close to the original and not
affected by speed. The quality is degraded especially for speeds less than 0.5 or
greater than 2.0.

Image mode

The Image Mode allows the user to choose between selecting the nearest frame,
or blending frames frames.

If 30fps footage is sped up to 2, it effectively becomes 60fps footage but with half

the duration of the original. In this example, the sped-up clip is twice the frame rate
of the timeline. This means two frames of source fit into the duration of one timeline
frame. The export engine has to choose what to do:

1. Choose a single source frame that is closest to the timestamp of the timeline
(nearest mode).

2. Blend multiple source frames into one mash-up frame with averaging (blend
mode).

Source at 1x
real 30fps

112106

30fps
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Quick tip: “Blend” mode could be useful for timelapse videos where the action
needs to be sped up around 8x or more. Instead of seeing people or stars or
whatever flickering between unpredictable positions on the screen, Blend mode
would average their movements and create connective trails similar to extreme
motion blur. This makes it much easier to track where people are moving and gives
a much more relaxed and artsy vibe to the video. This also means not having to do
a long-exposure photo sequence with your camera then stitch the photos into a
video later to get the same effect... instead, it can be done as a single normal
video, which can serve the dual purpose of extracting clips you care about in
normal speed, but motion blurring the rest of it for a timelapse.

Here’s why it works:

Nearest mode is the same as the frame drop-or-dupe method that the timeline has
used for years to handle frame rate mismatches. If someone puts 60fps video on a


https://forum.shotcut.org/uploads/default/original/3X/1/1/11c920a330faf7e79d3a63c28851a3ada6b4b3eb.png

30fps timeline, it drops every other frame of the 60fps video to scale it down to
30fps. It selected the “Nearest” frame to the 30fps cadence.

Extending that concept, if someone takes a 10-second clip and goes to Properties
> Speed > 5x so that it becomes a 2-second clip, Shotcut accomplishes the speed-
up by dropping (ignoring) four frames then displaying the fifth.

If the Time Remap filter is set to Nearest mode, then the usual dupe-or-drop
method described above continues to be used. For the exported frame below, |
took a 10-second countdown and did a Time Remap to 2 seconds in Nearest mode
(same as Properties > Speed > 5x) then exported:

But here is (almost) the same frame when the Time Remap filter is set to Blend
mode:

Instead of ignoring four frames and showing only the fifth, the five frames are now
averaged together. This causes a gradient in the circular swipe pattern, because
the dark bottom-left swipe was on the screen longer than the upper-left, therefore it
went darker when averaged.

The faster the speed-up, the more frames that will be blended together.


https://forum.shotcut.org/uploads/default/original/3X/3/5/35c73a51427cc3cb01fcc09423bb7cf9c64cbefa.jpeg
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I. Preset Locations: Filters

These are the locations (folders) of the filter presets that are both custom and
default filter presets you create and have saved. To find the preset folder for your
operating system, refer to the FAQ or from the main menu choose Settings > App
Data Directory > Show..., your file manager opens to the location, and open the
presets folder.

Preset locations as of Shotcut Version 24.02.29
Filter Name Language: English (United States)
n/a = Not Available

Preset Location Filter Name Type

bigshOt_eq_mask  360: Equirectangular Mask Video
bigshOt_eq_to_rect 360: Equirectangular to Rectilinear  Video
bigshOt_eq_to_stereo360: Equirectangular to StereographicVideo
bigshOt_hemi_to_eq 360: Hemispherical to EquirectangularVideo
bigshOt_rect to_eq 360: Rectilinear to Equirectangular  Video

bigshOt_stabilize _360360: Stabilize Video
bigshOt_stabilize _360360: Transform Video
n/a Alpha Channel: Adjust Video
n/a Alpha Channel: View Video
audioDance Audio Dance Visualization Video
audioLevelGraph Audio Level Visualization Video
audioLightshow Audio Light Visualization Video
audioSpectrum Audio Spectrum Visualization Video
audioWaveform Audio Waveform Visualization Video
n/a Blend Mode Video
boxblur Blur: Box Video
blur_exponential Blur: Expotential Video
blur_gaussian Blur: Glaussian Video
blur_lowpass Blur: Low Pass Video
blur_pad Blur: Pad Video
brightness Brightness Video
choppy Choppy Video
avfilter.chromahold Chroma Hold Video
freiOr.selectOr Chroma Key: Advanced Video
freiOr.bluescreenOr  Chroma Hold: Simple Video
lift_gamma_gain Color Grading Video
contrast Contrast Video
freiOr.cOrners Corner Pin Video
n/a Crop: Circle Video
cropRectangle Crop: Rectangle Video


https://shotcut.org/FAQ/#where-are-the-log-presets-database-and-settings-stored
https://shotcut.org/blog/new-release-240229/
https://forum.shotcut.org/

Preset Location

crop
deband
freiOr.distortOr
dither
elastic_scale
n/a

n/a
freiOr.defishOr
n/a
freiOr.glitchOr
freiOr.glow
gpsgraphic
gpstext
gradient

freiOr.cairoimagegrid

halftone
avfilter.hue
n/a

freiOr.keyspillmOpup

n/a

freiOr.lenscorrection

freiOr.levels

n/a

n/a
maskChromaKey
n/a
maskFromFile

maskSimpleShape

n/a
freiOr.pixelizOr
opencv.tracker
avfilter.random
nosync
noise_fast
noise_keyframes
dust

grain

oldfilm

lines

tcolor
brightnessOpacity
posterize
freiOr.hqdn3d

Filter Name

Crop: Source
Deband

Distort

Dither

Elastic Scale

Fade In Video

Fade Out Video
Fisheye

Flip

Glitch

Glow

GPS Graphic

GPS Text

Gradient

Grid

Halftone
Hue/Lightness/Saturation
Invert Colors

Key Spill: Advanced
Key Spill: Simple
Lens Correction
Levels

LUT (3D)

Mask: Apply

Mask: Chroma Key
Mask: Draw (Glaximate)
Mask: From File
Mask: Simple Shape
Mirror

Mosaic

Motion Tracker
Nervous

No Sync

Noise: Fast

Noise: Keyframes
Old Film: Dust

Old Film: Grain

Old Film: Projector
Old Film: Scratches
Old Film: Technicolor
Opacity

Posterize

Reduce Noise: HQDN3D

Type
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video



Preset Location

avfilter.smartblur
vaguedenoiser
n/a
freiOr.rgbsplitOr
freiOr.saturatOr
n/a

sepia
freiOr.sharpness
affineSizePosition
charcoal
spotRemover
n/a

richText
dynamicText
threshold

timer
avfilter.tmix

n/a

vertigo

vignette

wave
freiOr.colgate

Preset Location

Filter Name

Reduce Noise: Smart Blur
Reduce Noise: Wavelet

Reflect
RGB Shift
Saturation
Scan Lines
Sepia Tone
Sharpen

Size, Position & Rotate

Sketch

Spot Remover
Stabilize

Text: Rich
Text: Simple
Threshold
Timer

Trails

Unpremultiply Alpha

Vertigo
Vignette

Wave

White Balance

Filter Name

ambisonic-decoderAmbisonic Decoder

audioBalance
ladspa.1892
ladspa.1882
n/a
ladspa.1192
n/a
15BandEq
3BandEq
parametricEq
ladspa.1883
n/a

n/a

volume
ladspa.1890
n/a
ladspa.1913
ladspa.1891
n/a

Balance

Band Pass
Compressor

Copy Channel
Delay

Downmix
Equalizer: 15-Band

Type
Audio
Audio
Audio
Audio
Audio
Audio
Audio
Audio

Equalizer: 3-Band (Bass & Treble)Audio

Equalizer: Parametric
Expander

Fade In Audio

Fade Out Audio

Gain / Volume

High Pass

Invert

Limiter

Low Pass

Mute

Audio
Audio
Audio
Audio
Audio
Audio
Audio
Audio
Audio
Audio

Type
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video
Video



Preset Location  Filter Name Type

ladspa.1410 Noise Gate Audio
dynamic_loudness Normalize: One Pass Audio
n/a Normalize: Two Pass Audio
ladspa.1894 Notch Audio
audioPan Pan Audio
rbpitch Pitch Audio
ladspa.1216 Reverb Audio
stereoEnhance  Stereo Enhancer Audio
n/a Swap Channels Audio
Preset Location Filter Name Type
audioDeclick Declick Time
speedForwardReverseSpeed: Forward & ReverseTime
speedForward Speed: Forward Only Time

timeremap Time Remap Time



